Дано n чисел?

Информатика | 10 - 11 классы

Дано n чисел.

Замените все отрицательные числа их модулями.

Язык программирования Паскаль.

Запишите с помощью массивов.

Ответить на вопрос
Ответы (1)
Фиалка12345 18 июн. 2020 г., 01:38:33

Var a : array of integer ; i, n : integer ;

begin

write('Задайте размер массива : ') ; readln(n) ;

setlength(a, n) ;

for i : = 0 to n - 1 doreadln(a[i]) ;

writeln('Массив до обработки : ', a) ;

for i : = 0 to n - 1 do

if a[i] < ; 0 thena[i] : = abs(a[i]) ;

writeln('Массив после обработки : ', a) ;

end.

Arrrrt 22 февр. 2020 г., 22:13:18 | 10 - 11 классы

2) Опишите на русском языке или одном из языков программирования алгоритм подсчета максимального количества подряд идущих отрицательных элементов в целочисленном массиве длины 30?

2) Опишите на русском языке или одном из языков программирования алгоритм подсчета максимального количества подряд идущих отрицательных элементов в целочисленном массиве длины 30.

На Паскале АБС.

Katya43618 8 авг. 2020 г., 08:23:59 | 5 - 9 классы

Помогите решить, буду очень благодарен?

Помогите решить, буду очень благодарен.

1. Дан массив, найти произведение отрицательных элементов массива.

2. Дан массив, заменить все отрицательные элементы массива их модулями.

Dima111wsf 14 окт. 2020 г., 02:41:19 | 10 - 11 классы

Язык программирования Турбо ПаскальДан массив А из n действительных чисел : a1, …, an?

Язык программирования Турбо Паскаль

Дан массив А из n действительных чисел : a1, …, an.

Вычислить :

a1, a1 + a2, …, a1 + a2 + … + an ; Заменить все элементы массива, большие семи, числом 7.

Вычислить количество таких элементов.

Вприон 18 апр. 2020 г., 06:06:04 | 5 - 9 классы

Программирование на языке Паскаль?

Программирование на языке Паскаль.

Заставить пользователя ввести отрицательное число.

Помогите пожалуйста : ).

ANNAJHFKJHFDKV 15 июл. 2020 г., 18:23:24 | 5 - 9 классы

Даны целые числа a, b и с?

Даны целые числа a, b и с.

Написать программу подсчитывающую кол - во положительных и кол - во отрицательных чисел среди данных.

Входные данные - 2 4 - 1 выходные 2 1.

(язык программирования Паскаль АБС).

HomiTopi 15 июл. 2020 г., 09:30:41 | 5 - 9 классы

Составить программу в паскале, в которой : а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345?

Составить программу в паскале, в которой : а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345.

Б) Подсчитать и вывести отрицательные элементы массива.

O35n14w10 22 окт. 2020 г., 06:46:39 | 10 - 11 классы

Помогите сделать в паскале?

Помогите сделать в паскале!

Дан массив, содержащий 70 целых чисел.

Опишите на одном из языков программирования эффективный алгоритм, позволяющий найти и вывести наибольшую разность двух чисел, содержащихся в массиве.

Николай12281 17 окт. 2020 г., 01:16:41 | 5 - 9 классы

Даны целые числа X и Y?

Даны целые числа X и Y.

Вычислить X ^ (2 ^ Y ).

Язык программирования : Паскаль.

Fgulova999 20 сент. 2020 г., 11:57:59 | 10 - 11 классы

Дан массив чисел E = (e1, e2, ?

Дан массив чисел E = (e1, e2, .

, en) и число F.

Увеличить все отрицательные элементы массива Е на F.

Решить в паскале, расписать формулу.

Bambik 23 нояб. 2020 г., 17:27:44 | 5 - 9 классы

С клавиатуры вводится последовательность из n чисел ?

С клавиатуры вводится последовательность из n чисел .

Определите сумму максимального и минимального числа данной последовательности.

Нарисовать блок схему !

Язык программирования : Паскаль .

Вы открыли страницу вопроса Дано n чисел?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.