В одномерном массиве из 10 действительных чисел заменить все отрицательные элементы, противоположными им числами и вывести новый массив?

Информатика | 10 - 11 классы

В одномерном массиве из 10 действительных чисел заменить все отрицательные элементы, противоположными им числами и вывести новый массив.

Ответить на вопрос
Ответы (1)
Sasha124567 1 февр. 2020 г., 08:08:51

Program massive (input, output) ;

type vector = array[1.

10] of integer ;

var I : integer ;

z : vector ;

begin

for I : = 1 to 10 do

read (z[I]) ;

for I : = 1 to 10 do

if z[I]< ; 0 then z[I] : = z[i] * ( - 1) ;

for I : = 1 to 1o do

write (z[I], ' ') ;

end.

Valerynyashagerl 16 нояб. 2020 г., 06:17:01 | 10 - 11 классы

1. В одномерном массиве произвольных чисел А(10) положительные элементы уменьшить в двое, а отрицательные элементы заменить на значения их индексов?

1. В одномерном массиве произвольных чисел А(10) положительные элементы уменьшить в двое, а отрицательные элементы заменить на значения их индексов.

Natka16november 15 июн. 2020 г., 14:46:58 | 5 - 9 классы

Одномерный массив из 7 элементов заполнить случайным образом числами от 5 до 9?

Одномерный массив из 7 элементов заполнить случайным образом числами от 5 до 9.

Заменить все элементы массива равные 7 единицами.

Вывести на экран монитора первоначальный и преобразованный массивы в строчку.

Ghjkknbbv 21 дек. 2020 г., 09:04:39 | 1 - 4 классы

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами?

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами.

Требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

HomiTopi 15 июл. 2020 г., 09:30:41 | 5 - 9 классы

Составить программу в паскале, в которой : а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345?

Составить программу в паскале, в которой : а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345.

Б) Подсчитать и вывести отрицательные элементы массива.

Александр19833891 9 апр. 2020 г., 02:33:53 | 5 - 9 классы

1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N?

1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N.

Отрицательные элементы заменить на N.

Измененный массив вывести на экран одной строкой.

2. Дан одномерный массив размерностью N, заполненный случайными числами в интервале от - 15 до 20.

Вывести на экран значения элементов массива, абсолютное значение которых > ; 10.

3. Дан одномерный массив размерностью N, заполненный случайными числами.

Каждый третий элемент массива возвести в квадрат, если элемент отрицательный.

Измененный массив вывести на экран.

Kat2005 8 мар. 2020 г., 11:53:27 | 10 - 11 классы

Из элементов двумерного массива создать два новых одномерных Один из положительных Другой из отрицательных?

Из элементов двумерного массива создать два новых одномерных Один из положительных Другой из отрицательных.

Элин1111 25 февр. 2020 г., 06:51:33 | 10 - 11 классы

Дан одномерный массив целых чисел?

Дан одномерный массив целых чисел.

Заменить все четные числа в массиве 0.

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Angelina2016a 26 авг. 2020 г., 04:14:27 | 10 - 11 классы

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран?

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран.

На паскале.

Happyboy333 24 июл. 2020 г., 15:59:39 | 5 - 9 классы

ПОМОГИТЕ ОЧЕНЬ НАДО в одномерном массиве элементы которого целые числа вставить новый элемент перед первым отрицательным элементом?

ПОМОГИТЕ ОЧЕНЬ НАДО в одномерном массиве элементы которого целые числа вставить новый элемент перед первым отрицательным элементом.

Перед вами страница с вопросом В одномерном массиве из 10 действительных чисел заменить все отрицательные элементы, противоположными им числами и вывести новый массив?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.