Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных?

Информатика | 5 - 9 классы

Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных.

Паскаль.

Ответить на вопрос
Ответы (1)
АннаПетрякова 1 мая 2020 г., 08:00:30

Program z8 ;

uses crt ;

var a : array[1.

259] of shortint ;

i, k, n : byte ;

s : integer ;

begin

clrscr ;

randomize ;

write('Vvedi razmernost massiva = ') ;

readln(n) ;

for i : = 1 to n do begin

a[i] : = random(100 - - 100 + 1) + - 100 ;

write(a[i] : 4) ;

if a[i]< ; 0 then

s : = s + a[i] ;

if odd(a[i]) then

k : = k + 1 ;

end ;

writeln ;

writeln('Сумма отрицательных элементов равна ', s) ;

writeln('Кол - во нечётных элементов равно ', k) ;

readkey

end.

Ttde 15 дек. 2020 г., 04:02:04 | 5 - 9 классы

Все элементы массива А[1?

Все элементы массива А[1.

10] удвоить и вывести на экран.

Помогите решить на паскале.

Mishonok00 1 февр. 2020 г., 15:06:14 | 5 - 9 классы

1. Сгенерировать массив 8х14, вывести на экран?

1. Сгенерировать массив 8х14, вывести на экран.

Из чётных элементов этого массива, больших среднего арифметического нечётных элементов сформировать линейный массив, Вывести его на экран.

2. Сгенерировать массив 10х10, вывести на экран, найти сумму каждой строки.

Упорядочить строки в порядке возрастания суммы строки.

Результирующий массив вывести на экран.

Хадиджа 27 апр. 2020 г., 15:15:21 | 5 - 9 классы

Написать программу и доказать её работоспособность?

Написать программу и доказать её работоспособность.

Условие задачи : Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных.

Pascal ABC Полное решение задачи, заранее спасибо).

Яапелс 7 июн. 2020 г., 06:57:01 | 5 - 9 классы

С клавиатуры ввести массив А (Б)?

С клавиатуры ввести массив А (Б).

Найти сумму всех элементов массива.

Вывести ее на экран, и массив опять.

Klublena2011 27 июн. 2020 г., 01:58:52 | 5 - 9 классы

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран?

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран.

1) подсчитать количество элементов в массиве, значения которых больше 3.

2) найти сумму всех отрицательных элементов массива.

3) заменить все отрицательные элементы массива их индексами.

Вывести новый массив на экран

4)найти максимальный элемент.

Qleb 12 июн. 2020 г., 21:57:19 | 5 - 9 классы

Дан массив состоящий из 30 элементов?

Дан массив состоящий из 30 элементов.

Найти в массиве максимальный элемент, вывести его значение и номер на экран.

Отрицательный элемент массива заменить на равные по модулю положительные элементы.

ViskasAleksand 22 янв. 2020 г., 04:49:30 | 10 - 11 классы

В одномерном массиве произвольных чисел найти количество нечётных элементов(паскаль)?

В одномерном массиве произвольных чисел найти количество нечётных элементов(паскаль).

Angelina2016a 26 авг. 2020 г., 04:14:27 | 10 - 11 классы

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран?

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран.

На паскале.

Vasyapupkin201 2 июл. 2020 г., 19:43:53 | 5 - 9 классы

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран?

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран.

Язык Паскаль.

Dobori 14 дек. 2020 г., 05:07:33 | 10 - 11 классы

Решите плизВ массиве а1, а2, а3 … a10 вместо отрицательных элементов запи - сать их модули и вывести на экран полученный массив?

Решите плиз

В массиве а1, а2, а3 … a10 вместо отрицательных элементов запи - сать их модули и вывести на экран полученный массив.

Найти сумму всех элементов преобразованного массива.

На этой странице вы найдете ответ на вопрос Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.