Помогите, пожалуйста?

Информатика | 5 - 9 классы

Помогите, пожалуйста.

Даны три отрицательных числа найти предыдущее и следующее значение максимального из этих чисел.

На языке паскаль с изспользованием Goto.

Ответить на вопрос
Ответы (1)
Kristina99991 30 апр. 2020 г., 13:48:48

Uses crt ;

var a, b, c, ch1, ch2 : integer ;

begin

readln (a, b, c)

if (a> ; b) and (a> ; c) then begin ch1 : = a + 1 ; ch2 : = a - 1 ; end ;

if (b> ; c) and (b> ; a) then beginch1 : = b + 1 ; ch2 : = b - 1 ; end ;

if (c> ; b) and (c> ; a) then beginch1 : = c + 1 ; ch2 : = c - 1 ; end ;

writeln ('преведущее = ', ch2, 'последущее = ', ch1) ;

end.

Не пойму что тут делать с goto.

Lapteva240677 21 дек. 2020 г., 02:11:37 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найти максимальную цифру.

В паскале.

Через while.

1Kriz1 27 нояб. 2020 г., 05:48:53 | 5 - 9 классы

Написать программу на языке Паскаль?

Написать программу на языке Паскаль.

Даны три действительные числа.

Сложить те из них, значения которых не отрицательны.

Nnnn26 15 апр. 2020 г., 00:12:04 | 5 - 9 классы

Даны 3 числа?

Даны 3 числа.

Возведите в квадрат те из них значения которых отрицательны.

(записать программу на языке паскаль).

2221111333 8 янв. 2020 г., 05:32:47 | 5 - 9 классы

Даны три числа, найти максимальное из них и заменить квадратом этого числа?

Даны три числа, найти максимальное из них и заменить квадратом этого числа.

Помогите решить плииз с помощью паскаля.

Kovanov2014 27 окт. 2020 г., 02:37:24 | 10 - 11 классы

Дано трёхзначное число?

Дано трёхзначное число.

Найти среди цифр этого числа, максимальное.

Программа в Паскале.

Apasnii 7 янв. 2020 г., 09:51:57 | 5 - 9 классы

Даны 3 числа M, N, K?

Даны 3 числа M, N, K.

Найти максимальное из этих чисел.

Elvirazhambyl 18 июн. 2020 г., 01:38:27 | 10 - 11 классы

Дано n чисел?

Дано n чисел.

Замените все отрицательные числа их модулями.

Язык программирования Паскаль.

Запишите с помощью массивов.

Islan03 7 дек. 2020 г., 06:48:48 | 10 - 11 классы

Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности)?

Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности).

Найти первое отрицательное число этой последовательности.

Заранее благодарю за ответы.

Lerchik1204 3 нояб. 2020 г., 02:25:45 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Найти максимальную цифру.

В паскале.

Через процедуры.

Fimata 30 сент. 2020 г., 17:13:16 | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

ОЧЕНЬ НУЖНО!

Дано простое число.

Найти следующее за ним простое число.

Программа Паскаль.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Помогите, пожалуйста?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.