Сумма и произведение цифр случайного трехзначного числа Число вводится с клавиатуры В паскале сделайте пожалуйста?

Информатика | 5 - 9 классы

Сумма и произведение цифр случайного трехзначного числа Число вводится с клавиатуры В паскале сделайте пожалуйста.

Ответить на вопрос
Ответы (1)
Мирово 19 мар. 2020 г., 19:40:59

Var a, b, c, g : integer ;

Begin

readln (a) ;

b : = a mod 10 ;

a : = a div 10 ;

c : = a mod 10 ;

a : = a div 10 ;

g : = a mod 10 ;

write (b + c + g) ;

end.

Avs19082005iis 27 янв. 2020 г., 19:17:19 | 10 - 11 классы

1. С клавиатуры вводится число от 100 до 9999?

1. С клавиатуры вводится число от 100 до 9999.

Если число трехзначное, то найти произведение его цифр.

Если четырехзначное , то найти сумму этих цифр.

2. Определить, состоит, ли двузначное число, введенное с клавиатуры из одинаковых цифр.

Anzorparch 22 янв. 2020 г., 21:46:12 | 5 - 9 классы

С клавиатуры вводиться натуральное число м < ; 27 найдите и выведите на экран все трехзначные числа натуральные числа , сумма цифр которых равна м?

С клавиатуры вводиться натуральное число м < ; 27 найдите и выведите на экран все трехзначные числа натуральные числа , сумма цифр которых равна м.

200287 10 авг. 2020 г., 20:28:44 | 5 - 9 классы

С клавиатуры вводится трехзначное число?

С клавиатуры вводится трехзначное число.

Вывести на экран удвоенную цифру единиц Pascal.

Edikpro002701 8 авг. 2020 г., 06:55:49 | 10 - 11 классы

Ввести с клавиатуры трехзначное число и корень квадратный из суммы цифр этого числаpascal?

Ввести с клавиатуры трехзначное число и корень квадратный из суммы цифр этого числа

pascal.

Perehoghina01 16 июн. 2020 г., 00:48:43 | 10 - 11 классы

Получить случайное трехзначное число и вывести через запятую все его отдельные цифры?

Получить случайное трехзначное число и вывести через запятую все его отдельные цифры.

Сделать для программы Паскаль!

Без mod и div.

Vavdhksb 6 янв. 2020 г., 20:50:15 | 5 - 9 классы

С клавиатуры вводится четырехзначное число?

С клавиатуры вводится четырехзначное число.

Необходимо подсчитать сумму цифр этого числа.

Единорог1в1кармане 28 мар. 2020 г., 06:32:39 | 5 - 9 классы

9. Дано трехзначное число?

9. Дано трехзначное число.

Определить : а) Является ли сумма его цифр двузначным числом ; b) Является ли произведение его цифр трехзначных числом ; c) Больше ли числа А произведение его цифр ; число А – любое, оно вводится с клавиатуры ; d) Кратна ли пяти сумма его цифр ; e) Кратна ли сумма его цифр числу А ; число А – любое, оно вводится с клавиатуры ; Числа вводить, пока не будет введён нуль.

Блок - схему и программу.

Пожалуйста : ).

Maksson1997 6 апр. 2020 г., 03:47:22 | 10 - 11 классы

Дано двузначное число (водится с клавиатуры)?

Дано двузначное число (водится с клавиатуры).

Написать программу определения : превышает ли сумма его цифр третье число, которое вводится с клавиатуры.

Паскаль.

Тіна111113 12 нояб. 2020 г., 20:51:49 | 10 - 11 классы

Определить, что сумма цифр числа меньше А (А вводится с клавиатуры) СРОЧНООО ПОЖАЛУЙСТА паскаль?

Определить, что сумма цифр числа меньше А (А вводится с клавиатуры) СРОЧНООО ПОЖАЛУЙСТА паскаль.

Kenzzo 24 нояб. 2020 г., 17:16:23 | 5 - 9 классы

Написать программу которая считает количество цифр в числе и их сумму?

Написать программу которая считает количество цифр в числе и их сумму.

Паскаль.

Число вводится с клавиатуры.

Вопрос Сумма и произведение цифр случайного трехзначного числа Число вводится с клавиатуры В паскале сделайте пожалуйста?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.