Вводится целое положительное число?

Информатика | 10 - 11 классы

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

Ответить на вопрос
Ответы (1)
Katyastar1 25 нояб. 2020 г., 03:16:47

Var

a, k, m, min, i, flag : integer ; begin readln(a) ; m : = a ; {сохраняю введенное значение и считаю кол - во цифр в числе} while m > ; 0 do begin m : = m div 10 ; k : = k + 1 ; end ;

min : = 9 ; {записываю самое большое нечетное число}

{в цикле отсекаю последнюю цифру в числе и проверяю ее на нечетность.

Если она нечетная и меньше числа min, то сохраняю ее в min и присваиваю переменной Flag 1.

Если к концу программы в переменной flag будет 1, значит хотя бы одна нечетная цифра в числе была, если flag = 0 тогда в числе нет нечетных} for i : = 1 to k do begin if (a mod 10< ; = min)and(a mod 2< ; > ; 0) then begin min : = a mod 10 ; flag : = 1 ; end ; a : = a div 10 ; end ; if flag = 0 then writeln('нет нечетных') else writeln(min) ;

end.

Belousovaket 27 февр. 2020 г., 11:21:39 | 10 - 11 классы

Дано натуральное четырехзначное число?

Дано натуральное четырехзначное число.

Найти наименьшую нечетную цифру в числовой записи данного числа.

На языке С + + .

Rleisan 26 июн. 2020 г., 03:47:58 | 10 - 11 классы

Pascal?

Pascal.

Тема : Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа.

2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа.

Fakerjke 10 нояб. 2020 г., 04:19:49 | 5 - 9 классы

Составьте программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом ?

Составьте программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом .

Пример ввода :

1245

Пример вывода :

5 - нечетное число.

Yanovskyshura 23 нояб. 2020 г., 23:24:06 | 5 - 9 классы

Паскаль, цикл с предусловием while?

Паскаль, цикл с предусловием while.

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

SofArkadiu 12 нояб. 2020 г., 19:12:02 | 5 - 9 классы

PASCAL ABC, программа?

PASCAL ABC, программа!

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

Elektricman242 19 июл. 2020 г., 06:10:30 | 5 - 9 классы

Составьте, программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом?

Составьте, программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом.

Radusiii 7 июл. 2020 г., 18:00:57 | 5 - 9 классы

Определить кол - во нечетных цифр в числе?

Определить кол - во нечетных цифр в числе.

ТаткаТаточка 3 мая 2020 г., 01:57:08 | 5 - 9 классы

С клавиатуры вводится 5 - значное число?

С клавиатуры вводится 5 - значное число.

Если первая и последняя цифры этого числа четные, вывести на экран "четные", в противном случае вывести "нечетные" помогите пж.

Неумная 6 дек. 2020 г., 11:29:40 | 5 - 9 классы

Дано число?

Дано число.

Определить чему равна сумма нечетных цифр в этом числе.

ТошаКотов 4 нояб. 2020 г., 06:42:34 | 1 - 4 классы

Вводится натуральное число n требуется найти сумму четных цифр числа 2) найти количество цифр 2 в числе 3) найти максимальную нечетную цифру в числе ПАСКАЛЬ СРОЧНО?

Вводится натуральное число n требуется найти сумму четных цифр числа 2) найти количество цифр 2 в числе 3) найти максимальную нечетную цифру в числе ПАСКАЛЬ СРОЧНО!

Вы находитесь на странице вопроса Вводится целое положительное число? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.