1. С клавиатуры вводится число от 100 до 9999?

Информатика | 10 - 11 классы

1. С клавиатуры вводится число от 100 до 9999.

Если число трехзначное, то найти произведение его цифр.

Если четырехзначное , то найти сумму этих цифр.

2. Определить, состоит, ли двузначное число, введенное с клавиатуры из одинаковых цифр.

Ответить на вопрос
Ответы (1)
Nastya23sasha 27 янв. 2020 г., 19:17:23

1. for( t = n, s = 0, m = 1 ; t > ; 0 ; t / = 10 ) if (n < ; 1000) m * = t % 10 ; else s + = t % 10 ;

2.

If (n % 10 = = n / 10) printf( "состоит \ n" ) ;

Tu02 19 мая 2020 г., 09:46:33 | 5 - 9 классы

Ввести с клавиатуры двузначное число и цифру?

Ввести с клавиатуры двузначное число и цифру.

Определить, есть ли данная цифра в этом числе.

Alikaalika 27 авг. 2020 г., 23:16:26 | 10 - 11 классы

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры)?

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры).

Sweetkate1 16 июн. 2020 г., 08:12:55 | 5 - 9 классы

Найти произведение цифр целого положительного числа, введенного с клавиатуры?

Найти произведение цифр целого положительного числа, введенного с клавиатуры.

Jyliakirillova 19 дек. 2020 г., 10:54:31 | 5 - 9 классы

Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа?

Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа.

Supergoodgirl93 9 июл. 2020 г., 23:31:58 | 5 - 9 классы

Составьте программу решения следующей задачи : С клавиатуры вводится двузначное число a?

Составьте программу решения следующей задачи : С клавиатуры вводится двузначное число a.

Найти сумму его цифр.

Maxim887 11 нояб. 2020 г., 06:39:03 | 5 - 9 классы

Написать программу для Pascal?

Написать программу для Pascal.

Найти произведение цифр числа введенного с клавиатуры.

Vavdhksb 6 янв. 2020 г., 20:50:15 | 5 - 9 классы

С клавиатуры вводится четырехзначное число?

С клавиатуры вводится четырехзначное число.

Необходимо подсчитать сумму цифр этого числа.

Единорог1в1кармане 28 мар. 2020 г., 06:32:39 | 5 - 9 классы

9. Дано трехзначное число?

9. Дано трехзначное число.

Определить : а) Является ли сумма его цифр двузначным числом ; b) Является ли произведение его цифр трехзначных числом ; c) Больше ли числа А произведение его цифр ; число А – любое, оно вводится с клавиатуры ; d) Кратна ли пяти сумма его цифр ; e) Кратна ли сумма его цифр числу А ; число А – любое, оно вводится с клавиатуры ; Числа вводить, пока не будет введён нуль.

Блок - схему и программу.

Пожалуйста : ).

Андрейкораблёв1456 19 мар. 2020 г., 19:40:55 | 5 - 9 классы

Сумма и произведение цифр случайного трехзначного числа Число вводится с клавиатуры В паскале сделайте пожалуйста?

Сумма и произведение цифр случайного трехзначного числа Число вводится с клавиатуры В паскале сделайте пожалуйста.

Olyakabanina8 31 окт. 2020 г., 16:57:18 | 5 - 9 классы

Определите, встречается ли заданная цифра в числе, введенном с клавиатуры?

Определите, встречается ли заданная цифра в числе, введенном с клавиатуры.

Кратно ли это число заданной цифре?

На этой странице находится вопрос 1. С клавиатуры вводится число от 100 до 9999?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.