Составте программу , вычисления суммы цифр трёхзначного числа а?

Информатика | 5 - 9 классы

Составте программу , вычисления суммы цифр трёхзначного числа а.

Значение а введите с клавиатуры Пример ввода : 375 Пример вывода : Сумма цифр числа 375 равна 15 2) Составте программу , которая получает 'перевёртыш' трёхзначного числа а.

Значение а введите с клавиатуры Пример ввода : 375 Пример вывода : 573.

Ответить на вопрос
Ответы (1)
Hlilia68 10 февр. 2020 г., 04:29:00

Var

a : integer ;

begin

readln(n) ;

writeln('Сумма цифр числа ', a, ' равна', a div 100 + (a mod 100) div 10 + a mod 10) ;

end.

Var

a : integer ;

begin

readln(n) ;

writeln((a mod 10) * 100 + ((a mod 100) div 10) * 10 + a div 100) ;

end.

Temasan1998 11 авг. 2020 г., 05:07:05 | 5 - 9 классы

Паскаль : «Введите с клавиатуры число x?

Паскаль : «Введите с клавиатуры число x.

Определите, является ли данное число дробным.

Пример ввода : 3.

5 Пример вывода : Число дробное».

Дживс 14 сент. 2020 г., 21:37:14 | 5 - 9 классы

Составьте программу вычисления суммы цифр двузначного числа а?

Составьте программу вычисления суммы цифр двузначного числа а.

Значение а введите с клавиатуры Пример ввода : 35 Пример вывода : Сумма цифр числа 35 равна 8.

Alikaalika 27 авг. 2020 г., 23:16:26 | 10 - 11 классы

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры)?

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры).

Fles1 11 февр. 2020 г., 10:58:12 | 5 - 9 классы

Составьте программу, определяющую, является ли введенное с клавиатуры целое число четным?

Составьте программу, определяющую, является ли введенное с клавиатуры целое число четным.

Пример ввода : 7

Пример вывода : Нет.

Elenasurikova2011 27 апр. 2020 г., 00:21:41 | 5 - 9 классы

Составьте программу, выводящую на экран все делители числа х?

Составьте программу, выводящую на экран все делители числа х.

Число x введите с клавиатуры.

Пример ввода : 12 Пример вывода : 1 2 3 4 6 12 Помогите пожалуйста!

Sacha5000 25 апр. 2020 г., 05:19:42 | 5 - 9 классы

Составьте программу , выходящую на экран все делители числа х ?

Составьте программу , выходящую на экран все делители числа х .

Число х введите с клавиатуры .

Пример ввода : 12 Пример вывода : 1 2 3 4 6 12.

MaksimPRO888 10 дек. 2020 г., 03:30:25 | 5 - 9 классы

Введите с клавиатуры число х?

Введите с клавиатуры число х.

Определите , является ли данное число дробным

пример ввода 3.

5

пример вывода

число дробное.

Olgaiviva 30 апр. 2020 г., 21:34:25 | 10 - 11 классы

Составить программу вычисления суммы цифр 5 - значного числа вводимого с клавиатуры где N вводиться с клавиатуры?

Составить программу вычисления суммы цифр 5 - значного числа вводимого с клавиатуры где N вводиться с клавиатуры.

Jesdasd 20 окт. 2020 г., 23:54:53 | 5 - 9 классы

Напишите программу, которая по исходному пятизначному числу находит сумму квадратов цифр данного числа Пример ввода 12345 Пример вывода 55 С + + ПРОГРАММА?

Напишите программу, которая по исходному пятизначному числу находит сумму квадратов цифр данного числа Пример ввода 12345 Пример вывода 55 С + + ПРОГРАММА.

Lenaaruda 30 сент. 2020 г., 14:24:55 | 5 - 9 классы

Составить программу, которая вычисляет сумму вводимых с клавиатуры целых чисел до ввода отрицательного числа и выводит на экран значение вычисленной суммы?

Составить программу, которая вычисляет сумму вводимых с клавиатуры целых чисел до ввода отрицательного числа и выводит на экран значение вычисленной суммы.

На этой странице находится вопрос Составте программу , вычисления суммы цифр трёхзначного числа а?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.