Очень нужна помощь ?

Информатика | 5 - 9 классы

Очень нужна помощь !

С клавиатуры вводятся трёхзначные числа до тех пор, пока первая цифра не станет равна третьей.

Вывести на экран только те числа, где сумма цифр меньше десяти.

Паскаль abc.

Ответить на вопрос
Ответы (1)
Registracia2 5 июл. 2020 г., 05:02:41

Var a, a2, b, c : integer ;

begin

write('введите трёхзначное число = = > ; ') ;

readln(a) ;

a2 : = a ;

while ((a div 100)< ; > ; (a mod 10)) do begin

while (a2< ; > ; 0) do begin

b : = a2 mod 10 ;

c : = c + b ;

a2 : = a2 div 10 ;

end ;

if c< ; 10 then writeln('сумма цифр меньше 10 = = > ; ', a) ;

c : = 0 ;

write('введите трёхзначное число = = > ; ') ;

readln(a) ;

end ;

end.

Rleisan 26 июн. 2020 г., 03:47:58 | 10 - 11 классы

Pascal?

Pascal.

Тема : Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа.

2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа.

5клас 4 июн. 2020 г., 06:42:03 | 10 - 11 классы

Ребят, помоги в паскале?

Ребят, помоги в паскале.

Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0.

В конце работы программы на экран выводится сумма и произведение введенных чисел.

Alikaalika 27 авг. 2020 г., 23:16:26 | 10 - 11 классы

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры)?

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры).

200287 10 авг. 2020 г., 20:28:44 | 5 - 9 классы

С клавиатуры вводится трехзначное число?

С клавиатуры вводится трехзначное число.

Вывести на экран удвоенную цифру единиц Pascal.

Dasha999922 2 сент. 2020 г., 16:30:56 | 5 - 9 классы

Написать программу в паскаль?

Написать программу в паскаль.

Из всех двузначных чисел вывести на экран те из них, сумма цифр которых равна А.

(А вводится с клавиатуры).

Лерочка88775 24 апр. 2020 г., 20:08:37 | 5 - 9 классы

Из всех двузначных чисел вывести на экран те из них, сумма цифр которых равна А?

Из всех двузначных чисел вывести на экран те из них, сумма цифр которых равна А.

( А вводится с клавиатуры).

Inessik 16 апр. 2020 г., 08:23:38 | 10 - 11 классы

С клавиатуры вводится трёхзначное число?

С клавиатуры вводится трёхзначное число.

Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях.

Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

DanielRuss 2 апр. 2020 г., 04:07:08 | 10 - 11 классы

Клавиатуры вводится трёхзначное число?

Клавиатуры вводится трёхзначное число.

Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях.

Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

Лёликет 15 дек. 2020 г., 13:58:06 | 10 - 11 классы

1) С клавиатуры вводится трёхзначное число?

1) С клавиатуры вводится трёхзначное число.

Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях.

Тіна111113 12 нояб. 2020 г., 20:51:49 | 10 - 11 классы

Определить, что сумма цифр числа меньше А (А вводится с клавиатуры) СРОЧНООО ПОЖАЛУЙСТА паскаль?

Определить, что сумма цифр числа меньше А (А вводится с клавиатуры) СРОЧНООО ПОЖАЛУЙСТА паскаль.

Вы находитесь на странице вопроса Очень нужна помощь ? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.