Из данного натурального числа n, удалить все цифры 5 ( n вводиться с клавиатуры)?

Информатика | 10 - 11 классы

Из данного натурального числа n, удалить все цифры 5 ( n вводиться с клавиатуры).

Например вводим 25455, выводит 24.

Ответить на вопрос
Ответы (1)
Kristinas2085 18 апр. 2020 г., 23:45:39

Var s : string ;

i : byte ;

begin

read(s) ;

if (length(s) = 1)and (s = '5') then writeln(' ') else begin

while i< ; > ; length(s) do

begin

i : = i + 1 ;

if copy(s, i, 1) = '5' then begin delete (s, i, 1) ; i : = i - 1 ; end ;

end ;

writeln(s) ;

end ;

end.

Asia271 12 мая 2020 г., 22:59:44 | 5 - 9 классы

С клавиатуры вводится натуральное число?

С клавиатуры вводится натуральное число.

Определите сколько в его записи нечетных чисел.

Evelinakotova 27 окт. 2020 г., 12:03:08 | 5 - 9 классы

Типы данных, условный оператор, операторы ввода / вывода, написать программу сложения 3 цифр, которые будут вводиться с клавиатуры?

Типы данных, условный оператор, операторы ввода / вывода, написать программу сложения 3 цифр, которые будут вводиться с клавиатуры.

(pascal abc).

Dinarka007 7 июл. 2020 г., 16:17:11 | 5 - 9 классы

С клавиатуры вводится натуральное число N?

С клавиатуры вводится натуральное число N.

Найдите и выведите самую большую цифру этого числа.

89678692155 5 апр. 2020 г., 04:10:50 | 10 - 11 классы

Написать программу при выполнение которой с клавиатуры вводятся натуральное число n, не привосходящее 1000 и выводится произведение цифр этого числа?

Написать программу при выполнение которой с клавиатуры вводятся натуральное число n, не привосходящее 1000 и выводится произведение цифр этого числа.

Срочно нужно!

Zoya22 10 февр. 2020 г., 13:54:03 | 5 - 9 классы

С клавиатуры вводится натуральное число n?

С клавиатуры вводится натуральное число n.

Найдите и выведите самую большую цифру этого числа.

КРОЛЛЬ 17 февр. 2020 г., 04:49:02 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить, есть ли в нем цифра равная а (а вводится с клавиатуры).

Wewqeq 19 дек. 2020 г., 18:12:56 | 5 - 9 классы

Написать программу при которой с клавиатуры вводится натуральное число n не при восходящее 1000 и выводится произведение цифр этого числа?

Написать программу при которой с клавиатуры вводится натуральное число n не при восходящее 1000 и выводится произведение цифр этого числа.

Marina19821119 5 мая 2020 г., 17:14:32 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Найти количество цифр данного числа больших b(b вводится с клавиатуры).

Лаура200011 29 мар. 2020 г., 12:30:09 | 5 - 9 классы

С клавиатуры вводится натуральное число n?

С клавиатуры вводится натуральное число n.

Посчитать сумму натурального числа от 1 до n?

Kama2846 1 апр. 2020 г., 18:19:07 | 10 - 11 классы

Помогите составить программу на языке паскаль Вводится натуральное число Х (Х> ; 9)?

Помогите составить программу на языке паскаль Вводится натуральное число Х (Х> ; 9).

1. определить, совпадают ли по значению первая и последняя цифры.

Например, Ввод : 727 Вывод : Число начинается и заканчивается цифрой 7 Ввод 123 Вывод Первая и последняя цифры не совпадают.

На этой странице находится вопрос Из данного натурального числа n, удалить все цифры 5 ( n вводиться с клавиатуры)?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.