Написать программу при выполнение которой с клавиатуры вводятся натуральное число n, не привосходящее 1000 и выводится произведение цифр этого числа?

Информатика | 10 - 11 классы

Написать программу при выполнение которой с клавиатуры вводятся натуральное число n, не привосходящее 1000 и выводится произведение цифр этого числа.

Срочно нужно!

Ответить на вопрос
Ответы (1)
Kyamrankurmanbaev 5 апр. 2020 г., 04:10:55

Var

n, prod : integer ;

begin read (n) ;

prod : = 1 ;

while n > ; 0 do

begin prod : = prod * (n mod 10) ; n : = n div 10 ;

end ;

write (prod) ;

end.

Sana8977 22 янв. 2020 г., 07:02:31 | 5 - 9 классы

Написать программу, которая вычисляет сумму произведения, разность, деления, сложения, остаток деления?

Написать программу, которая вычисляет сумму произведения, разность, деления, сложения, остаток деления.

Числа вводятся с клавиатуры результат выводится в консоль.

Kosta2006 10 дек. 2020 г., 07:26:14 | 5 - 9 классы

Срочно помогите, завтра срез?

Срочно помогите, завтра срез!

Составьте программу, которая вводит с клавиатуры 2 числа и выводит на экран их сумму, разность, произведение и частное.

Vovochkapleshk 21 мар. 2020 г., 13:50:56 | 10 - 11 классы

Написать программу при выполнение которой с клавиатуры вводятся 10 целых чисел?

Написать программу при выполнение которой с клавиатуры вводятся 10 целых чисел.

Программа выводит кол - во чисел кратных 5 и её произведение.

Mery1305 7 окт. 2020 г., 16:15:51 | 5 - 9 классы

Написать программу которая находит произведение n первых натуральных чисел ?

Написать программу которая находит произведение n первых натуральных чисел .

Число n вводится с клавиатуры.

Выполнить программу для n = 9 записать результат.

Wewqeq 19 дек. 2020 г., 18:12:56 | 5 - 9 классы

Написать программу при которой с клавиатуры вводится натуральное число n не при восходящее 1000 и выводится произведение цифр этого числа?

Написать программу при которой с клавиатуры вводится натуральное число n не при восходящее 1000 и выводится произведение цифр этого числа.

Керим1 11 авг. 2020 г., 21:30:24 | 10 - 11 классы

Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры?

Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры.

Licey4 21 янв. 2020 г., 01:21:28 | 5 - 9 классы

Написать программу которая вводит с клавиатуры два числа с помощью цикла while выводить на экран число a в раз?

Написать программу которая вводит с клавиатуры два числа с помощью цикла while выводить на экран число a в раз.

Соломія6 30 янв. 2020 г., 14:24:45 | 5 - 9 классы

С клавиатуры вводится двухзначное число ?

С клавиатуры вводится двухзначное число .

Написать программу которая проверяет если среди его значащих цифр 0.

Maksson1997 6 апр. 2020 г., 03:47:22 | 10 - 11 классы

Дано двузначное число (водится с клавиатуры)?

Дано двузначное число (водится с клавиатуры).

Написать программу определения : превышает ли сумма его цифр третье число, которое вводится с клавиатуры.

Паскаль.

Kenzzo 24 нояб. 2020 г., 17:16:23 | 5 - 9 классы

Написать программу которая считает количество цифр в числе и их сумму?

Написать программу которая считает количество цифр в числе и их сумму.

Паскаль.

Число вводится с клавиатуры.

Вопрос Написать программу при выполнение которой с клавиатуры вводятся натуральное число n, не привосходящее 1000 и выводится произведение цифр этого числа?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.