Дано натуральное число?

Информатика | 10 - 11 классы

Дано натуральное число.

Определить, есть ли в нем цифра равная а (а вводится с клавиатуры).

Ответить на вопрос
Ответы (1)
Fhferfhb 17 февр. 2020 г., 04:49:07

Var

z, a, i : integer ;

begin

writeln('vvedite chislo') ;

readln(z) ;

writeln('vvedite zifru') ;

readln(a) ;

for i : = 1 to length(IntToStr(z)) do begin

if z mod 10 = a then

writeln('est') ;

z : = z div 10 ;

end ;

end.

Asia271 12 мая 2020 г., 22:59:44 | 5 - 9 классы

С клавиатуры вводится натуральное число?

С клавиатуры вводится натуральное число.

Определите сколько в его записи нечетных чисел.

Dinarka007 7 июл. 2020 г., 16:17:11 | 5 - 9 классы

С клавиатуры вводится натуральное число N?

С клавиатуры вводится натуральное число N.

Найдите и выведите самую большую цифру этого числа.

Pmashkarin 18 апр. 2020 г., 23:45:34 | 10 - 11 классы

Из данного натурального числа n, удалить все цифры 5 ( n вводиться с клавиатуры)?

Из данного натурального числа n, удалить все цифры 5 ( n вводиться с клавиатуры).

Например вводим 25455, выводит 24.

Anzorparch 22 янв. 2020 г., 21:46:12 | 5 - 9 классы

С клавиатуры вводиться натуральное число м < ; 27 найдите и выведите на экран все трехзначные числа натуральные числа , сумма цифр которых равна м?

С клавиатуры вводиться натуральное число м < ; 27 найдите и выведите на экран все трехзначные числа натуральные числа , сумма цифр которых равна м.

SKORPIONS1996 28 июл. 2020 г., 03:42:41 | 5 - 9 классы

ПОМОГИИТЕ?

ПОМОГИИТЕ!

Дано натуральное число.

Определить, сколько раз в нем встречается цифра равная последней.

Zoya22 10 февр. 2020 г., 13:54:03 | 5 - 9 классы

С клавиатуры вводится натуральное число n?

С клавиатуры вводится натуральное число n.

Найдите и выведите самую большую цифру этого числа.

Marina19821119 5 мая 2020 г., 17:14:32 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Найти количество цифр данного числа больших b(b вводится с клавиатуры).

Ryazanceva0303 28 мая 2020 г., 19:24:24 | 5 - 9 классы

Дано натуральное число ?

Дано натуральное число .

Определить есть ли в нем цифра а Написать с постусловием язык Паскаля !

Luneva281983 5 мая 2020 г., 18:59:18 | 5 - 9 классы

С клавиатуры вводится целое положительное число?

С клавиатуры вводится целое положительное число.

Определить, сколько в этом числе чётных цифр.

(PASCAL).

Sofa08 17 июл. 2020 г., 03:23:43 | 5 - 9 классы

С клавиатуры вводится целое положительное число?

С клавиатуры вводится целое положительное число.

Определить, сколько раз в этом числе встретилась цифра 5.

Вопрос Дано натуральное число?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.