Дано натуральное число?

Информатика | 10 - 11 классы

Дано натуральное число.

Найти количество цифр данного числа больших b(b вводится с клавиатуры).

Ответить на вопрос
Ответы (1)
Gangsterlexa 5 мая 2020 г., 17:14:33

Паскаль :

uses crt ; var a, b, c, code, i, k : integer ; st : string ; begin

write ('N = ') ; readln (a) ;

write ('B = ') ; readln (b) ; str (a, st) ; for i : = 1 to length (st) do begin val (st[i], c, code) ; if c> ; b then k : = k + 1 ; end ; writeln (k) ; readkey ; end.

ДЕГЕРЕГЕ 30 мар. 2020 г., 08:34:51 | 5 - 9 классы

Дано натуральное число N найти количество нулей в этом числе?

Дано натуральное число N найти количество нулей в этом числе.

VOLAN97 27 июл. 2020 г., 16:21:50 | 5 - 9 классы

1)найти количесво делителей натурального числа, сколько из них чётных?

1)найти количесво делителей натурального числа, сколько из них чётных?

2) дано натуральное число : найти две первые цыфры числа верно ли, что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа, которые состоят из разных цыфр, а их сумма равна А(А вводится с клавиатуры) 4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры).

Dinarka007 7 июл. 2020 г., 16:17:11 | 5 - 9 классы

С клавиатуры вводится натуральное число N?

С клавиатуры вводится натуральное число N.

Найдите и выведите самую большую цифру этого числа.

Pmashkarin 18 апр. 2020 г., 23:45:34 | 10 - 11 классы

Из данного натурального числа n, удалить все цифры 5 ( n вводиться с клавиатуры)?

Из данного натурального числа n, удалить все цифры 5 ( n вводиться с клавиатуры).

Например вводим 25455, выводит 24.

Antonkhvorov 20 июн. 2020 г., 12:56:51 | 10 - 11 классы

1) дано натуральное а?

1) дано натуральное а.

Верно ли, что данное число состоит из 3 цифр?

2) дано натуральное число.

Верно ли, что в данном числе четыре цифры?

3) Даны два натуральных числа.

Определить в каком числе первая цифра больше.

4) Дано натуральное n.

Найти количество 6, входящих в данное число.

Нужно решить в программе паскаль.

Если поможет, то мы учим цикл в паскале, div, mod.

Пустой 15 мар. 2020 г., 10:32:37 | 5 - 9 классы

Найти количество делителей натурального числа А, больших К?

Найти количество делителей натурального числа А, больших К.

(А и К вводятся с клавиатуры, K< ; = A).

Код должен быть написан на языке Паскаля (Pascal).

Zoya22 10 февр. 2020 г., 13:54:03 | 5 - 9 классы

С клавиатуры вводится натуральное число n?

С клавиатуры вводится натуральное число n.

Найдите и выведите самую большую цифру этого числа.

КРОЛЛЬ 17 февр. 2020 г., 04:49:02 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить, есть ли в нем цифра равная а (а вводится с клавиатуры).

Maksson1997 6 апр. 2020 г., 03:47:22 | 10 - 11 классы

Дано двузначное число (водится с клавиатуры)?

Дано двузначное число (водится с клавиатуры).

Написать программу определения : превышает ли сумма его цифр третье число, которое вводится с клавиатуры.

Паскаль.

Yps 1 окт. 2020 г., 23:15:52 | 10 - 11 классы

Составить программу в с + +Дано натуральное число :1) найти кол - во четных цифр этого числа2) верно ли, что в Данном числе встречается A и B (числа A и B вводится с клавиатуры)?

Составить программу в с + +

Дано натуральное число :

1) найти кол - во четных цифр этого числа

2) верно ли, что в Данном числе встречается A и B (числа A и B вводится с клавиатуры).

Вы зашли на страницу вопроса Дано натуральное число?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.