Составить на языке Паскаль программу, которая запрашивает с клавиатуры N целых чисел и считает, сколько из них положительных, сколько отрицательных и сколько нулей?

Информатика | 10 - 11 классы

Составить на языке Паскаль программу, которая запрашивает с клавиатуры N целых чисел и считает, сколько из них положительных, сколько отрицательных и сколько нулей.

Разработать для программы не менее двух тестов и доказать правильность её работы.

Ответить на вопрос
Ответы (1)
Rasper 10 мар. 2020 г., 15:51:33

Program ms3o1 ; {пишу по памяти - не судите строго за ошибки}

var n, i, j, p, o, n : integer ;

begin

n : = 0 ; {тут у нас будут ноли}

o : = 0 ; {тут отрицательные}

p : = o ; {и тут соответственно положительные}

writeln('Введите кол - во целых чисел для проверки') ; readln(n) ;

for i : = 1 to n do

begin

writeln('Введите число : ') ; readln(j) ;

if j = 0 then n : = n + 1 ;

if j> ; 0 then p : = p + 1 ;

if j< ; 0 then o : = o + 1 ;

end ;

writeln('Отрицательных : ', o) ;

writeln('Положительных : ', p) ;

writeln('Равны ноль : ', n) ;

readln ;

end.

13anna05 21 окт. 2020 г., 00:43:19 | 5 - 9 классы

Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных чисел и ищет их сумму?

Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных чисел и ищет их сумму.

Число N вводится с клавиатуры.

Lindasayfutdin1 17 окт. 2020 г., 00:46:28 | 5 - 9 классы

Программа в Паскале нужна, пожалуйста?

Программа в Паскале нужна, пожалуйста!

Даю 60 баллов!

С клавиатуры вводится последовательность из N чисел, положительных и отрицательных.

Какая сумма чисел по модулю больше, положительных или отрицательных?

Savickiy2006 25 авг. 2020 г., 22:56:18 | 5 - 9 классы

Написать программу которая запрашивает N целых чисел и сообщает сколько было введено нечетных чисел?

Написать программу которая запрашивает N целых чисел и сообщает сколько было введено нечетных чисел.

Vibornova 16 мар. 2020 г., 18:39:46 | 5 - 9 классы

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры?

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры.

Romastovpets 25 сент. 2020 г., 05:34:38 | 10 - 11 классы

Составить программу, которая считает в формуле, заданной с клавиатуры, колличество плюсов и минусов (программа в паскале)?

Составить программу, которая считает в формуле, заданной с клавиатуры, колличество плюсов и минусов (программа в паскале).

Dodydyd 13 янв. 2020 г., 18:54:23 | 10 - 11 классы

Даны три целых числа?

Даны три целых числа.

Определить, сколько среди них положительных чисел.

Составить программу на языке Паскаль.

Katerinka1297 6 февр. 2020 г., 18:40:58 | 10 - 11 классы

Составьте программу в ПАСКАЛЬ, которая запрашивает ввод целых положительных чисел и определяет произведение нечётных из них?

Составьте программу в ПАСКАЛЬ, которая запрашивает ввод целых положительных чисел и определяет произведение нечётных из них.

Признаком конца ввода считать ввод числа - 4.

Zhenk2011 20 июн. 2020 г., 10:41:16 | 10 - 11 классы

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел?

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел.

( На языке Паскаль С + + ).

Аня1210 5 июн. 2020 г., 08:29:44 | 5 - 9 классы

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом?

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом.

Aida201 1 авг. 2020 г., 15:23:32 | 5 - 9 классы

Как создать программу которая из трех чисел, введенных с клавиатуры, возводит в квадрат положительные, а отрицательные оставляет без изменения в паскале?

Как создать программу которая из трех чисел, введенных с клавиатуры, возводит в квадрат положительные, а отрицательные оставляет без изменения в паскале?

На странице вопроса Составить на языке Паскаль программу, которая запрашивает с клавиатуры N целых чисел и считает, сколько из них положительных, сколько отрицательных и сколько нулей? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.