Серёжа мечтает о том, что бы каждый второй символ был #?

Информатика | 10 - 11 классы

Серёжа мечтает о том, что бы каждый второй символ был #.

Он пытался написать программу, которая вводила строку, а потом выводила вместе каждого второго символа "#", но у него не получилось этого сделать.

Помогите ему осуществить свою мечту.

))) Формат ввода : вводится строка Формат вывода : выводится строка, где каждый второй символ заменён нам "#" Пример ввода : Milye druz'ya Пример вывода : M#l#e#d#u#'#a.

Ответить на вопрос
Ответы (1)
10nikita10com 19 мар. 2020 г., 09:51:54

Var s : string ; i : byte ;

begin Write('Введи строку : ') ; Readln(s) ; i : = 2 ; while i< ; = length(s) do begin s[i] : = '#' ; i : = i + 2 end ; Writeln(s)

end.

Тестовое решение :

Введи строку : Milye druz'ya

M#l#e#d#u#'#a.

80665 11 нояб. 2020 г., 14:08:35 | 5 - 9 классы

Составьте программу, которая вычисляет сумму трёх чисел, введённых с клавиатуры, и выводит её на экран?

Составьте программу, которая вычисляет сумму трёх чисел, введённых с клавиатуры, и выводит её на экран.

Формат ввода : a - первое число, b - второе число ; с - третье число.

Пример ввода : a - 5, b - 7, c - 3.

Формат вывода : s - сумма чисел, пример вывода : 15.

123tyi 17 июл. 2020 г., 13:12:03 | 10 - 11 классы

Помогите плз сделать домашку по информатике))) с клавиатуры одной строкой вводят имя и фамилию?

Помогите плз сделать домашку по информатике))) с клавиатуры одной строкой вводят имя и фамилию.

Составьте программу, которая : а) определяет, есть ли во введенной строке заданный символ б) копирует в новую строку имя и выводит его в) выводит сначала фамилию, а затем имя.

89129627357 12 апр. 2020 г., 07:10:10 | 10 - 11 классы

Составить программу для ввода строки символов с клавиатуры в буфер и вывод этой строки на экран?

Составить программу для ввода строки символов с клавиатуры в буфер и вывод этой строки на экран.

Laisrem13 8 дек. 2020 г., 23:51:41 | 10 - 11 классы

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов)?

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов).

Алёнушка2002 9 окт. 2020 г., 09:26:45 | 10 - 11 классы

. Вводится две строки?

. Вводится две строки.

Длина каждой не превосходит 255 символов.

Определить, верно ли, что все элементы первой строки входят во вторую.

Romodo 26 июл. 2020 г., 20:36:37 | 10 - 11 классы

Напишите программу, которая вводит значение трёх переменных и выводит их произведение?

Напишите программу, которая вводит значение трёх переменных и выводит их произведение.

Ввод каждого значения производится с отдельной строки.

GlebovichPolinka 22 дек. 2020 г., 15:42:26 | 10 - 11 классы

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и ch?

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и chr).

Dasdgffjj 4 апр. 2020 г., 20:51:39 | 5 - 9 классы

Помогите, прошу?

Помогите, прошу.

Составить программу, которая вводит с клавиатуры один символ и выводит на экран два символа стоящие до и после этого символа.

Лили0108 30 окт. 2020 г., 19:25:42 | 5 - 9 классы

1) с клавиатуры вводится строка символов состоящая из заменить все буквы в слов, последнем слове на восклицательные знаки 2)С клавиатуры вводится строка символов, удалить все символы стоящие между пер?

1) с клавиатуры вводится строка символов состоящая из заменить все буквы в слов, последнем слове на восклицательные знаки 2)С клавиатуры вводится строка символов, удалить все символы стоящие между первой и второй точкой запятой.

ПРИМЕР : abсxyz ; reо(xyz - удаляется.

Непонятно 6 дек. 2020 г., 01:10:08 | 10 - 11 классы

Программа вводит две строки?

Программа вводит две строки.

Из более длинной строки программа выводит все символы, коды которых > ; 70.

В короткой строке заменяет все «!

» знаки на « * » и выводит короткую строку на экран.

Вы находитесь на странице вопроса Серёжа мечтает о том, что бы каждый второй символ был #? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.