Задан вид квадратного уравнения ах квадрат + bx + c = 0, коэффициенты a, b, c?

Информатика | 10 - 11 классы

Задан вид квадратного уравнения ах квадрат + bx + c = 0, коэффициенты a, b, c.

Найти корни уравнения x1, x2.

1. Разработать схему алгоритма программы 2.

Составить программу на языке Паскаль по разработанному алгоритму.

Ответить на вопрос
Ответы (1)
Эээм 12 июн. 2020 г., 00:00:59

Var a, b, c, d, x1, x2 : real ;

begin

writeln('Решение квадратных уравнений') ;

writeln('') ;

writeln('Введите коэффициенты a, b, c : ') ;

readln(a, b, c) ;

d : = sqr(b) - 4 * a * c ;

if d< ; 0 then writeln('Корней нет') ;

if d = 0 then begin x1 : = - b / (2 * a) ;

writeln('Один корень : ') ;

writeln(x1 : 4 : 2) ;

end ;

if d> ; 0 then begin

x1 : = - b + sqrt(d) / (2 * a) ;

x2 : = - b - sqrt(d) / (2 * a) ;

writeln('Корни уравнения : ') ;

writeln(x1 : 4 : 2) ;

writeln(x2 : 4 : 2) ;

end ;

end.

Ldfdg 25 июн. 2020 г., 08:53:10 | 5 - 9 классы

Составить программу на языке программирования Паскаль , которая бы соответствовала бы следующему алгоритму?

Составить программу на языке программирования Паскаль , которая бы соответствовала бы следующему алгоритму.

Ksyushagordien 4 окт. 2020 г., 08:14:12 | 10 - 11 классы

Циклические алгоритмы и разработка программыЦиклы с параметрамиРазработать схему алгоритма (блок схему), написать программный код на языке паскаль, используя оператор FOR?

Циклические алгоритмы и разработка программы

Циклы с параметрами

Разработать схему алгоритма (блок схему), написать программный код на языке паскаль, используя оператор FOR.

TumblrBoy 24 февр. 2020 г., 11:49:48 | 10 - 11 классы

Составить блок - схему алгоритма и программу на алгоритмическом языке?

Составить блок - схему алгоритма и программу на алгоритмическом языке.

Язык Паскаль ( любой ).

Simidockiy03 24 апр. 2020 г., 08:35:09 | 5 - 9 классы

Разработайте алгоритм в виде блок - схем для значения функции?

Разработайте алгоритм в виде блок - схем для значения функции.

Rahimbaevaalina 23 нояб. 2020 г., 10:13:33 | 10 - 11 классы

Используя метод нисходящего проектирования, разработать схему алгоритма и составить программу вычисления функции при заданных значениях аргументов?

Используя метод нисходящего проектирования, разработать схему алгоритма и составить программу вычисления функции при заданных значениях аргументов.

(язык pascal).

Gevork65 8 июл. 2020 г., 03:50:21 | 10 - 11 классы

Циклы с постусловиями?

Циклы с постусловиями.

Разработать схему алгоритма и написать программный код на языке Паскаль.

Используя оператор Repeat Until.

Yuliakiteva 20 апр. 2020 г., 18:45:23 | 1 - 4 классы

Разработать алгоритм и составить программу на выбранном языке программирования ( Паскаль или Qbasic) для нахождения произведения цифр числа, полученного при умножении числа 12 на свой порядковый номер?

Разработать алгоритм и составить программу на выбранном языке программирования ( Паскаль или Qbasic) для нахождения произведения цифр числа, полученного при умножении числа 12 на свой порядковый номер в списке группы.

Syuzi3009 7 июн. 2020 г., 05:40:11 | 5 - 9 классы

Запишите программу на языке Паскаль согласно заданному алгоритму?

Запишите программу на языке Паскаль согласно заданному алгоритму.

Sashakirpicenko 17 апр. 2020 г., 13:32:34 | 5 - 9 классы

Составить программу на компе в паскале по алгоритму?

Составить программу на компе в паскале по алгоритму.

Maxsi8 24 дек. 2020 г., 07:03:02 | 10 - 11 классы

Разработать алгоритм и программу вычисления квадратов и кубов целых чисел от 1 до 50?

Разработать алгоритм и программу вычисления квадратов и кубов целых чисел от 1 до 50.

Результат выдать на экран в виде таблицы : в паскале.

На этой странице находится вопрос Задан вид квадратного уравнения ах квадрат + bx + c = 0, коэффициенты a, b, c?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.