Используя метод нисходящего проектирования, разработать схему алгоритма и составить программу вычисления функции при заданных значениях аргументов?

Информатика | 10 - 11 классы

Используя метод нисходящего проектирования, разработать схему алгоритма и составить программу вычисления функции при заданных значениях аргументов.

(язык pascal).

Ответить на вопрос
Ответы (1)
A12345а 23 нояб. 2020 г., 10:13:37

/ / PascalABC.

Net 3.

0, версия 1066

function t(a, x : real) : real ;

begin if a> ; = x then t : = 2 * a * x else t : = a / (2 * x)

end ;

function w(a, x : real) : real ;

begin w : = sqr(x) + cos(a * x + t(a, x))

end ;

var a, x : real ;

begin a : = 0.

5 ; while a< ; = 1.

9 do begin Writeln('a = ', a) ; x : = 0.

2 ; while x< ; = 2.

2 do begin Writeln('x = ', x : 3 : 1, ', w = ', w(a, x) : 9 : 6) ; x : = x + 0.

5 end ; a : = a + 0.

2 end

end.

Результат выполнения программы :

a = 0.

5

x = 0.

2, w = 0.

995336

x = 0.

7, w = 1.

250221

x = 1.

2, w = 2.

130705

x = 1.

7, w = 3.

432775

x = 2.

2, w = 5.

189615

a = 0.

7

x = 0.

2, w = 0.

953089

x = 0.

7, w = 0.

590626

x = 1.

2, w = 1.

865152

x = 1.

7, w = 3.

064023

x = 2.

2, w = 4.

712057

a = 0.

9

x = 0.

2, w = 0.

897709

x = 0.

7, w = 0.

176189

x = 1.

2, w = 1.

555538

x = 1.

7, w = 2.

667957

x = 2.

2, w = 4.

264064

a = 1.

1

x = 0.

2, w = 0.

829992

x = 0.

7, w = - 0.

183700

x = 1.

2, w = 1.

233950

x = 1.

7, w = 2.

306743

x = 2.

2, w = 3.

949154

a = 1.

3

x = 0.

2, w = 0.

750914

x = 0.

7, w = - 0.

426485

x = 1.

2, w = 1.

407617

x = 1.

7, w = 2.

037078

x = 2.

2, w = 3.

840096

a = 1.

5

x = 0.

2, w = 0.

661610

x = 0.

7, w = - 0.

509965

x = 1.

2, w = 2.

074693

x = 1.

7, w = 1.

901291

x = 2.

2, w = 3.

962090

a = 1.

7

x = 0.

2, w = 0.

563366

x = 0.

7, w = - 0.

419629

x = 1.

2, w = 2.

426715

x = 1.

7, w = 1.

920695

x = 2.

2, w = 4.

286946

a = 1.

9

x = 0.

2, w = 0.

457595

x = 0.

7, w = - 0.

171179

x = 1.

2, w = 2.

288943

x = 1.

7, w = 1.

924966

x = 2.

2, w = 4.

739599.

Ksyushagordien 4 окт. 2020 г., 08:14:12 | 10 - 11 классы

Циклические алгоритмы и разработка программыЦиклы с параметрамиРазработать схему алгоритма (блок схему), написать программный код на языке паскаль, используя оператор FOR?

Циклические алгоритмы и разработка программы

Циклы с параметрами

Разработать схему алгоритма (блок схему), написать программный код на языке паскаль, используя оператор FOR.

Sfa34 12 июн. 2020 г., 00:00:57 | 10 - 11 классы

Задан вид квадратного уравнения ах квадрат + bx + c = 0, коэффициенты a, b, c?

Задан вид квадратного уравнения ах квадрат + bx + c = 0, коэффициенты a, b, c.

Найти корни уравнения x1, x2.

1. Разработать схему алгоритма программы 2.

Составить программу на языке Паскаль по разработанному алгоритму.

Simidockiy03 24 апр. 2020 г., 08:35:09 | 5 - 9 классы

Разработайте алгоритм в виде блок - схем для значения функции?

Разработайте алгоритм в виде блок - схем для значения функции.

Seregabv 27 мая 2020 г., 00:14:22 | 10 - 11 классы

Вычислить на эвм значения функции заданной в таблице?

Вычислить на эвм значения функции заданной в таблице.

Программу составить таким образом, чтобы вычислялось многократное значение функции при изменении аргумента в указанном диапазоне и с заданным шагом.

Организовать вывод значения аргумента и вычисленного значения функции в виде таблицы.

Катёнок8888 24 мар. 2020 г., 01:33:07 | 10 - 11 классы

Составить по алгоритму программу на языке программирования Pascal?

Составить по алгоритму программу на языке программирования Pascal.

LexanDros 2 нояб. 2020 г., 07:06:43 | 10 - 11 классы

Разработайте алгоритм вычисления функции v?

Разработайте алгоритм вычисления функции v.

Dartwey 19 окт. 2020 г., 21:00:10 | 10 - 11 классы

Разработайте алгоритм вычисления функции z?

Разработайте алгоритм вычисления функции z.

Infoplan 26 сент. 2020 г., 16:48:23 | 5 - 9 классы

Составить по алгоритму программу на языке программирования Pascal?

Составить по алгоритму программу на языке программирования Pascal.

Dimarasher 14 окт. 2020 г., 15:01:02 | 10 - 11 классы

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно?

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно.

Мяусик1 8 нояб. 2020 г., 20:39:47 | 10 - 11 классы

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно?

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно.

Вы перешли к вопросу Используя метод нисходящего проектирования, разработать схему алгоритма и составить программу вычисления функции при заданных значениях аргументов?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.