Вывести на экран элементы, расположеные перед первым минимальным ?

Информатика | 10 - 11 классы

Вывести на экран элементы, расположеные перед первым минимальным .

Массив, паскаль.

Ответить на вопрос
Ответы (1)
Superbolt 27 февр. 2020 г., 07:19:55

Uses crt ;

var n, i, min, ind : integer ;

a : array[1.

100] of integer ;

begin

writeln('Input "n" and elements of array : ') ;

read(n) ;

read(a[1]) ;

min : = a[1] ;

ind : = 1 ;

for i : = 2 to n do

begin

read(a[i]) ;

if a[i]< ; min then

begin

min : = a[i] ;

ind : = i ;

end ;

end ;

for i : = 1 to ind - 1 do

write(a[i], ' ') ;

end.

Soltanly 15 апр. 2020 г., 10:37:47 | 5 - 9 классы

(Паскаль)2?

(Паскаль)2.

Заполнить с клавиатуры массив из 10 элементов.

Если минимальный элемент находится в первой половине массива увеличить каждый четный элемент массива в два раза, в противном случае массив оставить без изменения.

Вывести новый массив на экран в виде строки.

Hatashaprudhik 4 авг. 2020 г., 01:37:25 | 10 - 11 классы

Дан целочисленный одномерный массив из n - элементов?

Дан целочисленный одномерный массив из n - элементов.

Вывести на экран четные элементы стоящие на нечетных массивов через паскаль.

Orchok 2 мая 2020 г., 17:28:09 | 10 - 11 классы

Задан массив с(9)вывести элементы расположенные за минимальным элементом?

Задан массив с(9)вывести элементы расположенные за минимальным элементом.

Ksana1051 29 янв. 2020 г., 11:47:00 | 5 - 9 классы

Заполнить массив случайным образом и вывести на экран сумму нечетных элементов?

Заполнить массив случайным образом и вывести на экран сумму нечетных элементов.

В паскале).

Maneckoba0sha 21 апр. 2020 г., 16:28:40 | 10 - 11 классы

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный?

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент.

Angelina2016a 26 авг. 2020 г., 04:14:27 | 10 - 11 классы

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран?

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран.

На паскале.

Zvladimirov78 1 мар. 2020 г., 11:54:52 | 5 - 9 классы

Дан целочисленный массив, в нём есть один ноль?

Дан целочисленный массив, в нём есть один ноль.

Вывести на экран все элементы, расположенные до нуля включительно.

Маша999910 26 мар. 2020 г., 23:07:43 | 5 - 9 классы

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале)?

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале).

Наталья19951 14 февр. 2020 г., 14:04:32 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста.

Нужно составить программу в Турбо Паскаль, которая находит минимальный элемент в массиве и ставит его на первое место, при этом все остальные элементы сдвигаются.

Вывести на экран новый массив.

Vasyapupkin201 2 июл. 2020 г., 19:43:53 | 5 - 9 классы

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран?

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран.

Язык Паскаль.

Вы перешли к вопросу Вывести на экран элементы, расположеные перед первым минимальным ?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.