Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале)?

Информатика | 5 - 9 классы

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале).

Ответить на вопрос
Ответы (1)
Inna802010 26 мар. 2020 г., 23:07:49

Program ideone ;

var arr : array[1.

10] of integer ; i, max : integer ;

begin randomize ; max : = 0 ; for i : = 1 to length(arr) do begin arr[i] : = random(100) ; if arr[i] > ; = arr[max] then begin max : = i ; end ; end ; i : = arr[1] ; arr[1] : = arr[max] ; arr[max] : = i ; for i : = 1 to length(arr) do begin writeln(arr[i]) ; end ;

end.

Theayanamirin 20 февр. 2020 г., 07:21:49 | 5 - 9 классы

В среде Turbo Pascal написать программу : используя одномерный массив из 10 чисел найти сумму < ; max" и "min" элемента (входной массив вывести на экран)?

В среде Turbo Pascal написать программу : используя одномерный массив из 10 чисел найти сумму < ; max" и "min" элемента (входной массив вывести на экран).

Adilkami 27 февр. 2020 г., 07:19:50 | 10 - 11 классы

Вывести на экран элементы, расположеные перед первым минимальным ?

Вывести на экран элементы, расположеные перед первым минимальным .

Массив, паскаль.

Hatashaprudhik 4 авг. 2020 г., 01:37:25 | 10 - 11 классы

Дан целочисленный одномерный массив из n - элементов?

Дан целочисленный одномерный массив из n - элементов.

Вывести на экран четные элементы стоящие на нечетных массивов через паскаль.

Ulia026 12 мар. 2020 г., 22:54:59 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста.

Срочно нужно.

Дан одномерный массив, состоящий из 10 элементов.

Вывести на экран в строчку.

Поменять местами значения от 6 - 10 элементов массива элементов массива и снова вывести на экран!

Vojnalex1 19 окт. 2020 г., 08:33:56 | 10 - 11 классы

Поменять местами значения второго и третьего элементов в одномерном массиве?

Поменять местами значения второго и третьего элементов в одномерном массиве.

Вывести на экран исходный массив, заданный пользователем любым способом, и преобразованный массив.

Bazuko 11 мар. 2020 г., 17:03:57 | 10 - 11 классы

В заданном одномерном массиве поменять местами соседние элементы?

В заданном одномерном массиве поменять местами соседние элементы.

Напишите программу на Паскале, заранее спасибо!

Angelina2016a 26 авг. 2020 г., 04:14:27 | 10 - 11 классы

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран?

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран.

На паскале.

Fvfvfv333333333 10 мая 2020 г., 23:32:14 | 10 - 11 классы

Сформировать одномерный целочисленный массив размерностью N?

Сформировать одномерный целочисленный массив размерностью N.

Поменять местами первый элемент с последним, второй с предпоследним.

Вывести на экран исходный и итоговый массивы.

VictoriyaR 5 июн. 2020 г., 20:05:38 | 5 - 9 классы

Помогите пожалуйста составить программы в паскале : 1?

Помогите пожалуйста составить программы в паскале : 1.

Сформировать массив из 15 элементов случайным образом и вывести его на элементы на экран в обратном порядке.

2. дан одномерный массив найдите разность наибольшего и наименьшего элемента этого массива.

Aishakov2000 5 мар. 2020 г., 16:27:29 | 5 - 9 классы

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент?

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент.

Вы перешли к вопросу Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале)?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.