Составить программу, которая будет вводить N чисел и искать максимальное число среди этих чисел?

Информатика | 10 - 11 классы

Составить программу, которая будет вводить N чисел и искать максимальное число среди этих чисел.

1< ; = a[i], N< ; = 100.

Ответить на вопрос
Ответы (1)
Volgong1 18 апр. 2020 г., 19:16:07

Const

n = 100 ;

var

a : array[1.

N] of integer ;

max, i : integer ;

begin

randomize ;

for i : = 1 to n do

begin

writeln(a[i] = '') ;

readln(a[i]) ;

end ;

max : = a[1] ;

for i : = 2 to n do

If a[i]> ; max then begin

max : = a[i] ;

end ;

writeln ;

writeln('Max = ', max) ;

readln ;

End.

Murad345 4 окт. 2020 г., 05:28:04 | 5 - 9 классы

C + + Напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел?

C + + Напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел.

Программа получает на входе целее числа, количество введённых чисел неизвестно, последовательность чисел заканчивается число 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30000.

Программа должна вывести одно число : разность максимального и минимального чисел.

Matsuk01 4 дек. 2020 г., 23:35:43 | 10 - 11 классы

Вводится число N, а затем - N чисел?

Вводится число N, а затем - N чисел.

Определить, сколько среди них пар одинаковых чисел.

2< ; = N< ; = 100.

На паскале.

Смышлённый 30 окт. 2020 г., 17:54:32 | 5 - 9 классы

Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел?

Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел.

Superdiman2012 26 мар. 2020 г., 14:17:48 | 10 - 11 классы

Нужно написать программу на PascalABC?

Нужно написать программу на PascalABC.

Вводится n чисел, найти максимальное двузначное среди них.

ROMSIS2013 24 окт. 2020 г., 03:11:07 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел ( ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального ( наибольшего) из введённых чисел?

Напишите программу, в которой осуществляется ввод целых чисел ( ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального ( наибольшего) из введённых чисел.

Используйте оператор repeat.

Vcyrkina 15 окт. 2020 г., 16:09:15 | 5 - 9 классы

Составь программу, которая вводит 2 целых числа и выводит на экран модуль разности этих чисел?

Составь программу, которая вводит 2 целых числа и выводит на экран модуль разности этих чисел.

Delyahelp123 15 сент. 2020 г., 22:37:44 | 5 - 9 классы

Составить программу которая определяет среди введеных с клавиатуры целых чисел количества нечетных до ввода числа 0?

Составить программу которая определяет среди введеных с клавиатуры целых чисел количества нечетных до ввода числа 0.

Bigibaga 17 нояб. 2020 г., 00:47:40 | 5 - 9 классы

Напишите программу, в которой пользователь вводит 3 дробных числа А В и С?

Напишите программу, в которой пользователь вводит 3 дробных числа А В и С.

Программа должна определить какое из трёх чисел максимальное( самое большое) и вывести его на экран.

Sokolovaolliver 26 сент. 2020 г., 16:53:40 | 5 - 9 классы

Составить программу которая определяет среди введеных с клавиатуры целых чисел количества нечетных , до ввода числа 0 PascalABC?

Составить программу которая определяет среди введеных с клавиатуры целых чисел количества нечетных , до ввода числа 0 PascalABC.

Art900 15 дек. 2020 г., 17:51:32 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТАНаписать программу, которая определяет максимальное число из введённой последовательности положительных чиселзавершение вводом 0?

ПОМОГИТЕ ПОЖАЛУЙСТА

Написать программу, которая определяет максимальное число из введённой последовательности положительных чисел

завершение вводом 0.

Перед вами страница с вопросом Составить программу, которая будет вводить N чисел и искать максимальное число среди этих чисел?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.