Дан вектор размером N поменять местами максимальный и минимальный элементы ( пожалуйста решите, я ничего не понимаю, весь день делаю не получается?

Информатика | 10 - 11 классы

Дан вектор размером N поменять местами максимальный и минимальный элементы ( пожалуйста решите, я ничего не понимаю, весь день делаю не получается.

).

Ответить на вопрос
Ответы (1)
Anaidakdogan 23 сент. 2020 г., 12:32:06

Uses crt ;

var n, i, k, k1, m, min, max : integer ; a : array[1.

1000] of integer ;

begin

randomize ;

read(n) ;

for i : = 1 to n do begin a[i] : = random(101) - 50 ; if max< ; a[i] then begin k : = i ; max : = a[i] ; end ; if min> ; a[i] then begin k1 : = i ; min : = a[i] ; end ; write(a[i], ' ') ;

end ;

writeln ;

m : = a[k] ;

a[k] : = a[k1] ;

a[k1] : = m ;

for i : = 1 to n do write(a[i], ' ') ;

end.

Лёшаайгуля 19 февр. 2020 г., 09:46:34 | 10 - 11 классы

Помогите, пожалуйста, решить задачу :Дана матрица В : 5 * 6?

Помогите, пожалуйста, решить задачу :

Дана матрица В : 5 * 6.

Образовать и напечатать вектор с, элементами которого являются максимальные элементы строк матрицы В.

Найти номер минимального элемента

вектора с.

Sasa023 16 янв. 2020 г., 11:32:58 | 10 - 11 классы

4. Дан одномерный массив А размерности N?

4. Дан одномерный массив А размерности N.

Поменять местами максимальный и минимальный элементы.

LeroyBogdanova 26 мар. 2020 г., 15:00:19 | 5 - 9 классы

Поменять местами минимальный и первый элементы массива?

Поменять местами минимальный и первый элементы массива.

Alina200415 17 янв. 2020 г., 01:07:56 | 10 - 11 классы

1) Поменять местами минимальный четный элемент с последним?

1) Поменять местами минимальный четный элемент с последним.

2)На место максимального отрицательного элемента поместить сумму элементов кратных 3.

(в программе Паскаль) РЕБЯТКИ помогите))))))).

Katyahey 17 нояб. 2020 г., 17:52:13 | 10 - 11 классы

В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы?

В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы.

Флора123 2 сент. 2020 г., 06:16:29 | 10 - 11 классы

1)Дана матрица размером M * N?

1)Дана матрица размером M * N.

В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N.

Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.

Использовать три процедуры (заполнение, смена, вывод).

Тимур149 18 июл. 2020 г., 17:26:36 | 10 - 11 классы

Дан одномерный массив А размерности N?

Дан одномерный массив А размерности N.

Поменять местами максимальный и минимальный элементы.

Елизаветаа654 26 февр. 2020 г., 21:17:46 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива.

Число элементов в массиве не более 10 - ти Pascal.

Galinababenko 9 окт. 2020 г., 06:25:18 | 10 - 11 классы

Написать программу на паскале?

Написать программу на паскале.

Создать двухмерный массив из целых чисел, в котором поменять местами максимальный и минимальный элементы.

Помогите пж.

Gaben345 24 дек. 2020 г., 08:36:03 | 10 - 11 классы

. Поменять местами минимальные и максимальные элементы?

. Поменять местами минимальные и максимальные элементы.

Вопрос Дан вектор размером N поменять местами максимальный и минимальный элементы ( пожалуйста решите, я ничего не понимаю, весь день делаю не получается?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.