4. Дан одномерный массив А размерности N?

Информатика | 10 - 11 классы

4. Дан одномерный массив А размерности N.

Поменять местами максимальный и минимальный элементы.

Ответить на вопрос
Ответы (1)
Klopchenkon 16 янв. 2020 г., 11:33:02

Program nnatovna ;

uses crt ;

const n = 13 ;

var a : array [1.

N] of integer ; i, min, max, temp : integer ;

begin writeln(' * * * alphaues is thinking.

* * * ') ; writeln(' * * * OK * * * ') ; writeln() ; randomize ; writeln('Элементы массива : ') ; {создание и вывод массива} for i : = 1 to n do begin a[i] : = random(100) - 50 ; write (a[i] : 5) ; end ;

{ищем номера мин и мах} min : = 1 ; max : = 1 ; for i : = 1 to n do begin if a[min]> ; a[i] then min : = i ; if a[max]< ; a[i] then max : = i ; end ;

{меняем местами мин и мах элементы} temp : = a[min] ; a[min] : = a[max] ; a[max] : = temp ;

{вывод результата} writeln() ; writeln('Результат : ') ; for i : = 1 to n do write(a[i] : 5) ;

end.

Angel1999861 24 июн. 2020 г., 05:15:04 | 10 - 11 классы

Дан одномерный массив на 15 элементов?

Дан одномерный массив на 15 элементов.

Переставить в обратном порядке элементы, расположенные между максимальным и минимальным элементами, включая их.

Fkg 18 июл. 2020 г., 15:05:07 | 10 - 11 классы

Дан двумерный массив размерностью 5 х 6, заполненный случайным образом?

Дан двумерный массив размерностью 5 х 6, заполненный случайным образом.

Вставить после столбцов с максимальными элементами столбец из единиц.

И поменять местами предпоследний и последний столбцы.

Mehanik8283 15 мар. 2020 г., 22:04:01 | 10 - 11 классы

Дан одномерный массив из n целых чисел?

Дан одномерный массив из n целых чисел.

Составить программу нахождения максимального и минимального элементов.

Annatyrganova11 18 нояб. 2020 г., 15:20:38 | 10 - 11 классы

В произвольно заданных двух 2 одномерных массивах определить максимальные элементы и поменять их местами?

В произвольно заданных двух 2 одномерных массивах определить максимальные элементы и поменять их местами.

(C + + ).

Ellada0308 15 мая 2020 г., 03:38:11 | 5 - 9 классы

ПОМОГИТЕ?

ПОМОГИТЕ!

Дан одномерный массив размерностью 40 элементов, изменяющийся от - 100 до 100.

Определить максимальный элемент массива и его номер без учёта максимального.

Это нужно в паскале.

Тимур149 18 июл. 2020 г., 17:26:36 | 10 - 11 классы

Дан одномерный массив А размерности N?

Дан одномерный массив А размерности N.

Поменять местами максимальный и минимальный элементы.

Wapiro 15 июн. 2020 г., 23:50:17 | 5 - 9 классы

Дан одномерный массив с индексами от 0 до 14, найти индекс минимального и максимального элементов массива(числа вводятся с клавиатуры)?

Дан одномерный массив с индексами от 0 до 14, найти индекс минимального и максимального элементов массива

(числа вводятся с клавиатуры).

Fvfvfv333333333 10 мая 2020 г., 23:32:14 | 10 - 11 классы

Сформировать одномерный целочисленный массив размерностью N?

Сформировать одномерный целочисленный массив размерностью N.

Поменять местами первый элемент с последним, второй с предпоследним.

Вывести на экран исходный и итоговый массивы.

Gaben345 24 дек. 2020 г., 08:36:03 | 10 - 11 классы

. Поменять местами минимальные и максимальные элементы?

. Поменять местами минимальные и максимальные элементы.

Маша999910 26 мар. 2020 г., 23:07:43 | 5 - 9 классы

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале)?

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале).

Вопрос 4. Дан одномерный массив А размерности N?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.