Люди подскажите где ошибка, пожалуйста?

Информатика | 10 - 11 классы

Люди подскажите где ошибка, пожалуйста.

Это Pascal

когда компилирую это и ввожу числа 10 и 5 ответ выходит 0.

0​

program h ;

var a : real ;

b : real ;

c : real ;

begin

a : = b + c ;

WriteLn('Введите числа, которые необходимо сложить : ') ;

readln(b) ;

readln(c) ;

Writeln('Ответ : ', a) ;

end.

Ответить на вопрос
Ответы (1)
Kris9494 23 февр. 2024 г., 15:04:02

Ответ : строку a : = b + c ; нуно поставить перед строкой Writeln('Ответ : ', a) ;

Объяснение : сначала нужно ввести значение в переменную и только потом с ними работать, а не наоборот.

Dandyd 10 мар. 2024 г., 04:48:51 | студенческий

ДАЮ 30 БАЛЛОВ?

ДАЮ 30 БАЛЛОВ!

Выдает такую ошибку, что мне надо исправить я не понимаю Fatal : Syntax error, ")" expected but "identifier D" found Program P2 ;

var a, b : integer ; d, s, p : real ;

Begin

write('введите сторону прямоугольника a = ') ;

readln(a) ;

write('введите сторону прямоугольника b = ') ;

readln(b) ; d : = sqrt(sqr(a) + sqr(b)) ;

writeln('диагональ прямоугольника = 'd) ;

s : = a * b ;

writeln('площадь прямоугольника = 's) ;

p : = 2 * (a + b) ; writeln('периметр прямоугольника = 'p) ;

end.

Гргргр 7 янв. 2024 г., 23:19:23 | 5 - 9 классы

Даны два целых числа A и B (A < ; B)?

Даны два целых числа A и B (A < ; B).

Найти сумму квадратов всех целых чисел от A до B включительно.

В питоне.

Юраконовалов 15 янв. 2024 г., 13:15:51 | студенческий

Пожалуйста нарисуйте это в программе Paint и сделайте ответ фотографией(дам 65 баллов)​?

Пожалуйста нарисуйте это в программе Paint и сделайте ответ фотографией

(дам 65 баллов)​.

SENSEY11111 23 янв. 2024 г., 18:37:43 | студенческий

Выдает такую ошибку , в чем проблема?

Выдает такую ошибку , в чем проблема?

Source.

Pas(13, 11) Fatal : Syntax error, ")" expected but "(" found

Program P1 ;

var a, b, c : integer ;

s, p : real ;

Begin

write('введите координату a = ') ; readln(a) ; write('введите координату b = ') ;

readln(b) ; write('введите координату c = ') ; readln(c) ; P : = (a + b + c) / 2 ;

writeln('периметр треугольника = ', P : 2 : 2) ;

s : = sqrt(p(p - a) * (p - b) * (p - c)) ; writeln('площадь треугольника = ', s : 2 : 2) ;

end.

Школота15лохатрон 1 мар. 2024 г., 07:02:11 | 5 - 9 классы

Вывести нечетные числа из диапазона [a ; b], где a b м?

Вывести нечетные числа из диапазона [a ; b], где a b м.

Б. как четными так и нечетными, а также отрицательными НО обязательно a.

Omertys 17 мар. 2024 г., 03:27:25 | студенческий

Пожалуйста помогитеНапишите программу, которая запрашивает двацелых числа x и y, после чего вычисляет и выводитзначение x в степени y на пайтоне?

Пожалуйста помогите

Напишите программу, которая запрашивает два

целых числа x и y, после чего вычисляет и выводит

значение x в степени y на пайтоне.

Tolyamenseitov 3 янв. 2024 г., 10:12:21 | 10 - 11 классы

Перед вами фрагмент программы :a : = 2018 ;b : = a + 2 ;a : = b - a ;write(b, a) ;Какие числа будут выведены на экран?

Перед вами фрагмент программы :

a : = 2018 ;

b : = a + 2 ;

a : = b - a ;

write(b, a) ;

Какие числа будут выведены на экран?

В качестве ответ запишите числа, разделяя их одинарным пробелом, например, 1 2.

​.

EvdokiomovaUna 16 янв. 2024 г., 19:45:36 | 5 - 9 классы

Дана часть программы?

Дана часть программы.

Определите число, которое выведет программа на экран.

Dmitrievvanya 4 мар. 2024 г., 04:10:55 | 10 - 11 классы

ПОМОГИТЕ СДЕЛАТЬ В ПИТОНЕ?

ПОМОГИТЕ СДЕЛАТЬ В ПИТОНЕ!

Дано неотрицательное число N - количество элементов массива (N< ; = 100)

Заполнить массив из N элементов первыми натуральными трехзначными числами, произведение цифр которых есть трехзначное число.

ДашаВова 30 янв. 2024 г., 05:19:22 | 5 - 9 классы

Даны три числа a, b, с?

Даны три числа a, b, с.

Найти их среднее арифметическое(сумму чисел разделить на их количество).

С клавиатуры вводится число a, количество килобайт.

Переведите это число в байты, биты и мегабайты и выведите значения на экран.

​.

На этой странице находится вопрос Люди подскажите где ошибка, пожалуйста?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.