Выдает такую ошибку , в чем проблема?

Информатика | студенческий

Выдает такую ошибку , в чем проблема?

Source.

Pas(13, 11) Fatal : Syntax error, ")" expected but "(" found

Program P1 ;

var a, b, c : integer ;

s, p : real ;

Begin

write('введите координату a = ') ; readln(a) ; write('введите координату b = ') ;

readln(b) ; write('введите координату c = ') ; readln(c) ; P : = (a + b + c) / 2 ;

writeln('периметр треугольника = ', P : 2 : 2) ;

s : = sqrt(p(p - a) * (p - b) * (p - c)) ; writeln('площадь треугольника = ', s : 2 : 2) ;

end.

Ответить на вопрос
Ответы (1)
Тим135 23 янв. 2024 г., 18:37:47

Ответ :

синтаксис у тебя не верний.

YanockaKisil 25 февр. 2024 г., 05:08:26 | 5 - 9 классы

Задание №1?

Задание №1.

Напишите программу, которая находит сумму цифр чисел между k и р.

Какую ошибку вы допу - стили при выполнении задания?

Про - верьте работу операторов, расположен - ных в теле цикла, путем трассировки.

​.

GuzyaM 29 февр. 2024 г., 13:56:23 | студенческий

Известно, что на доске 8×8 можно расставить 8 ферзей так, чтобы они не били друг друга?

Известно, что на доске 8×8 можно расставить 8 ферзей так, чтобы они не били друг друга.

Вам дана расстановка 8 ферзей на доске, определите, есть ли среди них пара бьющих друг друга.

Входные данные

Программа получает на вход восемь пар чисел, каждое число от 1 до 8 - координаты 8 ферзей.

Dandyd 10 мар. 2024 г., 04:48:51 | студенческий

ДАЮ 30 БАЛЛОВ?

ДАЮ 30 БАЛЛОВ!

Выдает такую ошибку, что мне надо исправить я не понимаю Fatal : Syntax error, ")" expected but "identifier D" found Program P2 ;

var a, b : integer ; d, s, p : real ;

Begin

write('введите сторону прямоугольника a = ') ;

readln(a) ;

write('введите сторону прямоугольника b = ') ;

readln(b) ; d : = sqrt(sqr(a) + sqr(b)) ;

writeln('диагональ прямоугольника = 'd) ;

s : = a * b ;

writeln('площадь прямоугольника = 's) ;

p : = 2 * (a + b) ; writeln('периметр прямоугольника = 'p) ;

end.

Навичок03 26 мар. 2024 г., 10:37:53 | 5 - 9 классы

3. Трамвайный билет имеет шестизначный номер?

3. Трамвайный билет имеет шестизначный номер.

Выяснить, является ли билет "счастливым".

Билет назовем "счастливым", если сумма первых трех цифр равна сумме последних трех цифр.

Примечание.

Так как шестизначное число больше 32767(тип Integer), необходимо номер билета определит как тип Longint( до 10 знаков).

FFK666 9 янв. 2024 г., 14:06:53 | 10 - 11 классы

Расположите строки так, чтобы получилась прогрмма, расчитывающая по двум введенным с клавиатуры вещественным значениям катетов квадрат гипотенузы прямоугольного треугольника?

Расположите строки так, чтобы получилась прогрмма, расчитывающая по двум введенным с клавиатуры вещественным значениям катетов квадрат гипотенузы прямоугольного треугольника.

1) C = A * A + B * B

2) print('Квадрат гипотенузы ', С)

3) A = float(input)

4) print('Введите длины катетов')

5) B = float(input()).

Habibullaeva199 17 февр. 2024 г., 04:31:11 | 5 - 9 классы

Каким будет конечное значение переменной ѕпосле выполнения программы :1?

Каким будет конечное значение переменной ѕ

после выполнения программы :

1.

S = 0

2.

For x in range (3, 6) :

3.

S = S + X

4.

Print(s)

7

0

12

3​.

Balashova123 7 янв. 2024 г., 09:38:54 | студенческий

В задании обязательно нужно использовать процедуру или функцию – для выполнения основной работы?

В задании обязательно нужно использовать процедуру или функцию – для выполнения основной работы.

Если результатом работы подпрограммы является значение простого типа или строка, то разработайте функцию, иначе – процедуру.

При этом данные в процедуру или функцию должны передаваться исключительно через параметры.

Результаты работы процедуры должны передаваться в главную программу также только через параметры.

Результаты работы функции – через имя функции и параметры.

Подпрограмма не должна использовать глобальные переменные ( это требование - в учебных целях ).

Подпрограмма не должна быть откликом на событие ( Button1Click, FormDblClick и т п.

), т е она должна быть полностью самодельной – от заголовка (Procedure ИМЯ …) до конца ( end ; ).

Вот мой вариант :

Программа содержит процедуру подбора пароля.

Известна длина

пароля ( < ; 6 ) и пароль ( латинский ) .

Делает простой перебор

букв входящих в слово – до тех пор, пока слово не совпадет с

паролем.

В качестве результата выдает количество проверенных

вариантов.

Программа должны быть написана в Delphi даю 80 балов если программа будет работать правильно.

ЕфСоня 21 янв. 2024 г., 18:41:38 | 5 - 9 классы

Определите что в перечисленных величинах константы, а что переменные?

Определите что в перечисленных величинах константы, а что переменные.

А)переменная

Б)константа

1.

Высота Останкинской телебашни

2.

Температура воздуха на архипелаге Шпицберген

3.

Географические координаты острова Врангеля

4.

Количество писем, пришедших на электронную почту

5.

Количество минут в часе

6.

Длина железнодорожного пути от Москвы до Санкт - Петербурга

7.

Количество пассажиров в вагоне метро.

Altynova2000 22 янв. 2024 г., 03:56:14 | 5 - 9 классы

Строго на Python?

Строго на Python!

Вводится координаты точки на плоскости х и у.

Определить, попадает ли точка в заштрихованную часть.

Urinkovanadezhd 26 янв. 2024 г., 13:56:32 | 1 - 4 классы

ПОМОГИТЕ ПОЖАЛУЙСТАЗаписать программу на языке Паскаль и определить, что будет выведено в результате работы программы?

ПОМОГИТЕ ПОЖАЛУЙСТА

Записать программу на языке Паскаль и определить, что будет выведено в результате работы программы.

От программы, записанной на алгоритмическом языке, перейти к записи программы на языке Паскаль.

Определить, что будет выведено в результате работы программы.

Алгоритмический язык :

алг

цел s, k

нач

s : = 0

k : = 0

нц пока k< ; 6

s : = s + 2

k : = k + 1

кц

вывод s

кон.

Вы открыли страницу вопроса Выдает такую ошибку , в чем проблема?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся студенческий. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.