Составьте программу, в которой значение переменной с вычисляется поформуле : а + Ь, если а — нечетное (a mod 2 = 1), и а * Ь, если а — четное (а mod2 = 0)?

Информатика | 10 - 11 классы

Составьте программу, в которой значение переменной с вычисляется по

формуле : а + Ь, если а — нечетное (a mod 2 = 1), и а * Ь, если а — четное (а mod

2 = 0).

Ответить на вопрос
Ответы (1)
L200E 11 мар. 2024 г., 12:09:54

Var a, b, s : integer ;

Begin

readln (a, b) ;

if (a mod 2 = 1)

then s : = a + b

else if (a mod 2 = 0)

then s : = a * b ;

write(s) ;

End.

Школота15лохатрон 1 мар. 2024 г., 07:02:11 | 5 - 9 классы

Вывести нечетные числа из диапазона [a ; b], где a b м?

Вывести нечетные числа из диапазона [a ; b], где a b м.

Б. как четными так и нечетными, а также отрицательными НО обязательно a.

Omertys 17 мар. 2024 г., 03:27:25 | студенческий

Пожалуйста помогитеНапишите программу, которая запрашивает двацелых числа x и y, после чего вычисляет и выводитзначение x в степени y на пайтоне?

Пожалуйста помогите

Напишите программу, которая запрашивает два

целых числа x и y, после чего вычисляет и выводит

значение x в степени y на пайтоне.

Damiryusiev 29 февр. 2024 г., 03:38:40 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль ЛЕГКИЙ ВАРИАНД С While.

Yekaterinashev1 9 мар. 2024 г., 17:19:35 | 5 - 9 классы

Задано двузначное число?

Задано двузначное число.

Найдите среднее арифметическое цифр числа.

Напишите программу для решения задачи.

Используя операции div и mod.

Срочно, прошу.

Даю 50 баллов за правильное решение!

Saduakasov04 18 янв. 2024 г., 23:01:23 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

Напишите программу которая получает с клавиатуры 2 целых числа и вычисляет их произведение, используя только операции сложения.

Пробить через repeat(постусловие) pascal abc очень прошу.

Daniilrubik61 30 янв. 2024 г., 06:11:37 | 5 - 9 классы

В результате выполнения программы переменной y присвоено значение 10?

В результате выполнения программы переменной y присвоено значение 10.

Чему равно значение переменной x?

If x < ; 2018 then y : = - 10

else if x > ; 2018 then y : = 0 else y : = 10 ;

Polinka4523 6 февр. 2024 г., 03:09:18 | 10 - 11 классы

Чему будет равна переменная «c» после выполнения этой программы :a : = 22 ;b : = 4 ;c : = a mod b + b ?

Чему будет равна переменная «c» после выполнения этой программы :

a : = 22 ;

b : = 4 ;

c : = a mod b + b ;

Akchurinalina 16 февр. 2024 г., 13:17:34 | 5 - 9 классы

Напишите программу, которая вычисляет площадь и периметр квадрата со стороной равной 3 см (ПАСКАЛЬ) ЧТО БЫ БЫЛО ПРАВИЛЬНО?

Напишите программу, которая вычисляет площадь и периметр квадрата со стороной равной 3 см (ПАСКАЛЬ) ЧТО БЫ БЫЛО ПРАВИЛЬНО!

Как надо!

Nsysoeva29 30 янв. 2024 г., 21:04:14 | 5 - 9 классы

С клавиатуры вводится последовательность натуральных чисел, оканчивающихся числом 0?

С клавиатуры вводится последовательность натуральных чисел, оканчивающихся числом 0.

Количество чисел в последовательности неизвестно.

Программа должна вывести на экран четные числа из этой последовательности, которые не меньше 50.

Dkhaliov1 26 мар. 2024 г., 00:12:31 | студенческий

Переведите с Паскаля на c + + :var count, min, i : integer ;begin min : = 20000 ; count : = 0 ; for i : = 7525 to 13486 do begin if i mod 7 = 0 then if i mod 6 < ; > ; 0 then if i mod 9 < ; > ?

Переведите с Паскаля на c + + :

var count, min, i : integer ;

begin min : = 20000 ; count : = 0 ; for i : = 7525 to 13486 do begin if i mod 7 = 0 then if i mod 6 < ; > ; 0 then if i mod 9 < ; > ; 0 then if i mod 14 < ; > ; 0 then if i mod 21 < ; > ; 0 then begin count : = count + 1 ; if i < ; min then min : = i ; end ; end ; writeln(count, min) ;

end.

​.

Вы перешли к вопросу Составьте программу, в которой значение переменной с вычисляется поформуле : а + Ь, если а — нечетное (a mod 2 = 1), и а * Ь, если а — четное (а mod2 = 0)?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.