С клавиатуры вводится последовательность натуральных чисел, оканчивающихся числом 0?

Информатика | 5 - 9 классы

С клавиатуры вводится последовательность натуральных чисел, оканчивающихся числом 0.

Количество чисел в последовательности неизвестно.

Программа должна вывести на экран четные числа из этой последовательности, которые не меньше 50.

Ответить на вопрос
Ответы (2)
SofiaNike28 30 янв. 2024 г., 21:04:16

Ответ :

var   ; a : array of Integer ;   ; n, i : Integer ;

begin   ; repeat   ;   ; ReadLn (n) ;   ;   ; if n < ; > ; 0 then begin   ;   ;   ; SetLength (a, High (a) + 2) ;   ;   ;   ; a [High (a)] : = n ;   ;   ; end ;   ; until n = 0 ;   ; WriteLn ;   ; for i : = Low (a) to High (a) do   ;   ; if (a[i] > ; = 50) and (a[i] mod 2 = 0) then   ;   ;   ; Write (a [i], ' ') ;   ; ReadLn ;

end.

Dan1loff 30 янв. 2024 г., 21:04:20

= = = = = PascalABC.

NET = = = = =

begin   ; ReadSeqIntegerWhile(p - > ; p < ; > ; 0).

  ;   ; Where(p - > ; p.

IsEven and (p > ; = 50)).

Println

end.

Aidanai250 28 февр. 2024 г., 21:14:24 | 5 - 9 классы

Паскаль программа, срочно?

Паскаль программа, срочно!

Кароче надо с randomize вывести 10 чисел от 1 до 100​.

EvdokiomovaUna 16 янв. 2024 г., 19:45:36 | 5 - 9 классы

Дана часть программы?

Дана часть программы.

Определите число, которое выведет программа на экран.

ДашаВова 30 янв. 2024 г., 05:19:22 | 5 - 9 классы

Даны три числа a, b, с?

Даны три числа a, b, с.

Найти их среднее арифметическое(сумму чисел разделить на их количество).

С клавиатуры вводится число a, количество килобайт.

Переведите это число в байты, биты и мегабайты и выведите значения на экран.

​.

ДдддАааа 2 февр. 2024 г., 01:57:06 | студенческий

Написать программу, которая проверяет, делится ли на 3 число введенная с клавиатуры?

Написать программу, которая проверяет, делится ли на 3 число введенная с клавиатуры.

Если да то, выполните деление, если нет, то выведите на экран сообщение что нельзя поделит без остатка.

Помогите пж!

Namiesfhikova 14 февр. 2024 г., 10:22:51 | студенческий

Идёт ввод натуральных чисел?

Идёт ввод натуральных чисел.

Если было введено не натуральное число, то команда останавливается и в выводе появляется наибольшее четное число из ранее введенных либо если не было введено ни одного натурального числа, то в выводе должна быть надпись "Чётных чисел нет" или что - то похожее

программа python

с помощью цикла while.

Анжелика268 18 февр. 2024 г., 07:10:49 | 5 - 9 классы

Дан одномерный массив B из 20 целых чисел(числа вводятся по формуле (i + 2 * (i - 1)), вывестина экран массив в строку через пробел, найти ивывести максимальный элемент массива?

Дан одномерный массив B из 20 целых чисел

(числа вводятся по формуле (i + 2 * (i - 1)), вывести

на экран массив в строку через пробел, найти и

вывести максимальный элемент массива.

Цвяточек001 24 мар. 2024 г., 14:18:54 | студенческий

Создайте программу нахождения суммы чисел А и В (числа произвольные)?

Создайте программу нахождения суммы чисел А и В (числа произвольные).

​.

Milinaoyc5lf 12 янв. 2024 г., 01:13:59 | студенческий

A1, a2, a3?

A1, a2, a3.

N Дана последовательность целых чисел.

В цепочке положительных чисел есть ли числа в квадрате 3

Надо решить на языке Python.

Милана632 14 мар. 2024 г., 23:48:12 | 5 - 9 классы

Разработать подпрограмму, которая в качестве аргумента получает целое число и проверяет, является ли оно простым?

Разработать подпрограмму, которая в качестве аргумента получает целое число и проверяет, является ли оно простым.

Используя подпрограмму вывести на экран все простые числа из промежутка целых чисел, определенного пользователем.

Pascal ABC.

Русский242 27 янв. 2024 г., 11:28:29 | студенческий

M меньше n, n и m натуральные числа?

M меньше n, n и m натуральные числа.

Вывести на экран числа от m до n которые не являются простыми.

Вопрос С клавиатуры вводится последовательность натуральных чисел, оканчивающихся числом 0?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.