Задано двузначное число?

Информатика | 5 - 9 классы

Задано двузначное число.

Найдите среднее арифметическое цифр числа.

Напишите программу для решения задачи.

Используя операции div и mod.

Срочно, прошу.

Даю 50 баллов за правильное решение!

Ответить на вопрос
Ответы (1)
6KellyJones9 9 мар. 2024 г., 17:19:39

Program n1 ;

var a : integer ;

begin

readln(a) ;

write(((a div 10) + (a mod 10)) / 2) ;

end.

Supernolik333 24 мар. 2024 г., 01:33:13 | 5 - 9 классы

Переведите число 59 записанное в десятичной системе счисления в двоичную восьмеричную и шестнадцатеричную системы счисления Запишите решение и ответ​?

Переведите число 59 записанное в десятичной системе счисления в двоичную восьмеричную и шестнадцатеричную системы счисления Запишите решение и ответ​.

Kolokolchik09 10 янв. 2024 г., 00:14:01 | студенческий

СРОЧНО ДАЮ 30 БАЛЛОВ?

СРОЧНО ДАЮ 30 БАЛЛОВ.

Wowelona 14 янв. 2024 г., 20:24:33 | 5 - 9 классы

Напишите программу (paskal)?

Напишите программу (paskal).

Sharkovka05 1 февр. 2024 г., 22:51:40 | студенческий

Программа на С + +Не сталкивался и с этимПросьба большая помочьСоздать целочисленный массив типа short int размером n?

Программа на С + +

Не сталкивался и с этим

Просьба большая помочь

Создать целочисленный массив типа short int размером n.

Элементы массива инициализируются по следующему алгоритму :

1) число А вводится с консоли ;

2) используя битовые операции, сделать в нем так, чтобы 11 бит был заменён значением 5 - го бита, а остальные сохранили свои значения.

3) присвоить преобразованное число А текшему элементу массива.

Инициализированный массив вывести на печать и найти в нём элементы, у которых старшая четвёрка бит имеет все единицы.

Omertys 17 мар. 2024 г., 03:27:25 | студенческий

Пожалуйста помогитеНапишите программу, которая запрашивает двацелых числа x и y, после чего вычисляет и выводитзначение x в степени y на пайтоне?

Пожалуйста помогите

Напишите программу, которая запрашивает два

целых числа x и y, после чего вычисляет и выводит

значение x в степени y на пайтоне.

EvdokiomovaUna 16 янв. 2024 г., 19:45:36 | 5 - 9 классы

Дана часть программы?

Дана часть программы.

Определите число, которое выведет программа на экран.

Madinabajramova 8 мар. 2024 г., 21:23:13 | 5 - 9 классы

Решите пожалуйста?

Решите пожалуйста!

Автомат получает на вход пятизначное десятичное число.

По полученному числу строится новое десятичное число по следующим правилам.

1. Вычисляются два числа – сумма первой, третьей и пятой цифр и сумма второй и четвёртой цифр заданного числа.

2. Полученные два числа записываются друг за другом в порядке неубывания (без разделителей).

Пример.

Исходное число : 15177.

Поразрядные суммы : 9, 12.

Результат : 912.

Определите, сколько из приведённых ниже чисел могут получиться

в результате работы автомата.

1220 120 210 2012 1920 2019 212 2919 1929

В ответе запишите только количество чисел.

Arisheshka 12 янв. 2024 г., 21:34:34 | студенческий

4. Напишите программный код для следующей задачи : Составьте программу вычисления математического выражения​?

4. Напишите программный код для следующей задачи : Составьте программу вычисления математического выражения​.

ДашаВова 30 янв. 2024 г., 05:19:22 | 5 - 9 классы

Даны три числа a, b, с?

Даны три числа a, b, с.

Найти их среднее арифметическое(сумму чисел разделить на их количество).

С клавиатуры вводится число a, количество килобайт.

Переведите это число в байты, биты и мегабайты и выведите значения на экран.

​.

Damiryusiev 29 февр. 2024 г., 03:38:40 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль ЛЕГКИЙ ВАРИАНД С While.

На этой странице находится ответ на вопрос Задано двузначное число?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.