Нужно составить описание к программеprogram pr1 ;const n = 5 ;var a : array[1?

Информатика | 5 - 9 классы

Нужно составить описание к программе

program pr1 ;

const n = 5 ;

var a : array[1.

N] of integer ;

i, s1, s2 : integer ;

begin

randomize ;

s1 : = 0 ;

s2 : = 0 ;

for i : = 1 to n do begin

a[i] : = random(20) - 8 ;

writeln(a[i] : 4, ' Порядковый номер ', i) ;

end ;

writeln ;

for i : = 1 to n do begin

if i mod 20 then s1 : = s1 + sqr(a[i]) * a[i] ;

if i mod 2 = 0 then s2 : = s2 + sqr(a[i]) ;

end ;

writeln('Сумма 1 = ', s1) ;

writeln('Сумма 2 = ', s2) ;

end.

Ответить на вопрос
Ответы (1)
Gulia1679 11 июн. 2022 г., 12:03:18

Как - то так.

Bdot 4 февр. 2022 г., 06:35:56 | 10 - 11 классы

65) (Д?

65) (Д.

Ф. Муфаззалов, Уфа) Какое число будет напечатано в результате выполнения программы :

var i, k : integer ;

function f(x : integer) : integer ;

var m : integer ;

begin

if x < 10 then f : = x

else begin

m : = f(x div 10) ;

if m < x mod 10 then

f : = x mod 10

else f : = m ;

end ;

end ;

begin

k : = 0 ;

for i : = 1000 to 9999 do

if f(i mod 100) = 1 then

if f(i div 100) = f(i mod 100) then

k : = k + 1 ;

writeln(k) ;

end.

Объясните, пожалуйста.

Serge12 12 янв. 2022 г., 22:07:37 | 5 - 9 классы

СРОЧНООО , ПОМОГИИИТЕ((((Ниже записана программа?

СРОЧНООО , ПОМОГИИИТЕ((((

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, L и M .

Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 0.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x > 0 do begin L : = L + 1 ; if x mod 2 = 0 then M : = M + x mod 10 ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Малой2000 12 мар. 2022 г., 05:10:32 | студенческий

А как быть с этим?

А как быть с этим?

Определите пожалуйста, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 120 :

var i, k : integer ;

function F(x : integer) : integer ;

begin if x < 1 then F : = 1 else F : = F(x - 1) + 3 * F(x - 2) ;

end ;

begin i : = 0 ; readln(K) ; while F(i) < K do i : = i + 1 ; writeln(i) ;

end.

Arzni 4 февр. 2022 г., 15:08:15 | 10 - 11 классы

Перевод кода паскаль в c + +2)var i, sum : integer ;n : real ;beginsum : = 0 ;for i : = 1 to 15 dobeginreadln(n) ;if n = trunc(n) then sum : = sum + 1 ;end ;writeln(sum) ;end?

Перевод кода паскаль в c + +

2)var i, sum : integer ;

n : real ;

begin

sum : = 0 ;

for i : = 1 to 15 do

begin

readln(n) ;

if n = trunc(n) then sum : = sum + 1 ;

end ;

writeln(sum) ;

end.

2

Var

a1, b2, c, d : integer ;

begin

write('Введите числа через пробел : ') ;

read(a1) ;

for d : = 2 to 10 do begin

read(b2) ;

if b2>a1 then inc(c) ;

a1 : = b2 ;

end ;

if c = 9 then writeln('Да') else writeln('Нет') ;

end.

Froggy2005 25 февр. 2022 г., 23:54:15 | 5 - 9 классы

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Var n : integer ;

begin

readln(n) ;

writeln(n div 100 mod 10 * 1000 + n div 10 mod 10 * 100 + n mod 10 * 10 + n div 1000) ;

end.

Doooooos2016 24 мар. 2022 г., 08:38:40 | 10 - 11 классы

СрочноProgram sredarifment ;Var a : array[1?

Срочно

Program sredarifment ;

Var a : array[1.

10] of real ;

i, k : integer ;

C, S, sred : real ;

Begin

For i : = 1 to 10 do begin write ('a[', i, '] = ') ; readln (a[i]) ; end ;

write('введите C : ') ; readln (C) ;

For i : = 1 to 10 do begin If a[i]>C then begin S = S + a[i] ; K = K + 1 ; end ; end ;

sred = S / k ;

Writeln('среднее арифметическое чисел, превосходящих ', C, ' равно ', sred) ;

End.

Помогите чтобы программа запускалась.

Выходит что не верно.

Наатт 18 янв. 2022 г., 09:13:42 | 5 - 9 классы

Перевести из Pascal в Сvar a, b : longint ; n, m : byte ;begin readln(a) ; readln(n) ; b : = 0 ; while a > 0 do begin m : = a mod 10 ; if m n then b : = b * 10 + m ; a : = a div 10 ; end ; while b > 0?

Перевести из Pascal в С

var a, b : longint ; n, m : byte ;

begin readln(a) ; readln(n) ; b : = 0 ; while a > 0 do begin m : = a mod 10 ; if m n then b : = b * 10 + m ; a : = a div 10 ; end ; while b > 0 do begin a : = a * 10 + b mod 10 ; b : = b div 10 ; end ; writeln(a) ;

end.

78FF 20 апр. 2022 г., 21:22:25 | 10 - 11 классы

Переделать из программы Pascal в C#Задание : Шифр атбашconst s1 = 'ABCDEFGHIJKLMNOPQRSTUVWXYZабвгдеёжзийклмнопрстуфхцчшщъыьэюя' ; s2 = 'ZYXWVUTSRQPONMLKJIHGFEDCBAяюэьыъщшчцхфутсрпонмлкйизжедгвба' ;var?

Переделать из программы Pascal в C#

Задание : Шифр атбаш

const s1 = 'ABCDEFGHIJKLMNOPQRSTUVWXYZабвгдеёжзийклмнопрстуфхцчшщъыьэюя' ; s2 = 'ZYXWVUTSRQPONMLKJIHGFEDCBAяюэьыъщшчцхфутсрпонмлкйизжедгвба' ;

var i, p : integer ; s : string ;

begin Write('Введите текст : ') ; Readln(s) ; for i : = 1 to Length(s) do begin p : = Pos(s[i], s1) ; if p>0 then s[i] : = s2[p] end ; Writeln('Результат : ', s)

end.

Дианочка11111111 26 мар. 2022 г., 14:25:30 | 5 - 9 классы

Program numb19 ;Var a, b, c, d, e, f, g : integer ;BeginReadln(a) ; if a mod 2 = 0 then Writeln('da')else Writeln('NO') ; if a div 10 then Writeln('2 zn')else Writeln('1 zn') ;end?

Program numb19 ;

Var a, b, c, d, e, f, g : integer ;

Begin

Readln(a) ; if a mod 2 = 0 then Writeln('da')

else Writeln('NO') ; if a div 10 then Writeln('2 zn')

else Writeln('1 zn') ;

end.

В чём ошибка?

Вы открыли страницу вопроса Нужно составить описание к программеprogram pr1 ;const n = 5 ;var a : array[1?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.