Перевести из Pascal в Сvar a, b : longint ; n, m : byte ;begin readln(a) ; readln(n) ; b : = 0 ; while a > 0 do begin m : = a mod 10 ; if m n then b : = b * 10 + m ; a : = a div 10 ; end ; while b > 0?

Информатика | 5 - 9 классы

Перевести из Pascal в С

var a, b : longint ; n, m : byte ;

begin readln(a) ; readln(n) ; b : = 0 ; while a > 0 do begin m : = a mod 10 ; if m n then b : = b * 10 + m ; a : = a div 10 ; end ; while b > 0 do begin a : = a * 10 + b mod 10 ; b : = b div 10 ; end ; writeln(a) ;

end.

Ответить на вопрос
Ответы (1)
RTWeshСашаПоротков 18 янв. 2022 г., 09:13:45

#include

int main(void) { long int a, b = 0 ; int n, m ; scanf("%d", &a) ; scanf("%d", &n) ; while (a>0) { m = a % 10 ; if (m !

= n) b = b * 10 + m ; a = a / 10 ; } while (b !

= 0) { a = a * 10 + b%10 ; b = b / 10 ; } printf("a = %d", a) ; return 0 ;

}

Пример :

125272

157.

Екатерина29051999 2 янв. 2022 г., 14:32:50 | 10 - 11 классы

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :var a, b : integer ;begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; wr?

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :

var a, b : integer ;

begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; writeln(a) ;

end.

Bdot 4 февр. 2022 г., 06:35:56 | 10 - 11 классы

65) (Д?

65) (Д.

Ф. Муфаззалов, Уфа) Какое число будет напечатано в результате выполнения программы :

var i, k : integer ;

function f(x : integer) : integer ;

var m : integer ;

begin

if x < 10 then f : = x

else begin

m : = f(x div 10) ;

if m < x mod 10 then

f : = x mod 10

else f : = m ;

end ;

end ;

begin

k : = 0 ;

for i : = 1000 to 9999 do

if f(i mod 100) = 1 then

if f(i div 100) = f(i mod 100) then

k : = k + 1 ;

writeln(k) ;

end.

Объясните, пожалуйста.

Элькаспросит 31 янв. 2022 г., 03:16:43 | 5 - 9 классы

Определите что будет напечатано в результате выполнения алкоритма, записанного на паскалеVar a, b : integer ;begina : = 1333 ;b : = (a div 100) * 13 + 5 :a : = (10 * b - a) mod 100 ;writeln (`a = `, a?

Определите что будет напечатано в результате выполнения алкоритма, записанного на паскале

Var a, b : integer ;

begin

a : = 1333 ;

b : = (a div 100) * 13 + 5 :

a : = (10 * b - a) mod 100 ;

writeln (`a = `, a) ;

writeln (`b = `, b) ;

end.

Serge12 12 янв. 2022 г., 22:07:37 | 5 - 9 классы

СРОЧНООО , ПОМОГИИИТЕ((((Ниже записана программа?

СРОЧНООО , ПОМОГИИИТЕ((((

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, L и M .

Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 0.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x > 0 do begin L : = L + 1 ; if x mod 2 = 0 then M : = M + x mod 10 ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Nastjakijam 28 янв. 2022 г., 23:03:19 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число , эта программа

печатает два числа, a и b.

Укажите наибольшее из чисел , при вводе которых алгоритм печатает сначала 2, а потом 8.

Var x, a, b : integer ;

begin

readln(x) ;

a : = 0 ; b : = 0 ;

while x > 0 do begin

a : = a + 1 ;

b : = b + (x mod 100) ;

x : = x div 100 ;

end ;

writeln(a) ; write(b) ;

end.

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Сурок228 2 февр. 2022 г., 14:17:32 | студенческий

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)var n, s : integerbeginn : = 0 ;s : = 402 ;while s>0 dobegins : = s - 10 ;n : = ?

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)

var n, s : integer

begin

n : = 0 ;

s : = 402 ;

while s>0 do

begin

s : = s - 10 ;

n : = n + 3

end ;

write(n)

end.

Agent2013 10 мар. 2022 г., 07:17:40 | студенческий

Дайте ответ пожалуйста?

Дайте ответ пожалуйста!

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, и .

Укажите наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом10.

Var x, a, b : integer ;

begin readln(x) ; a : = 0 ; b : = 1 ; while x > 0 do begin a : = a + 1 ; b : = b * (x mod 8) ; x : = x div 8 ; end ; writeln(a) ; write(b) ;

end.

Froggy2005 25 февр. 2022 г., 23:54:15 | 5 - 9 классы

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Var n : integer ;

begin

readln(n) ;

writeln(n div 100 mod 10 * 1000 + n div 10 mod 10 * 100 + n mod 10 * 10 + n div 1000) ;

end.

Дианочка11111111 26 мар. 2022 г., 14:25:30 | 5 - 9 классы

Program numb19 ;Var a, b, c, d, e, f, g : integer ;BeginReadln(a) ; if a mod 2 = 0 then Writeln('da')else Writeln('NO') ; if a div 10 then Writeln('2 zn')else Writeln('1 zn') ;end?

Program numb19 ;

Var a, b, c, d, e, f, g : integer ;

Begin

Readln(a) ; if a mod 2 = 0 then Writeln('da')

else Writeln('NO') ; if a div 10 then Writeln('2 zn')

else Writeln('1 zn') ;

end.

В чём ошибка?

На этой странице сайта размещен вопрос Перевести из Pascal в Сvar a, b : longint ; n, m : byte ;begin readln(a) ; readln(n) ; b : = 0 ; while a > 0 do begin m : = a mod 10 ; if m n then b : = b * 10 + m ; a : = a div 10 ; end ; while b > 0? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.