Что будет напечатано в результате выполнения следующего фрагмента программы, если значение R равно - 10?

Информатика | 5 - 9 классы

Что будет напечатано в результате выполнения следующего фрагмента программы, если значение R равно - 10?

Read(R) ;

if R = 0 then Y : = R * 10 ;

if R > 0 then Y : = R + 10 ;

if R < 0 then Y : = R * R / 2 ;

writeln ( 'R = ' , R).

Ответить на вопрос
Ответы (1)
Avdienko2004 3 февр. 2022 г., 10:46:34

Программа выведет : R = - 10.

Ты уверена, что программа написана правильно?

Просто код считывает - 10 в R, и ее выводит так, что следующие строчки бесполезны

if R = 0 then Y : = R * 10 ;

if R > 0 then Y : = R + 10 ;

if R < 0 then Y : = R * R / 2 ;

Bdot 4 февр. 2022 г., 06:35:56 | 10 - 11 классы

65) (Д?

65) (Д.

Ф. Муфаззалов, Уфа) Какое число будет напечатано в результате выполнения программы :

var i, k : integer ;

function f(x : integer) : integer ;

var m : integer ;

begin

if x < 10 then f : = x

else begin

m : = f(x div 10) ;

if m < x mod 10 then

f : = x mod 10

else f : = m ;

end ;

end ;

begin

k : = 0 ;

for i : = 1000 to 9999 do

if f(i mod 100) = 1 then

if f(i div 100) = f(i mod 100) then

k : = k + 1 ;

writeln(k) ;

end.

Объясните, пожалуйста.

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Arjaa 17 февр. 2022 г., 08:53:17 | студенческий

Функция F(n), где n – натуральное число, задана следующим образом :Паскальfunction F(n : integer) : integer ;begin if n > 1 then F : = 2 * n + F(n - 2) + F(n - 3) else F : = n + 5 ;end ;Чему будет рав?

Функция F(n), где n – натуральное число, задана следующим образом :

Паскаль

function F(n : integer) : integer ;

begin if n > 1 then F : = 2 * n + F(n - 2) + F(n - 3) else F : = n + 5 ;

end ;

Чему будет равно значение, вычисленное алгоритмом при выполнении вызова F(6)?

Arzni 4 февр. 2022 г., 15:08:15 | 10 - 11 классы

Перевод кода паскаль в c + +2)var i, sum : integer ;n : real ;beginsum : = 0 ;for i : = 1 to 15 dobeginreadln(n) ;if n = trunc(n) then sum : = sum + 1 ;end ;writeln(sum) ;end?

Перевод кода паскаль в c + +

2)var i, sum : integer ;

n : real ;

begin

sum : = 0 ;

for i : = 1 to 15 do

begin

readln(n) ;

if n = trunc(n) then sum : = sum + 1 ;

end ;

writeln(sum) ;

end.

2

Var

a1, b2, c, d : integer ;

begin

write('Введите числа через пробел : ') ;

read(a1) ;

for d : = 2 to 10 do begin

read(b2) ;

if b2>a1 then inc(c) ;

a1 : = b2 ;

end ;

if c = 9 then writeln('Да') else writeln('Нет') ;

end.

Патя20 17 мая 2022 г., 03:09:49 | 5 - 9 классы

Срочно ПжДано целое число х?

Срочно Пж

Дано целое число х.

Вывести на экран модуль числа х.

С помощью PascalABC

Использовать условный оператор If.

Then.

Else.

Kirillokk 12 янв. 2022 г., 05:43:38 | 5 - 9 классы

Определитель значение переменной c после выполнения следующего фрагмента программыA : = 50B : = 10A : = a - 4 * bif a > b then c : = b + 3 * a else c : = b - 5 * a?

Определитель значение переменной c после выполнения следующего фрагмента программы

A : = 50

B : = 10

A : = a - 4 * b

if a > b then c : = b + 3 * a else c : = b - 5 * a.

Sveta55552 29 мар. 2022 г., 07:43:14 | 10 - 11 классы

Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы?

Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы.

Программист торопился и написал программу неправильно.

Вот она :

var x, y : real ;

begin

readln(x, y) ;

if y = 0 then

if y> = x + 1 then

write('принадлежит')

else

write('не принадлежит')

end.

Последовательно выполните следующее :

1)​ приведите пример таких чисел x, y, при которых программа неверно решает поставленную задачу ;

2)​ укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы ; это можно сделать несколькими способами, поэтому можно указать любой способ доработки исходной программы.

Bombaigr01 2 июн. 2022 г., 12:27:20 | студенческий

Помогите дописать программу в с + + ?

Помогите дописать программу в с + + .

Использовать оператор if нельзя.

Дианочка11111111 26 мар. 2022 г., 14:25:30 | 5 - 9 классы

Program numb19 ;Var a, b, c, d, e, f, g : integer ;BeginReadln(a) ; if a mod 2 = 0 then Writeln('da')else Writeln('NO') ; if a div 10 then Writeln('2 zn')else Writeln('1 zn') ;end?

Program numb19 ;

Var a, b, c, d, e, f, g : integer ;

Begin

Readln(a) ; if a mod 2 = 0 then Writeln('da')

else Writeln('NO') ; if a div 10 then Writeln('2 zn')

else Writeln('1 zn') ;

end.

В чём ошибка?

1q22 11 июн. 2022 г., 12:03:16 | 5 - 9 классы

Нужно составить описание к программеprogram pr1 ;const n = 5 ;var a : array[1?

Нужно составить описание к программе

program pr1 ;

const n = 5 ;

var a : array[1.

N] of integer ;

i, s1, s2 : integer ;

begin

randomize ;

s1 : = 0 ;

s2 : = 0 ;

for i : = 1 to n do begin

a[i] : = random(20) - 8 ;

writeln(a[i] : 4, ' Порядковый номер ', i) ;

end ;

writeln ;

for i : = 1 to n do begin

if i mod 20 then s1 : = s1 + sqr(a[i]) * a[i] ;

if i mod 2 = 0 then s2 : = s2 + sqr(a[i]) ;

end ;

writeln('Сумма 1 = ', s1) ;

writeln('Сумма 2 = ', s2) ;

end.

На этой странице находится вопрос Что будет напечатано в результате выполнения следующего фрагмента программы, если значение R равно - 10?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.