Функция F(n), где n – натуральное число, задана следующим образом :Паскальfunction F(n : integer) : integer ;begin if n > 1 then F : = 2 * n + F(n - 2) + F(n - 3) else F : = n + 5 ;end ;Чему будет рав?

Информатика | студенческий

Функция F(n), где n – натуральное число, задана следующим образом :

Паскаль

function F(n : integer) : integer ;

begin if n > 1 then F : = 2 * n + F(n - 2) + F(n - 3) else F : = n + 5 ;

end ;

Чему будет равно значение, вычисленное алгоритмом при выполнении вызова F(6)?

Ответить на вопрос
Ответы (1)
Nika20000000000004 17 февр. 2022 г., 08:53:24

Имеем рекуррентное соотношение для F(n) :

F(n) = 2n + F(n - 2) + F(n - 3) при n > 1, и n + 5 иначе.

F( - 1) = - 1 + 5 = 4

F(0) = 0 + 5 = 5

F(1) = 1 + 5 = 6

F(2) = 2 * 2 + F(0) + F( - 1) = 4 + 5 + 4 = 13

F(3) = 2 * 3 + F(1) + F(0) = 6 + 6 + 5 = 17

F(4) = 2 * 4 + F(2) + F(1) = 8 + 13 + 6 = 27

F(5) = 2 * 5 + F(3) + F(2) = 10 + 17 + 13 = 40

F(6) = 2 * 6 + F(4) + F(3) = 12 + 27 + 17 = 56

Ответ.

F(6) = 56.

Ника1576 24 янв. 2022 г., 12:26:04 | 10 - 11 классы

Два фрагмента программы записанный на языке ПаскальBeginK : = 5 ; N : = 0 ;For i : = 1 to K do ;BeginN : = i + K + N ;N : = n - 5 ;End ;K : = N ;End?

Два фрагмента программы записанный на языке Паскаль

Begin

K : = 5 ; N : = 0 ;

For i : = 1 to K do ;

Begin

N : = i + K + N ;

N : = n - 5 ;

End ;

K : = N ;

End.

Чему равно значение переменной K после выполнения?

Екатерина29051999 2 янв. 2022 г., 14:32:50 | 10 - 11 классы

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :var a, b : integer ;begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; wr?

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :

var a, b : integer ;

begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; writeln(a) ;

end.

Bdot 4 февр. 2022 г., 06:35:56 | 10 - 11 классы

65) (Д?

65) (Д.

Ф. Муфаззалов, Уфа) Какое число будет напечатано в результате выполнения программы :

var i, k : integer ;

function f(x : integer) : integer ;

var m : integer ;

begin

if x < 10 then f : = x

else begin

m : = f(x div 10) ;

if m < x mod 10 then

f : = x mod 10

else f : = m ;

end ;

end ;

begin

k : = 0 ;

for i : = 1000 to 9999 do

if f(i mod 100) = 1 then

if f(i div 100) = f(i mod 100) then

k : = k + 1 ;

writeln(k) ;

end.

Объясните, пожалуйста.

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Сурок228 2 февр. 2022 г., 14:17:32 | студенческий

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)var n, s : integerbeginn : = 0 ;s : = 402 ;while s>0 dobegins : = s - 10 ;n : = ?

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)

var n, s : integer

begin

n : = 0 ;

s : = 402 ;

while s>0 do

begin

s : = s - 10 ;

n : = n + 3

end ;

write(n)

end.

Малой2000 12 мар. 2022 г., 05:10:32 | студенческий

А как быть с этим?

А как быть с этим?

Определите пожалуйста, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 120 :

var i, k : integer ;

function F(x : integer) : integer ;

begin if x < 1 then F : = 1 else F : = F(x - 1) + 3 * F(x - 2) ;

end ;

begin i : = 0 ; readln(K) ; while F(i) < K do i : = i + 1 ; writeln(i) ;

end.

Arzni 4 февр. 2022 г., 15:08:15 | 10 - 11 классы

Перевод кода паскаль в c + +2)var i, sum : integer ;n : real ;beginsum : = 0 ;for i : = 1 to 15 dobeginreadln(n) ;if n = trunc(n) then sum : = sum + 1 ;end ;writeln(sum) ;end?

Перевод кода паскаль в c + +

2)var i, sum : integer ;

n : real ;

begin

sum : = 0 ;

for i : = 1 to 15 do

begin

readln(n) ;

if n = trunc(n) then sum : = sum + 1 ;

end ;

writeln(sum) ;

end.

2

Var

a1, b2, c, d : integer ;

begin

write('Введите числа через пробел : ') ;

read(a1) ;

for d : = 2 to 10 do begin

read(b2) ;

if b2>a1 then inc(c) ;

a1 : = b2 ;

end ;

if c = 9 then writeln('Да') else writeln('Нет') ;

end.

Artur123456783316 2 мар. 2022 г., 13:46:25 | 5 - 9 классы

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на языке программирования ПаскальVar s, k, x : integer ;begins : = 1 ;x : = 2 ;for k : = 1 to 9 dos : = s * x?

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на языке программирования Паскаль

Var s, k, x : integer ;

begin

s : = 1 ;

x : = 2 ;

for k : = 1 to 9 do

s : = s * x ;

writeln(s) ;

end.

Дианочка11111111 26 мар. 2022 г., 14:25:30 | 5 - 9 классы

Program numb19 ;Var a, b, c, d, e, f, g : integer ;BeginReadln(a) ; if a mod 2 = 0 then Writeln('da')else Writeln('NO') ; if a div 10 then Writeln('2 zn')else Writeln('1 zn') ;end?

Program numb19 ;

Var a, b, c, d, e, f, g : integer ;

Begin

Readln(a) ; if a mod 2 = 0 then Writeln('da')

else Writeln('NO') ; if a div 10 then Writeln('2 zn')

else Writeln('1 zn') ;

end.

В чём ошибка?

Ananas1318 9 апр. 2022 г., 02:24:34 | 5 - 9 классы

Алгоритм вычисления значения функции F(n), где n — натуральное число, задан следующими соотношениями :F(1) = 1 ;F(n) = F(n − 1) + n если n>1Чему равно значение функции F(173)?

Алгоритм вычисления значения функции F(n), где n — натуральное число, задан следующими соотношениями :

F(1) = 1 ;

F(n) = F(n − 1) + n если n>1

Чему равно значение функции F(173)?

В ответе запиши только натуральное число.

Вы находитесь на странице вопроса Функция F(n), где n – натуральное число, задана следующим образом :Паскальfunction F(n : integer) : integer ;begin if n > 1 then F : = 2 * n + F(n - 2) + F(n - 3) else F : = n + 5 ;end ;Чему будет рав? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся студенческий. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.