Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы?

Информатика | 10 - 11 классы

Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы.

Программист торопился и написал программу неправильно.

Вот она :

var x, y : real ;

begin

readln(x, y) ;

if y = 0 then

if y> = x + 1 then

write('принадлежит')

else

write('не принадлежит')

end.

Последовательно выполните следующее :

1)​ приведите пример таких чисел x, y, при которых программа неверно решает поставленную задачу ;

2)​ укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы ; это можно сделать несколькими способами, поэтому можно указать любой способ доработки исходной программы.

Ответить на вопрос
Ответы (1)
Анастасия302 29 мар. 2022 г., 07:43:20

Пример (1 ; 1)

var x, y : real ;

begin

readln(x, y) ;

if y = 0 and x> = 0 ory> = x + 1 and x < 0then

write('принадлежит')

else

write('не принадлежит')

end.

Kleo901 4 янв. 2022 г., 20:25:54 | 5 - 9 классы

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область?

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.

Входные данные

Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x - координата, затем – y - координата).

Выходные данные

Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала.

Примеры

входные данные

0.

5 0. 5

выходные данные

YES

входные данные - 0.

5 - 0.

5

выходные данные

NO.

Maxkorzhnev 7 янв. 2022 г., 06:32:51 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО1) с клавиатуры вводятся два целых числа А и В?

ПОМОГИТЕ СРОЧНО

1) с клавиатуры вводятся два целых числа А и В.

Написать программу, которая выводит число 1, если числа равны, и число 0 в противно случае.

2) написать программу, в которой подсчитывается сумма только положительных чисел из трёх данных.

3) определить принадлежит ли точка с координатами (x, y) первой четверти.

Всё надо в паскале написать.

Алиса1317 8 янв. 2022 г., 08:05:37 | 5 - 9 классы

Составить программу, которая печатает true, если точка с координатами (х, у) принадлежит заштрихованной области, и false в противном случае?

Составить программу, которая печатает true, если точка с координатами (х, у) принадлежит заштрихованной области, и false в противном случае.

Serge12 12 янв. 2022 г., 22:07:37 | 5 - 9 классы

СРОЧНООО , ПОМОГИИИТЕ((((Ниже записана программа?

СРОЧНООО , ПОМОГИИИТЕ((((

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, L и M .

Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 0.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x > 0 do begin L : = L + 1 ; if x mod 2 = 0 then M : = M + x mod 10 ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Aneliagross 28 февр. 2022 г., 16:42:03 | студенческий

M11 official :построить программу, которая вводит координаты точки (x, y) и определяет, попадает ли точка в заштрихованную область на рисунке?

M11 official :

построить программу, которая вводит координаты точки (x, y) и определяет, попадает ли точка в заштрихованную область на рисунке.

Попадание на границу области считать попаданием в область.

Помогите пожалуйста.

Ksa84 3 янв. 2022 г., 21:12:08 | 5 - 9 классы

1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 0?

1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 0.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).

2. Что будет на экране после выполнения программы

Var I, s, k : integer ;

Begin .

S : = 0 ;

for i : = 0 to 10 do

s : = s - i + 5 ; writeln(s) ;

End.

Vitaymba200 9 мар. 2022 г., 01:48:45 | студенческий

Написать программу, которая вводит с клавиатуры последовательность из 5 - ти вещественных чисел ипосле ввода каждого числа выводит среднее арифметическое полученной части последовательностиНа паскале ?

Написать программу, которая вводит с клавиатуры последовательность из 5 - ти вещественных чисел ипосле ввода каждого числа выводит среднее арифметическое полученной части последовательности

На паскале (через for to do).

Leravolk05 16 мая 2022 г., 05:51:50 | студенческий

Разработать алгоритм и написать программу вычисления принадлежности точки с заданными координатами (x, y) заштрихованной области?

Разработать алгоритм и написать программу вычисления принадлежности точки с заданными координатами (x, y) заштрихованной области.

Программа должна выдавать текстовое сообщение о принадлежности точки заданной области.

(11).

Dashka1238 27 мая 2022 г., 17:19:06 | 10 - 11 классы

Напишите программу которая определяет делится ли введённое с клавиатуры число на 5?

Напишите программу которая определяет делится ли введённое с клавиатуры число на 5.

Miks86 10 февр. 2022 г., 18:30:48 | 10 - 11 классы

Написать программу на С + + 3?

Написать программу на С + + 3.

Известен факториал числа (вводится с клавиатуры).

Найти это число.

На странице вопроса Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.