С клавиатуры вводится четырёхзначное натуральное число?

Информатика | 5 - 9 классы

С клавиатуры вводится четырёхзначное натуральное число.

Поменяйте в нём местами первую цифру со второй и третью с четвёр -

той.

Затем результат надо вывести на экран.

Оператор вывода в про -

грамме должен быть единственным и выглядеть так : writeln(y).

Ответить на вопрос
Ответы (1)
ИринаМакарова11 20 мар. 2022 г., 09:07:46

Var n, y : integer ; a, b, c, d : integer ;

Begin

readln(n) ;

a : = n div 1000 ;

b : = n div 100 - a * 10 ;

c : = n div 10 - a * 100 - b * 10 ;

d : = n mod 10 ;

y : = b * 1000 + a * 100 + d * 10 + c ;

writeln(y) ;

end.

Пример : 4295 (5290)

Вывод : 2459 (2509).

Dasha29f 10 февр. 2022 г., 20:51:31 | 5 - 9 классы

Дано трехзначное число Х, вводимое с клавиатуры?

Дано трехзначное число Х, вводимое с клавиатуры.

Первую цифру этого числа перенесли в конец.

Вывести на экран полученное число.

( работать в паскале).

Mishan9lm 9 мар. 2022 г., 01:54:43 | студенческий

Поменять местами первую и последнюю цифру числа n?

Поменять местами первую и последнюю цифру числа n.

Rjkmxfr2015 6 янв. 2022 г., 19:49:32 | 5 - 9 классы

1)Вычислить и вывести на экран сумму тех целых чисел из промежутка от 1 до K, которые не делятся на 5 без остатка?

1)Вычислить и вывести на экран сумму тех целых чисел из промежутка от 1 до K, которые не делятся на 5 без остатка.

K вводится с клавиатуры.

2)С клавиатуры вводится целое положительное число.

Определить, сколько в числе цифр.

Рейзудинфаталиев 13 апр. 2022 г., 05:06:49 | 10 - 11 классы

Напишите программу, которая вводит с клавиатуры два целых числа - длины сторон прямоугольника?

Напишите программу, которая вводит с клавиатуры два целых числа - длины сторон прямоугольника.

Затем программа должна вывести на экран друг перед другом : периметр прямоугольника, площадь прямоугольника.

Serega1984637 7 мар. 2022 г., 23:57:06 | 1 - 4 классы

Вывести на экран три числа в порядке, обратном вводу(Язык програмирования Python)?

Вывести на экран три числа в порядке, обратном вводу(Язык програмирования Python).

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Dianamitul 15 янв. 2022 г., 01:37:01 | 5 - 9 классы

Написать программу о нахождении двухзначного числа А?

Написать программу о нахождении двухзначного числа А.

Найти сумму и произведение цифр данного числа, а также вывести новое число, в котором цифры числа А поменялись местами.

Bogdan1romanov 15 февр. 2022 г., 08:26:00 | 5 - 9 классы

(Питон)Трехзначное число называется "симметричным", если первая и последняя его цифры – одинаковы?

(Питон)Трехзначное число называется "симметричным", если первая и последняя его цифры – одинаковы.

Напиши программу, которая принимает с клавиатуры трехзначное число и проверяет, является ли оно "симметричным".

В соответствии с результатом проверки надо вывести на экран соответствующее текстовое сообщение.

Aoverchuk 16 апр. 2022 г., 08:21:23 | 10 - 11 классы

Составить программу?

Составить программу.

Дано число N нужно поменять порядок цифр в этом числе и вывести его.

Число N вводится с клавиатуры.

AliceTzar33 14 мая 2022 г., 17:29:25 | 10 - 11 классы

Помогите пожалуйста) информатика PascalABC1)Составьте программу , которая выводит на экран все двухзначные числа, сумма цифр которых делится на 7?

Помогите пожалуйста) информатика PascalABC

1)Составьте программу , которая выводит на экран все двухзначные числа, сумма цифр которых делится на 7.

2)Составьте программу : с клавиатуры вводятся два натуральных числа x и y.

Вывести на экран все четные числа на отрезке [x, y] и подсчитать сумму этих чисел.

На этой странице находится ответ на вопрос С клавиатуры вводится четырёхзначное натуральное число?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.