Написать программу в которой замена производится по такому правилу : если число делится на 2, то оно умножается на 4?

Информатика | 10 - 11 классы

Написать программу в которой замена производится по такому правилу : если число делится на 2, то оно умножается на 4.

Если нет - к нему прибавляется 1.

P. S.

На Паскале.

Помогите, плиз!

Я в информатике полный ноль.

Спасибо!

Ответить на вопрос
Ответы (1)
Nukuforak 8 мар. 2022 г., 22:29:25

/ / PascalABC.

Net v3.

1var n : integer ;

begin readln(n) ; if n mod 2 = 0 then n : = n * 4 else n : = n + 1 ; writeln(n) ;

end.

Gochirova98 19 янв. 2022 г., 07:42:39 | 5 - 9 классы

Помогите ?

Помогите !

Паскаль!

ИНФОРМАТИКА!

Составить программу , находящую сумму и произведение трёх чисел !

Poltoratskayan 22 янв. 2022 г., 23:28:30 | 10 - 11 классы

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4?

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4.

Паскаль.

Katenok228 26 янв. 2022 г., 21:24:36 | студенческий

Графика паскаль написать программу?

Графика паскаль написать программу.

Ziusupowa 21 янв. 2022 г., 17:34:13 | 5 - 9 классы

Помогите пожалуйста информатика, паскаль?

Помогите пожалуйста информатика, паскаль.

Maxkorzhnev 7 янв. 2022 г., 06:32:51 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО1) с клавиатуры вводятся два целых числа А и В?

ПОМОГИТЕ СРОЧНО

1) с клавиатуры вводятся два целых числа А и В.

Написать программу, которая выводит число 1, если числа равны, и число 0 в противно случае.

2) написать программу, в которой подсчитывается сумма только положительных чисел из трёх данных.

3) определить принадлежит ли точка с координатами (x, y) первой четверти.

Всё надо в паскале написать.

EgorkaLetoff 30 мар. 2022 г., 14:43:03 | 5 - 9 классы

Хелп?

Хелп.

Надо написать программу в Паскале.

Спасибо a + b / 2×(c×c).

Bazalaika2 18 апр. 2022 г., 02:28:18 | студенческий

Вычислить число и месяц в невисокосном году по номеру дня(информатика , написать программу )?

Вычислить число и месяц в невисокосном году по номеру дня(информатика , написать программу ).

Missis862 3 мар. 2022 г., 13:40:22 | 1 - 4 классы

ПОМОГИТЕ ПЛИЗ ОЧЕНЬ НАДО?

ПОМОГИТЕ ПЛИЗ ОЧЕНЬ НАДО.

Напишите программы к этим задачам (ЭТО ПАСКАЛЬ).

Clientmobi0001 29 апр. 2022 г., 05:05:32 | студенческий

Не получается написать программу в Паскале?

Не получается написать программу в Паскале.

Помогитеее.

Kristinakristi35 21 янв. 2022 г., 04:41:20 | 10 - 11 классы

Написать программу на паскале ?

Написать программу на паскале ?

На этой странице находится вопрос Написать программу в которой замена производится по такому правилу : если число делится на 2, то оно умножается на 4?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.