Чисел не принадлежащих промежутку[X, Y), подсчитать количество отрицательных чисел, стоящих на четных местах?

Информатика | 10 - 11 классы

Чисел не принадлежащих промежутку[X, Y), подсчитать количество отрицательных чисел, стоящих на четных местах.

Паскаль, одномерный массив.

Ответить на вопрос
Ответы (1)
Annaiovleva 9 янв. 2022 г., 16:00:19

/ / PascalABC.

NET 3.

3, сборка 1562 от 02.

11. 2017

var

a : array[1.

1000000] of integer ;

i, n, x, y, cnt : integer ;

begin

writeln('Введите кол - во элементов массива') ;

readln(n) ;

writeln('Введите ', n, ' чисел') ;

for i : = 1 to n do read(a[i]) ;

Writeln('Введите промежуток от X до Y') ;

readln(x, y) ;

for i : = x to y do

if (a[i] < 0) then cnt : = cnt + 1 ;

Write('Отрицательных элементов : ', cnt) ;

end.

Sony1111111 2 янв. 2022 г., 16:10:51 | 5 - 9 классы

Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент вмассиве, размерностью N, сформированном пользователем?

Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент в

массиве, размерностью N, сформированном пользователем.

Задача №2 : Дан одномерный массив вещественных чисел в диапазоне от 0 до 1.

Определите сумму и среднее арифметическое его элементов.

Задача №3 : Дан целочисленный одномерный массив, сформированный случайными

числами от 0 до 50.

Подсчитайте, сколько раз встречается в этой таблице число, заданное

пользователем.

Дарья176 17 янв. 2022 г., 22:13:03 | 5 - 9 классы

Сформировать одномерный массив из 15 целых числе, элементы которого выбрасываются случайным образом из отрезка от - 3 до 6?

Сформировать одномерный массив из 15 целых числе, элементы которого выбрасываются случайным образом из отрезка от - 3 до 6.

Подсчитать количество нечетных чисел.

Оформить дружественный интерфейс.

МАША14961 4 февр. 2022 г., 21:56:09 | 10 - 11 классы

Дан массив, посчитать среднее арифметическое элементов, стоящих на четных местах?

Дан массив, посчитать среднее арифметическое элементов, стоящих на четных местах.

Сформировать их этих элементов новый массив.

Kontralan456 10 мар. 2022 г., 22:58:41 | 10 - 11 классы

Помогите Написать программу c + +Найти сумму всех отрицательных четных двузначных чисел?

Помогите Написать программу c + +

Найти сумму всех отрицательных четных двузначных чисел.

Svetafff 19 февр. 2022 г., 01:25:42 | 5 - 9 классы

Ввести n = 100 целых чисел в одномерный массив?

Ввести n = 100 целых чисел в одномерный массив.

Вычислить и вывести

а) сумму чисел, заканчивающихся на 1

б) порядковые номера чисел, кратных 9

Решить в C#.

MultyPulty 8 февр. 2022 г., 14:27:57 | 5 - 9 классы

Ввести с клавиатуры 9 производных чисел (положительных и отрицательных)?

Ввести с клавиатуры 9 производных чисел (положительных и отрицательных).

Вычислить среднее арифметическое нечетных и отрицательных из них.

Нужна программа для паскаля.

Anonimno228 5 янв. 2022 г., 09:14:52 | 5 - 9 классы

Помогите решить?

Помогите решить.

Всё в с + + , для code blocks.

1. Вычислите сумму данных 100 натуральных чисел.

Вводятся 100 чисел, сумму которых необходимо посчитать.

2. Вводится число N, а затем N чисел.

Подсчитайте, сколько среди данных N чисел нулей.

3. Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел.

Вводится число N, а затем N чисел.

Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.

Залина901 18 янв. 2022 г., 03:48:44 | 5 - 9 классы

Даны числа a, b, c, d, e?

Даны числа a, b, c, d, e.

Подсчитать количество отрицательных среди данных чисел.

Chuev 4 июн. 2022 г., 06:07:33 | студенческий

Даны две последовательности целых чисел : a1, a2, ?

Даны две последовательности целых чисел : a1, a2, .

, a8 и b1, b2, .

, b8.

Найти количество четных чисел в первой из них и количество нечетных во

второй.

(Определить функцию, позволяющую распознавать четные числа.

)(решите на с + + ).

Madina0695 6 мая 2022 г., 19:46:29 | 5 - 9 классы

Найти сумму четных натуральных чисел кратных 7 из промежутка[23 ; 49]срочно Паскаль?

Найти сумму четных натуральных чисел кратных 7 из промежутка[23 ; 49]

срочно Паскаль!

Вы перешли к вопросу Чисел не принадлежащих промежутку[X, Y), подсчитать количество отрицательных чисел, стоящих на четных местах?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.