Программа на C + +Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Информатика | 5 - 9 классы

Программа на C + +

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Входные данные

Входная строка содержит два целых числа.

Выходные данные

Программа должна вывести произведение введённых чисел.

Примеры

входные данные

6 12

выходные данные

72

входные данные - 7 15

выходные данные - 105.

Ответить на вопрос
Ответы (2)
Novator82 15 февр. 2022 г., 10:52:24

#include

using namespace std ;

int multiply(int x, int y)

{ if(y = = 0) return 0 ; if(y > 0) return (x + multiply(x, y - 1)) ; if(y < 0) return - multiply(x, - y) ;

}

int main()

{ int a, b ; cin >> a >> b ; cout.

Whovian 15 февр. 2022 г., 10:52:26

#include

#include

int

main(void)

{ int a = 0 ; int b = 0 ; scanf("%d %d", &a, &b) ; long long mul = 0 ; for (int i = 0 ; i < abs(a) ; i + + ) { mul + = b ; } if (a < 0) { mul = - mul ; } printf("%lld \ n", mul) ; return 0 ;

}.

Kleo901 4 янв. 2022 г., 20:25:54 | 5 - 9 классы

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область?

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.

Входные данные

Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x - координата, затем – y - координата).

Выходные данные

Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала.

Примеры

входные данные

0.

5 0. 5

выходные данные

YES

входные данные - 0.

5 - 0.

5

выходные данные

NO.

Yolchuevanar 7 янв. 2022 г., 15:24:04 | 5 - 9 классы

Дано четыре целых числа?

Дано четыре целых числа.

Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - отрицательные

Входные данные : с клвиатуры вводится 4 целых числа

Выходные данные : необходимо вывести на экран преобразованные числа в той же последовательности

Пример входных и выходных данных

Входные данные

3 5 - 2 - 4

Выходные данные

9 25 16 256

C + +.

Аня2002Петрова 4 мар. 2022 г., 02:14:39 | 1 - 4 классы

ДЛЯ ПИТОНАДано натуральное число N?

ДЛЯ ПИТОНА

Дано натуральное число N.

Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае.

Операцией возведения в степень пользоваться нельзя!

Входные данные

Вводится натуральное число.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

3

выходные данные

NO

входные данные

8

выходные данные

YES.

Tatyanashmi 18 апр. 2022 г., 16:10:09 | 5 - 9 классы

ЭТО ЗАДАНИЕ НАДО РЕШИТЬ НА PYTHONПодсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел?

ЭТО ЗАДАНИЕ НАДО РЕШИТЬ НА PYTHON

Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел.

Входные данные

Вводится число N, а затем N чисел.

Выходные данные

Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.

Примеры

Входные данные

5

28

0

0

0

0

Выходные данные

4

1

0.

Tem04ka 12 апр. 2022 г., 15:21:31 | 5 - 9 классы

Задание решать на PYTHONВычислите сумму данных 100 натуральных чисел?

Задание решать на PYTHON

Вычислите сумму данных 100 натуральных чисел.

Входные данные

Вводятся 100 чисел, сумму которых необходимо посчитать.

Выходные данные

Программа должна вывести единственное число - полученную сумму.

GooDStaf 10 мар. 2022 г., 07:14:29 | 5 - 9 классы

Дано целое число n?

Дано целое число n.

Выведите следующее за ним четное число.

Входные данные

Вводится целое положительное число, не превышающее 1000.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

7

выходные данные

8

входные данные

8

выходные данные

10.

Аьчндhfgkg 19 февр. 2022 г., 02:43:38 | 5 - 9 классы

Программа в C + +Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

Программа в C + +

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

Входные данные

Входная строка содержит единственное число – требуемое количество чисел N .

Выходные данные

Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами.

Примеры

входные данные

5

выходные данные

2 4 6 8 10.

Name505 11 мар. 2022 г., 14:58:45 | 10 - 11 классы

Программа на с + +Дан массив, состоящий из целых чисел?

Программа на с + +

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные

Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Примеры

входные данные

5

1 2 3 4 5

выходные данные

4.

Bulambaev03 4 мар. 2022 г., 20:18:35 | 10 - 11 классы

На питонеВыведите все четные элементы списка?

На питоне

Выведите все четные элементы списка.

Входные данные

Вводится список чисел.

Все числа списка находятся на одной строке.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

1 2 2 3 3 3 4

выходные данные

2 2 4.

Физика6 30 мар. 2022 г., 16:38:32 | 10 - 11 классы

Помогите, надо записать эту задачу в с + + ?

Помогите, надо записать эту задачу в с + + .

В кафе мороженое продают по три шарика и по пять шариков.

Можно ли купить ровно k шариков мороженого?

Входные данные

Вводится число k (целое, положительное)

Выходные данные

Программа должна вывести слово YES, если при таких условиях можно набрать ровно k шариков (не больше и не меньше), в противном случае - вывести NO.

Примеры

входные данные

3

выходные данные

YES

входные данные

1

выходные данные

NO.

Вы перешли к вопросу Программа на C + +Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.