ИВТ 99 БАЛЛОВ?

Информатика | 5 - 9 классы

ИВТ 99 БАЛЛОВ!

Напишите программу в паскале

Даны два БоЛьШуЩиХ ЧиСЛа.

Проверьте, делится ли их произведение на девять.

Формат файла входных данных :

В двух строках входного файла даны два целых неотрицательных числа, по одному в строке.

Запись каждого из них состоит из не более чем 106 цифр.

Формат файла выходных данных :

В единственной строке выходного файла выведите "YES", если произведение данных чисел делится на девять, и "NO" в противном случае (без кавычек).

Пример :

72

840

YES

3

5

NO

Ограничение по времени : 3 сек

Ограничение по памяти : 256 Мб

Обычная программа по типу перемножить числа и проверить, кратно ли произведение 9 НЕ ПОДХОДИТ

Пожалуйста, учитывайте ограничения по времени и памяти.

Ответить на вопрос
Ответы (1)
AS58DF 3 янв. 2022 г., 09:42:29

Вычислим остатки от деления обоих чисел на 9, для этого заметив, что у числа 10a + c такой же остаток, что и у a + c.

Тогда можно, считывая цифру за цифрой, получить остаток для всего числа.

Дальше проверяем, чем равно произведение остатков : если делится на 9, то произведение делится на 9, иначе не делится.

Function mod9(f : text) : integer ;

var c : char ; rem : integer ;

begin rem : = 0 ; while not eoln(f) do begin read(f, c) ; rem : = (rem + ord(c) - ord('0')) mod 9 ; end ; readln(f) ; mod9 : = rem ;

end ;

var f : text ; a : integer ;

begin assign(f, 'input.

Txt') ; reset(f) ; a : = mod9(f) * mod9(f) ; close(f) ; assign(f, 'output.

Txt') ; rewrite(f) ; writeln(f, a) ; if a mod 9 = 0 then write(f, 'YES') else write(f, 'NO') ; close(f) ;

end.

Kleo901 4 янв. 2022 г., 20:25:54 | 5 - 9 классы

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область?

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.

Входные данные

Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x - координата, затем – y - координата).

Выходные данные

Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала.

Примеры

входные данные

0.

5 0. 5

выходные данные

YES

входные данные - 0.

5 - 0.

5

выходные данные

NO.

Аня2002Петрова 4 мар. 2022 г., 02:14:39 | 1 - 4 классы

ДЛЯ ПИТОНАДано натуральное число N?

ДЛЯ ПИТОНА

Дано натуральное число N.

Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае.

Операцией возведения в степень пользоваться нельзя!

Входные данные

Вводится натуральное число.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

3

выходные данные

NO

входные данные

8

выходные данные

YES.

GooDStaf 10 мар. 2022 г., 07:14:29 | 5 - 9 классы

Дано целое число n?

Дано целое число n.

Выведите следующее за ним четное число.

Входные данные

Вводится целое положительное число, не превышающее 1000.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

7

выходные данные

8

входные данные

8

выходные данные

10.

Margo196 15 февр. 2022 г., 10:52:22 | 5 - 9 классы

Программа на C + +Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Программа на C + +

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Входные данные

Входная строка содержит два целых числа.

Выходные данные

Программа должна вывести произведение введённых чисел.

Примеры

входные данные

6 12

выходные данные

72

входные данные - 7 15

выходные данные - 105.

Аьчндhfgkg 19 февр. 2022 г., 02:43:38 | 5 - 9 классы

Программа в C + +Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

Программа в C + +

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

Входные данные

Входная строка содержит единственное число – требуемое количество чисел N .

Выходные данные

Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами.

Примеры

входные данные

5

выходные данные

2 4 6 8 10.

Sergo2001 2 мар. 2022 г., 16:36:34 | 5 - 9 классы

Дано несколько чисел?

Дано несколько чисел.

Вычислите их сумму.

Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

Какое наименьшее число переменных нужно для решения этой задачи?

Входные данные

В первой строке вводится натуральное число N - количество чисел.

В следующих N строках вводится по одному целому числу.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

2

235

56

выходные данные

291

решение для паскаля.

Катя45879 4 янв. 2022 г., 23:19:11 | 5 - 9 классы

Задача 9Дано натуральное четырехзначное число?

Задача 9

Дано натуральное четырехзначное число.

Найти наименьшую нечетную цифру в числовой записи данного числа.

Формат входных данных :

Входной файл содержит натуральное четырехзначное число.

Формат выходных данных :

Выведите наименьшую нечетную цифру в числовой записи данного числа.

Если нечетных цифр в числе нет, выведите в выходной файл - 1.

Примеры :

Вход

1234

Выход

1.

Bulambaev03 4 мар. 2022 г., 20:18:35 | 10 - 11 классы

На питонеВыведите все четные элементы списка?

На питоне

Выведите все четные элементы списка.

Входные данные

Вводится список чисел.

Все числа списка находятся на одной строке.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

1 2 2 3 3 3 4

выходные данные

2 2 4.

Физика6 30 мар. 2022 г., 16:38:32 | 10 - 11 классы

Помогите, надо записать эту задачу в с + + ?

Помогите, надо записать эту задачу в с + + .

В кафе мороженое продают по три шарика и по пять шариков.

Можно ли купить ровно k шариков мороженого?

Входные данные

Вводится число k (целое, положительное)

Выходные данные

Программа должна вывести слово YES, если при таких условиях можно набрать ровно k шариков (не больше и не меньше), в противном случае - вывести NO.

Примеры

входные данные

3

выходные данные

YES

входные данные

1

выходные данные

NO.

Adyalera 17 февр. 2022 г., 04:44:26 | 5 - 9 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Найдите количество различных чисел.

Формат входных данных

Первая строка входного файла содержит целое число N (1.

На этой странице находится вопрос ИВТ 99 БАЛЛОВ?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.