Напишите программу на паскале которая решает уравнение ax ^ 2 + bx + c = 0 используя циклы?

Информатика | 5 - 9 классы

Напишите программу на паскале которая решает уравнение ax ^ 2 + bx + c = 0 используя циклы.

Ответить на вопрос
Ответы (1)
Liananail09 5 февр. 2022 г., 07:13:46

Для Одри можно и покороче ))

Только для случая одного корня печатается 2 одинаковых.

Так тоже можно

Var a, b, c, d : real ;

Begin

WriteLn('Решение ax ^ 2 + bx + c = 0') ;

WriteLn('Введите a b с ') ; ReadLn (a, b, c) ;

if a = 0 then WriteLn('Это не квадратное уравнение.

Решайте его сами!

')

else

begin

d : = b * b - 4 * a * c ;

if d.

Chichkova99 10 янв. 2022 г., 12:42:59 | 5 - 9 классы

СРОЧНОО?

СРОЧНОО!

ПО ИНФОРМАТИКЕ ПОЖАЛУЙСТА!

Вывести на экран квадраты и кубы целых чисел от 1 до 8

Программа ПаСКАЛЬ

с циклами , , Пока" "До".

Bonushajon 2 янв. 2022 г., 09:23:59 | 5 - 9 классы

Напишите программу(на паскале), которая вычисляет сумму всех двузначных положительных нечетных чисел?

Напишите программу(на паскале), которая вычисляет сумму всех двузначных положительных нечетных чисел.

Исла 10 янв. 2022 г., 01:32:17 | 1 - 4 классы

Напишите любые 5 программ с циклом со счетчиком в PascalABC?

Напишите любые 5 программ с циклом со счетчиком в PascalABC.

Svna3staKatrm 15 мар. 2022 г., 04:17:33 | 10 - 11 классы

Помогите?

Помогите!

Напишите пожалуйста блок - схему и программу для Паскаля!

KristinaHikitenko6 3 февр. 2022 г., 05:12:06 | 1 - 4 классы

Какой оператор в языке Паскаль является оператором цикла?

Какой оператор в языке Паскаль является оператором цикла.

Alykova1 24 мар. 2022 г., 19:05:12 | 1 - 4 классы

Какой оператор в языке Паскаль является оператором цикла?

Какой оператор в языке Паскаль является оператором цикла.

Lexan4223 11 янв. 2022 г., 16:35:36 | 1 - 4 классы

Нужно написать программу для ПАСКАЛЬ АВС, (тема : Циклы с пред - пост - условием)что бы программа выводила на экран знак « * » до тех пор, пока не будет введен с клавиатуры знак «0»?

Нужно написать программу для ПАСКАЛЬ АВС, (тема : Циклы с пред - пост - условием)что бы программа выводила на экран знак « * » до тех пор, пока не будет введен с клавиатуры знак «0».

Missis862 3 мар. 2022 г., 13:40:22 | 1 - 4 классы

ПОМОГИТЕ ПЛИЗ ОЧЕНЬ НАДО?

ПОМОГИТЕ ПЛИЗ ОЧЕНЬ НАДО.

Напишите программы к этим задачам (ЭТО ПАСКАЛЬ).

Kkv22032002 4 июн. 2022 г., 16:06:20 | студенческий

Правильно ли составлена схема к заданной системе?

Правильно ли составлена схема к заданной системе?

Если нет, исправьте пожалуйста.

Напишите программу для Паскаля.

Vladuk9666 4 июн. 2022 г., 18:31:49 | 5 - 9 классы

Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Напишите программу, которая считывает два целых положительных числа aa и bb и выводит наибольшее значение из них.

Вы открыли страницу вопроса Напишите программу на паскале которая решает уравнение ax ^ 2 + bx + c = 0 используя циклы?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.