Дан одномерный массив на 15 элементов?

Информатика | 10 - 11 классы

Дан одномерный массив на 15 элементов.

Переставить в обратном порядке элементы, расположенные между максимальным и минимальным элементами, включая их.

Ответить на вопрос
Ответы (1)
Кирюха22876 24 июн. 2020 г., 05:15:09

Program Pr1 ;

uses crt ;

var mas : array[1.

15] of integer ; i, max, min, b, v : integer ;

Begin

clrscr ;

for i : = 1 to 15 do mas[i] : = random(10) ;

for i : = 1 to 15 do write(mas[i]) ;

max : = 0 ;

min : = 100000 ;

b : = 0 ;

for i : = 1 to 15 do begin if mas[i]> ; max then max : = i ; if mas[i]< ; min then min : = i ; end ;

if max> ; min then for i : = min to max div 2 do begin v : = mas[max - b] ; mas[max - b] : = mas[i] ; mas[i] : = v ; b : = b + 1 ; end

else for i : = max to min div 2 do begin v : = mas[min - b] ; mas[min - b] : = mas[i] ; mas[i] : = v ; b : = b + 1 ; end ;

writeln() ;

for i : = 1 to 15 do write(mas[i]) ;

end.

Mehanik8283 15 мар. 2020 г., 22:04:01 | 10 - 11 классы

Дан одномерный массив из n целых чисел?

Дан одномерный массив из n целых чисел.

Составить программу нахождения максимального и минимального элементов.

Veronica1902 22 окт. 2020 г., 22:58:05 | 10 - 11 классы

Помогите пожалуйста написать программу на паскале : дан массив целых чисел?

Помогите пожалуйста написать программу на паскале : дан массив целых чисел.

Найти количество элементов, кратных 5, расположенных между максимальным и минимальным элементами массива (включая их).

Sasa023 16 янв. 2020 г., 11:32:58 | 10 - 11 классы

4. Дан одномерный массив А размерности N?

4. Дан одномерный массив А размерности N.

Поменять местами максимальный и минимальный элементы.

SRGB 14 июн. 2020 г., 21:44:57 | 5 - 9 классы

Дан массив A размера N и целые числа K и L (1 ≤ K < ; L ≤ N)?

Дан массив A размера N и целые числа K и L (1 ≤ K < ; L ≤ N).

Переставить в обратном порядке элементы массива, расположенные между элементами (AK и AL индексами), не включая эти элементы.

СРОЧНОООО!

Maxtv 20 дек. 2020 г., 13:51:56 | 10 - 11 классы

Дан массив размера n x n?

Дан массив размера n x n.

Найдите сумму, минимальный и максимальный из его элементов, расположенных над главной и над побочной диагоналями (элементы обеих диагоналей включить в рассмотрение).

Sofya2003 28 июн. 2020 г., 17:46:18 | 10 - 11 классы

Ввести одномерный массив A, вывести его?

Ввести одномерный массив A, вывести его.

Переставить в обратном порядке все элементы между максимальным и предпоследним отрицательным элементом.

Помогите, не могу найти предпоследний элемент в массиве, и как их переставить?

Тимур149 18 июл. 2020 г., 17:26:36 | 10 - 11 классы

Дан одномерный массив А размерности N?

Дан одномерный массив А размерности N.

Поменять местами максимальный и минимальный элементы.

Julia8282 3 дек. 2020 г., 11:36:00 | 5 - 9 классы

Дан одномерный массив, состоящий из N элементов?

Дан одномерный массив, состоящий из N элементов.

Найти максимальный из нечетных элементов массива.

DeadGirl5 6 сент. 2020 г., 01:59:41 | 10 - 11 классы

Turbo Pascal * * * * (Дан одномерный числовой массив?

Turbo Pascal * * * * (Дан одномерный числовой массив.

Определить произведение элементов массива, расположенных между максимальным и «центральным» элементами массива (предполагается, что число элементов – нечетное и максимальный единственный).

Osya00 4 дек. 2020 г., 15:10:44 | 10 - 11 классы

В одномерном массиве из 10 элементов определить местоположение минимального и максимального элементов?

В одномерном массиве из 10 элементов определить местоположение минимального и максимального элементов.

Обнулить элементы, стоящие между ними , а также вывести полученный массив.

На этой странице находится вопрос Дан одномерный массив на 15 элементов?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.