Дан двумерный массив размерностью 5 х 6, заполненный случайным образом?

Информатика | 10 - 11 классы

Дан двумерный массив размерностью 5 х 6, заполненный случайным образом.

Вставить после столбцов с максимальными элементами столбец из единиц.

И поменять местами предпоследний и последний столбцы.

Ответить на вопрос
Ответы (1)
Максимчикогл 18 июл. 2020 г., 15:05:08

Type

mas = array[, ] of integer ;

var

i, j, ik, jk, k, max : integer ;

a : mas ;

b : array[0.

5]of integer ; / / вспомогательный массив

begin

setlength(a, 5, 6) ;

writeln('Массив : ') ;

for i : = 0 to 4 do begin for j : = 0 to 5 do begin a[i, j] : = random( - 10, 10) ; write(a[i, j] : 4) ; end ; writeln ; end ;

writeln('Вставка столбцов : ') ; / / в массиве b признак наличия в столбце максимума

for i : = 0 to 4 do for j : = 1 to 5 do if a[i, j]> ; max then max : = a[i, j] ;

for i : = 0 to 4 do for j : = 0 to 5 do if a[i, j] = max thenb[j] : = 1 ;

for i : = 0 to 5 do k : = k + b[i] ;

k : = 5 + k ;

setlength(a, 5, k + 1) ;

jk : = k ;

for j : = 5 downto 0 do begin if b[j] = 1 then begin for ik : = 0 to 4 do a[ik, jk] : = 1 ; jk : = jk - 1 ; end ; for ik : = 0 to 4 do a[ik, jk] : = a[ik, j] ; jk : = jk - 1 ; end ;

for i : = 0 to 4 do begin for j : = 0 to k do write(a[i, j] : 4) ; writeln ; end ;

writeln('Обмен столбцов : ') ;

for i : = 0 to 4 do begin b[i] : = a[i, k - 1] ; a[i, k - 1] : = a[i, k] ; a[i, k] : = b[i] ; end ;

for i : = 0 to 4 do begin for j : = 0 to k do write(a[i, j] : 4) ; writeln ; end ;

end.

Ванига 13 июн. 2020 г., 19:28:24 | 5 - 9 классы

Дан двумерный массив?

Дан двумерный массив.

Вывести на экран все элементы S - го столбца массива.

Lera184567 21 февр. 2020 г., 13:53:50 | 10 - 11 классы

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ?

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ.

ПО ПАСКАЛЬ!

Задание : Дан двумерный массив А состоящий из 4 строк и 5 столбцов .

Найти, сколько положительных элементов содержит данная матрица в каждом столбце.

Sasa023 16 янв. 2020 г., 11:32:58 | 10 - 11 классы

4. Дан одномерный массив А размерности N?

4. Дан одномерный массив А размерности N.

Поменять местами максимальный и минимальный элементы.

Ry17012002 16 дек. 2020 г., 06:06:08 | 10 - 11 классы

C + + Заполнить двумерный числовой массив С(6, 6) целыми числами?

C + + Заполнить двумерный числовой массив С(6, 6) целыми числами.

Найти столбец с наибольшим произведением элементов и поменять его местами с первым столбцом.

SashoK200111 19 мар. 2020 г., 11:34:20 | 5 - 9 классы

Дан двумерный массив A(n ×m) ?

Дан двумерный массив A(n ×m) .

Найти количество элементов больших 5 в последнем столбце матрицы.

Тимур149 18 июл. 2020 г., 17:26:36 | 10 - 11 классы

Дан одномерный массив А размерности N?

Дан одномерный массив А размерности N.

Поменять местами максимальный и минимальный элементы.

Kris656 29 мая 2020 г., 11:19:10 | 10 - 11 классы

Написать программу и блок - схему для решения следующей задачи?

Написать программу и блок - схему для решения следующей задачи.

В двумерном массиве, состоящем из целочисленных элементов, поменять местами : в каждом столбце первый и последний отрицательные элементы ;

(Паскаль).

Fvfvfv333333333 10 мая 2020 г., 23:32:14 | 10 - 11 классы

Сформировать одномерный целочисленный массив размерностью N?

Сформировать одномерный целочисленный массив размерностью N.

Поменять местами первый элемент с последним, второй с предпоследним.

Вывести на экран исходный и итоговый массивы.

Alinakim200796 10 апр. 2020 г., 23:49:31 | 10 - 11 классы

Дан двумерный массив A целого типа размером 5x5, заполненный случайными числами в диапазоне от 1 до 10?

Дан двумерный массив A целого типа размером 5x5, заполненный случайными числами в диапазоне от 1 до 10.

Замените значения всех элементов пятого столбца на число 5.

Зарание спасибо!

Annst5inabald 14 дек. 2020 г., 23:08:46 | 10 - 11 классы

Помогите с информатикой 60 баллов?

Помогите с информатикой 60 баллов.

Двумерный массив.

Паскаль.

1) Дан двумерный массив размерностью 5 на 7.

Найти максимальный элемент массива.

2) Дан двумерный массив размерностью 5 на 7.

Найти произведение четных элементов.

На этой странице находится ответ на вопрос Дан двумерный массив размерностью 5 х 6, заполненный случайным образом?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.