Ученики школы № 100 любят загадывать загадки?

Информатика | 5 - 9 классы

Ученики школы № 100 любят загадывать загадки.

Один ученик задумал два целых числа от 0 до 1000 и сообщил вам их сумму и их произведение.

Напишите программу, угадывающую задуманные числа.

Ответить на вопрос
Ответы (1)
Ромчик64 28 янв. 2022 г., 17:08:18

Var s, p, a, b : integer ;

begin

readln(s, p) ;

a : = round((s + sqrt(s * s - 4 * p)) / 2) ;

b : = s - a ;

writeln(a, ' ', b) ;

end.

Пример :

73 1200

48 25.

Yanastolnikowa 18 янв. 2022 г., 13:43:22 | 5 - 9 классы

Напишите программу?

Напишите программу!

Является ли сумма трех чисел четным числом?

Антон480 25 янв. 2022 г., 17:36:39 | 5 - 9 классы

Ученик задумал целое число от - 10 до 10?

Ученик задумал целое число от - 10 до 10.

Какова вероятность что квадрат этого числа меньше 10.

Dim250696 21 мар. 2022 г., 00:10:52 | 5 - 9 классы

Напишите программу в PascalABC : нахождение наибольшего целого делителя целого числа?

Напишите программу в PascalABC : нахождение наибольшего целого делителя целого числа.

Alinasokolova123 14 мар. 2022 г., 07:51:13 | 5 - 9 классы

Ученик задумал целое число от - 10 до 10?

Ученик задумал целое число от - 10 до 10.

Какова вероятность что квадрат этого числа больше 25.

Margo196 15 февр. 2022 г., 10:52:22 | 5 - 9 классы

Программа на C + +Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Программа на C + +

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Входные данные

Входная строка содержит два целых числа.

Выходные данные

Программа должна вывести произведение введённых чисел.

Примеры

входные данные

6 12

выходные данные

72

входные данные - 7 15

выходные данные - 105.

Dinam03777 29 мая 2022 г., 06:58:52 | 5 - 9 классы

Напишите программу которая сравнивает три числа и выводит произведение двух наименьших?

Напишите программу которая сравнивает три числа и выводит произведение двух наименьших.

Dianamitul 15 янв. 2022 г., 01:37:01 | 5 - 9 классы

Написать программу о нахождении двухзначного числа А?

Написать программу о нахождении двухзначного числа А.

Найти сумму и произведение цифр данного числа, а также вывести новое число, в котором цифры числа А поменялись местами.

Dmitriy2005rus 2 мар. 2022 г., 23:03:03 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит н?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

(Паскаль).

Волк151 28 мар. 2022 г., 04:22:36 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит на?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

3) напишите программу, которая спрашивает целые числа а и b и выводит на экран количество чётных и нечётных чисел в диапазоне от а до b

4) напишите программу, которая спрашивает целое число n , целые числа а и b, и выводит на экран n случайных чисел от а до b.

Даша2900 28 февр. 2022 г., 13:36:14 | 1 - 4 классы

9 класс ?

9 класс !

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — при знак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30 000.

Программа должна вывести два числа : длину последовательности и сумму чётных чисел.

На этой странице вы найдете ответ на вопрос Ученики школы № 100 любят загадывать загадки?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.