Входной замок Лисы Алисы работает следующим образом : если введено натуральное число, которое меньше 100 или больше 999 - на дисплее устройства появляется надпись False если у введённого числа сумма ?

Информатика | 5 - 9 классы

Входной замок Лисы Алисы работает следующим образом : если введено натуральное число, которое меньше 100 или больше 999 - на дисплее устройства появляется надпись False если у введённого числа сумма цифр равна 13 - появляется Enter и можно войти ; в остальных случаях появляется надпись LOCK

Входные данные : натуральное число N (1 больше N меньше 10000

Выходные данные : необходимо вывести надпись которая должна быть на дисплее

Пример

Ввод 2 Вывод FALSE

Ввод 427 Вывод ENTER

Ввод 318 Вывод LOCK.

Ответить на вопрос
Ответы (1)
Mariaмаша 28 янв. 2022 г., 00:32:12

/ / PascalABC.

NET версия 3.

2, сборка 1389 / / Если программа не запускается, то обновите версию

begin var n : = ReadLnInteger('n = ') ; if (n < 100) or (n > 999) then begin writeln('FALSE') ; Halt ; end ; n : = n div 100 + (n div 10) mod 10 + n mod 10 ; if n = 13 then writeln('ENTER') else writeln('LOCK') ;

end.

Yolchuevanar 7 янв. 2022 г., 15:24:04 | 5 - 9 классы

Дано четыре целых числа?

Дано четыре целых числа.

Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - отрицательные

Входные данные : с клвиатуры вводится 4 целых числа

Выходные данные : необходимо вывести на экран преобразованные числа в той же последовательности

Пример входных и выходных данных

Входные данные

3 5 - 2 - 4

Выходные данные

9 25 16 256

C + +.

Аня2002Петрова 4 мар. 2022 г., 02:14:39 | 1 - 4 классы

ДЛЯ ПИТОНАДано натуральное число N?

ДЛЯ ПИТОНА

Дано натуральное число N.

Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае.

Операцией возведения в степень пользоваться нельзя!

Входные данные

Вводится натуральное число.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

3

выходные данные

NO

входные данные

8

выходные данные

YES.

Tem04ka 12 апр. 2022 г., 15:21:31 | 5 - 9 классы

Задание решать на PYTHONВычислите сумму данных 100 натуральных чисел?

Задание решать на PYTHON

Вычислите сумму данных 100 натуральных чисел.

Входные данные

Вводятся 100 чисел, сумму которых необходимо посчитать.

Выходные данные

Программа должна вывести единственное число - полученную сумму.

GooDStaf 10 мар. 2022 г., 07:14:29 | 5 - 9 классы

Дано целое число n?

Дано целое число n.

Выведите следующее за ним четное число.

Входные данные

Вводится целое положительное число, не превышающее 1000.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

7

выходные данные

8

входные данные

8

выходные данные

10.

Margo196 15 февр. 2022 г., 10:52:22 | 5 - 9 классы

Программа на C + +Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Программа на C + +

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Входные данные

Входная строка содержит два целых числа.

Выходные данные

Программа должна вывести произведение введённых чисел.

Примеры

входные данные

6 12

выходные данные

72

входные данные - 7 15

выходные данные - 105.

Аьчндhfgkg 19 февр. 2022 г., 02:43:38 | 5 - 9 классы

Программа в C + +Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

Программа в C + +

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

Входные данные

Входная строка содержит единственное число – требуемое количество чисел N .

Выходные данные

Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами.

Примеры

входные данные

5

выходные данные

2 4 6 8 10.

Ryabikina81 18 янв. 2022 г., 02:11:11 | 5 - 9 классы

Программа на c + +Напишите программу, которая вводит натуральные числа a и b , и выводит квадраты натуральных чисел в диапазоне [ a , b ] ?

Программа на c + +

Напишите программу, которая вводит натуральные числа a и b , и выводит квадраты натуральных чисел в диапазоне [ a , b ] .

Входные данные

Входная строка содержит два натуральных числа – значения a и b .

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести квадраты чисел в диапазоне [ a , b ] и показать способ вычисления.

Например, если ввести 4 и 5, программа должна вывести

4 * 4 = 16

5 * 5 = 25.

Sergo2001 2 мар. 2022 г., 16:36:34 | 5 - 9 классы

Дано несколько чисел?

Дано несколько чисел.

Вычислите их сумму.

Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

Какое наименьшее число переменных нужно для решения этой задачи?

Входные данные

В первой строке вводится натуральное число N - количество чисел.

В следующих N строках вводится по одному целому числу.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

2

235

56

выходные данные

291

решение для паскаля.

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Kristinaplotni2 28 мар. 2022 г., 08:53:01 | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

На этой странице сайта размещен вопрос Входной замок Лисы Алисы работает следующим образом : если введено натуральное число, которое меньше 100 или больше 999 - на дисплее устройства появляется надпись False если у введённого числа сумма ? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.