Решить задачу в Паскале авс?

Информатика | 10 - 11 классы

Решить задачу в Паскале авс.

Пользователь вводит натуральное число.

Программа находит первое следующее за ним число с той же суммой цифр.

Ответить на вопрос
Ответы (1)
Valera595 4 апр. 2020 г., 13:51:32

Var a, b, s1, s2 : integer ;

function sum(n : integer) : integer ;

var s : integer ;

begin

s : = 0 ;

while n< ; > ; 0 do

begin

s : = s + n mod 10 ;

n : = n div 10 ;

end ;

sum : = s ;

end ;

begin

write('a = ') ;

readln(a) ;

s1 : = sum(a) ;

writeln(' s1 = ', s1) ;

b : = a ;

while s1< ; > ; s2 do

begin

b : = b + 1 ;

s2 : = sum(b) ;

end ;

writeln('b = ', b, ' s2 = ', s2) ;

end.

Пример :

a = 153 s1 = 9

b = 162 s2 = 9.

Svetka9 10 апр. 2020 г., 08:05:20 | 5 - 9 классы

Написать программу на Pascal Пользователь вводит число?

Написать программу на Pascal Пользователь вводит число.

Сколько последовательно расположенных натуральных чисел необходимо, что бы их произведение стало больше введенного пользователем числа.

Соник123654 26 февр. 2020 г., 13:00:10 | 5 - 9 классы

Программа Паскаль Пользователь вводит число?

Программа Паскаль Пользователь вводит число.

Сколько раз из цифр числа можно составить число 23 - столько раз вывести "выведено число 23".

Avdieienko1976 20 авг. 2020 г., 21:00:43 | 5 - 9 классы

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными (паскаль авс).

Molokodj3 29 дек. 2020 г., 22:39:45 | 5 - 9 классы

Составить алгоритм и программу, определяющую последнюю цифру числа a (в n степени) , где натуральные числа n, а вводятся?

Составить алгоритм и программу, определяющую последнюю цифру числа a (в n степени) , где натуральные числа n, а вводятся.

Ответ на паскале.

CamKo 22 мар. 2020 г., 10:05:22 | 5 - 9 классы

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа?

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!

Supergoodgirl93 9 июл. 2020 г., 23:31:58 | 5 - 9 классы

Составьте программу решения следующей задачи : С клавиатуры вводится двузначное число a?

Составьте программу решения следующей задачи : С клавиатуры вводится двузначное число a.

Найти сумму его цифр.

Kirilacs 21 янв. 2020 г., 18:21:52 | 10 - 11 классы

1. пользователь вводит натуральное число?

1. пользователь вводит натуральное число.

Определить среднее арифметическое цифр этого числа.

2. пользователь вводит натуральное число N.

Найти сумму всех натуральных чисел от 1 до N.

Eqorqeiko 11 мар. 2020 г., 07:55:46 | 10 - 11 классы

Код программы в PASCAL, СРОЧНО?

Код программы в PASCAL, СРОЧНО!

Условие : Вводятся 3 натуральных числа.

Найти сумму цифр каждого из них (создать функцию для нахождения суммы цифр произвольного натурального числа).

Kenzzo 24 нояб. 2020 г., 17:16:23 | 5 - 9 классы

Написать программу которая считает количество цифр в числе и их сумму?

Написать программу которая считает количество цифр в числе и их сумму.

Паскаль.

Число вводится с клавиатуры.

Катюшка170212 27 сент. 2020 г., 04:27:12 | 5 - 9 классы

Написать программу в паскале?

Написать программу в паскале.

Дано натуральное число Х.

Найти сумму квадратов чётных цифр в числе.

Вы открыли страницу вопроса Решить задачу в Паскале авс?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.