Только начал изучать С + + и мне нужно написать решение задачи, где нужно узнать :является ли меньшее число делителем большего как это дополнить в мой код?

Информатика | студенческий

Только начал изучать С + + и мне нужно написать решение задачи, где нужно узнать :

является ли меньшее число делителем большего как это дополнить в мой код?

#include

using namespace std ;

int a, b ;

int main ()

{

setlocale (LC_ALL, "Russian") ;

cout«"a = " ;

cin»a ;

cout«"b = " ;

cin»b ;

if (a > b) {

cout « "a > b" « endl ;

} else if (a < b) {

cout « "b > a" « endl ;

}

return 0 ;

}.

Ответить на вопрос
Ответы (1)
Sasha7252y 3 янв. 2022 г., 03:49:51

#include using namespace std ;

int main(){ setlocale(LC_ALL, "rus") ; int a, b ; couta ; coutb ; if (a.

Gadi 19 янв. 2022 г., 06:10:21 | студенческий

Помогите сделать трассировочную таблицу?

Помогите сделать трассировочную таблицу.

Условие : Подсчитать, сколько букв надо исправить в слове x, чтобы получилось слово y (x, y - слова одинаковой длины).

#include

int main(int argc, char * argv[]){

char mama[4], papa[4] ;

gets[mama] ;

gets[papa] ;

int count = 0 ; i = 0 ;

for(i = 0 ; mama[i] !

= 0 ; i + + )

if (mama [i] !

= papa[i])

count + + ;

printf("%d", count) ;

return 0 ;

}.

Krasnov 6 мар. 2022 г., 12:23:59 | 10 - 11 классы

Где ошибка в коде С + + ?

Где ошибка в коде С + + ?

Помогите, пжл.

Задание : Динамически создать массив размера n (n вводится с клавиатуры) и заполнить его случайными числами из диапазона [a, b] (a, b вводятся с клавиатуры).

Заполнение массива реализовать с помощью функции.

Вычислить количество элементов массива, лежащих в диапазоне от number_А до number_В (number_А и number_В вводятся с клавиатуры), с помощью функции.

#include

#pragma hdrstop

#include

#include

#include

using namespace std ;

void z(int * m, int n, int a, int b)

{

srand(time(NULL)) ;

for(int i = 0 ; i< n ; i + + )m[i] = a + rand()%(b - a + 1) ; }

int k(int * m, int n, int a, int b)

{

int s = 0 ; for(int i = 0 ; i< n ; i + + )s + = m[i]> = a&&m[i]>b ;

z(m, n, a, b) ;

for(int i = 0 ; i< n ; i + + )cout< cout>nb ; cout.

Глф 17 февр. 2022 г., 07:33:23 | 10 - 11 классы

Друзья?

Друзья!

Требуется Ваша помощь!

Составляю алгоритм по задаче, но не знаю, как грамотно объяснить : "На сковородку одновременно можно положить k котлет.

Каждую котлету нужно с каждой стороны обжаривать m минут непрерывно.

За какое наименьшее время удастся поджарить с обеих сторон n котлет?

Вводятся 3 числа : k, m и n.

Вывести время, за которое все котлеты будут обжарены.

" Чтобы Вы не думали, что мне только решение нужно, прилагаю свой код, который неидеален.

Помогите, пожалуйста, довести задачу до конца.

K = int(input())

m = int(input())

n = int(input())

if n>k : if n%k>0 : print (n / / k * m * 2 + m * 2) if n%k = = 0 : print (n / / k * m * 2)

if n.

DvoeshNIK2002klass 2 апр. 2022 г., 19:01:36 | 5 - 9 классы

Помогите пожалуйста#includeusing namespace std ;int main() { int a, b, c, d ; cin >> d ; a = d / 100 ; b = d % 100 % 100 ; cout?

Помогите пожалуйста

#include

using namespace std ;

int main() { int a, b, c, d ; cin >> d ; a = d / 100 ; b = d % 100 % 100 ; cout.

Dimasalkah 21 апр. 2022 г., 00:42:40 | 10 - 11 классы

Нужно перевести cout / cin в printf / scanf - C + +#include #include using namespace std ; int main() {float a_1, a_2, a_3, x ;cout a_1 >> a_2 >> a_3 ; cout?

Нужно перевести cout / cin в printf / scanf - C + +

#include #include using namespace std ; int main() { float a_1, a_2, a_3, x ; cout a_1 >> a_2 >> a_3 ; cout.

Perviz 1 янв. 2022 г., 00:52:26 | 10 - 11 классы

C + +Написать программу, используя два раза while, которая выдает следующее : * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *Я написал, но не работает?

C + +

Написать программу, используя два раза while, которая выдает следующее : * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Я написал, но не работает.

Может найдете ошибку в моей?

(ошибка не в синтаксисе, а в выдаче результата)

#include

int main()

{ int verticalDown = 0 ; int horizontalRight = 0 ; int countColumns = 1 ; while(verticalDown.

HelpHero 25 апр. 2022 г., 19:52:56 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Определить :

а) какая из его цифр больше : первая или вторая ;

мой код :

int a = 32 ; if (a%10) = = (a / 10) ; { System.

Out. println("цифры одинаковы") ; }

Что тут не так?

Ошибка (Jillegal start of expression

incompatible types : int cannot be converted to boolean)

программа JAVA.

Капелькаяда1 18 апр. 2022 г., 04:02:49 | студенческий

Дано целое число K?

Дано целое число K.

Найти произведение цифр числа К.

Язык - С + + .

Нужен код внутри int main().

Samira58 28 мар. 2022 г., 13:33:09 | студенческий

Помогите, пожалуйста?

Помогите, пожалуйста!

Нужно отсортировать четные строки в прямом порядке, нечетные в обратном.

Запутался, не могу найти ошибку, в массиве все строки подряд.

Вот код который я написал :

#include "stdafx.

H"

#include

#include

using namespace std ;

int main()

{ setlocale(LC_ALL, "Russian") ; cout > N ; int * * mass = new int * [N] ; for (int i = 0 ; i < 10 ; i + + ) { mass[i] = new int[N] ; } for (int i = 0 ; i < 10 ; i + + ) { for (int j = 0 ; j < 10 ; j + + ) { mass[i][j] = - (N) + rand() % ((N) * 2) ; cout.

Если вам необходимо получить ответ на вопрос Только начал изучать С + + и мне нужно написать решение задачи, где нужно узнать :является ли меньшее число делителем большего как это дополнить в мой код?, относящийся к уровню подготовки учащихся студенческий, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.