Помогите сделать трассировочную таблицу?

Информатика | студенческий

Помогите сделать трассировочную таблицу.

Условие : Подсчитать, сколько букв надо исправить в слове x, чтобы получилось слово y (x, y - слова одинаковой длины).

#include

int main(int argc, char * argv[]){

char mama[4], papa[4] ;

gets[mama] ;

gets[papa] ;

int count = 0 ; i = 0 ;

for(i = 0 ; mama[i] !

= 0 ; i + + )

if (mama [i] !

= papa[i])

count + + ;

printf("%d", count) ;

return 0 ;

}.

Ответить на вопрос
Ответы (1)
R516brm 19 янв. 2022 г., 06:10:24

Таблица - в прилагаемом файле.

Ksubum 6 февр. 2022 г., 13:40:46 | 5 - 9 классы

Помогите, пожалуйста, найти ошибку в программе?

Помогите, пожалуйста, найти ошибку в программе.

Не все тесты проходит на сайте.

Текст задачи :

Текст на английском языке записан в массиве a[1.

1000] of char.

Помимо английских букв, в нем могут встречаться пробелы и знаки препинания.

В массиве b['A'.

'Z'] of integer получите сведения о том, сколько каких букв встречается в этом тексте.

При подсчете строчные и прописные буквы не различать.

Входные данные

На вход программе сначала подается значение n1000 — количество букв в тексте.

В следующей строке входных данных расположены сами буквы (без разделителей).

Выходные данные

Выдайте 26 чисел — значения элементов массива b.

Сама программа :

#include

using namespace std ;

int main()

{ int b[26], N, i, k ; char a[1000], m ; cin>>N ; for(i = 0 ; i { cin>>a[i] ; a[i] = toupper(a[i]) ; } for(m = 'A' ; m.

Krasnov 6 мар. 2022 г., 12:23:59 | 10 - 11 классы

Где ошибка в коде С + + ?

Где ошибка в коде С + + ?

Помогите, пжл.

Задание : Динамически создать массив размера n (n вводится с клавиатуры) и заполнить его случайными числами из диапазона [a, b] (a, b вводятся с клавиатуры).

Заполнение массива реализовать с помощью функции.

Вычислить количество элементов массива, лежащих в диапазоне от number_А до number_В (number_А и number_В вводятся с клавиатуры), с помощью функции.

#include

#pragma hdrstop

#include

#include

#include

using namespace std ;

void z(int * m, int n, int a, int b)

{

srand(time(NULL)) ;

for(int i = 0 ; i< n ; i + + )m[i] = a + rand()%(b - a + 1) ; }

int k(int * m, int n, int a, int b)

{

int s = 0 ; for(int i = 0 ; i< n ; i + + )s + = m[i]> = a&&m[i]>b ;

z(m, n, a, b) ;

for(int i = 0 ; i< n ; i + + )cout< cout>nb ; cout.

Aid14aidana 3 янв. 2022 г., 03:49:47 | студенческий

Только начал изучать С + + и мне нужно написать решение задачи, где нужно узнать :является ли меньшее число делителем большего как это дополнить в мой код?

Только начал изучать С + + и мне нужно написать решение задачи, где нужно узнать :

является ли меньшее число делителем большего как это дополнить в мой код?

#include

using namespace std ;

int a, b ;

int main ()

{

setlocale (LC_ALL, "Russian") ;

cout«"a = " ;

cin»a ;

cout«"b = " ;

cin»b ;

if (a > b) {

cout « "a > b" « endl ;

} else if (a < b) {

cout « "b > a" « endl ;

}

return 0 ;

}.

DvoeshNIK2002klass 2 апр. 2022 г., 19:01:36 | 5 - 9 классы

Помогите пожалуйста#includeusing namespace std ;int main() { int a, b, c, d ; cin >> d ; a = d / 100 ; b = d % 100 % 100 ; cout?

Помогите пожалуйста

#include

using namespace std ;

int main() { int a, b, c, d ; cin >> d ; a = d / 100 ; b = d % 100 % 100 ; cout.

Anna004smail 4 мар. 2022 г., 02:49:44 | 5 - 9 классы

C + + ?

C + + .

Помогите разобраться с программой!

Дайте комментарий к каждой строке и команде к ней , опишите принцип действия.

Int comb(vector sort) { int n = 0 ; / / количество перестановок double fakt = 1.

2473309 ; / / фактор уменьшения int step = sort.

Size() - 1 ; while (step > = 1) { for (int i = 0 ; i + step < sort.

Size() ; + + i) { if (sort[i] > sort[i + step]) { swap(sort[i], sort[i + step]) ; n + + ; } } step / = fakt ; } / / сортировка пузырьком for (int i = 0 ; i < sort.

Size() - 1 ; i + + ) { bool swapped = false ; for (int j = 0 ; j < sort.

Size() - i - 1 ; j + + ) { if (sort[j] > sort[j + 1]) { swap(sort[j], sort[j + 1]) ; swapped = true ; + + n ; } } if (!

Swapped) break ; } return n ; }.

Dimasalkah 21 апр. 2022 г., 00:42:40 | 10 - 11 классы

Нужно перевести cout / cin в printf / scanf - C + +#include #include using namespace std ; int main() {float a_1, a_2, a_3, x ;cout a_1 >> a_2 >> a_3 ; cout?

Нужно перевести cout / cin в printf / scanf - C + +

#include #include using namespace std ; int main() { float a_1, a_2, a_3, x ; cout a_1 >> a_2 >> a_3 ; cout.

Perviz 1 янв. 2022 г., 00:52:26 | 10 - 11 классы

C + +Написать программу, используя два раза while, которая выдает следующее : * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *Я написал, но не работает?

C + +

Написать программу, используя два раза while, которая выдает следующее : * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Я написал, но не работает.

Может найдете ошибку в моей?

(ошибка не в синтаксисе, а в выдаче результата)

#include

int main()

{ int verticalDown = 0 ; int horizontalRight = 0 ; int countColumns = 1 ; while(verticalDown.

HelpHero 25 апр. 2022 г., 19:52:56 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Определить :

а) какая из его цифр больше : первая или вторая ;

мой код :

int a = 32 ; if (a%10) = = (a / 10) ; { System.

Out. println("цифры одинаковы") ; }

Что тут не так?

Ошибка (Jillegal start of expression

incompatible types : int cannot be converted to boolean)

программа JAVA.

Samira58 28 мар. 2022 г., 13:33:09 | студенческий

Помогите, пожалуйста?

Помогите, пожалуйста!

Нужно отсортировать четные строки в прямом порядке, нечетные в обратном.

Запутался, не могу найти ошибку, в массиве все строки подряд.

Вот код который я написал :

#include "stdafx.

H"

#include

#include

using namespace std ;

int main()

{ setlocale(LC_ALL, "Russian") ; cout > N ; int * * mass = new int * [N] ; for (int i = 0 ; i < 10 ; i + + ) { mass[i] = new int[N] ; } for (int i = 0 ; i < 10 ; i + + ) { for (int j = 0 ; j < 10 ; j + + ) { mass[i][j] = - (N) + rand() % ((N) * 2) ; cout.

Вы открыли страницу вопроса Помогите сделать трассировочную таблицу?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся студенческий. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.