На экран вводится два пятизначных числа?

Информатика | 5 - 9 классы

На экран вводится два пятизначных числа.

Найти среднее арифметическое всех четных цифр в наименьшем из чисел.

Ответить на вопрос
Ответы (1)
Ника162 11 февр. 2022 г., 10:49:09

Var a, b, n : integer ; sr : real ;

begin sr : = 0 ; n : = 0 ; read(a, b) ; if(a > b) then a : = b ; while a > 0 do begin if((a mod 10) mod 2 = 0) then begin sr : = sr + a mod 10 ; n : = n + 1 ; end ; a : = a div 10 ; end ; write(sr / n) ;

end.

Natalie24 9 янв. 2022 г., 05:21:47 | 5 - 9 классы

Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое?

Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое.

(КуМир).

Aliona10 21 янв. 2022 г., 19:20:14 | 5 - 9 классы

Вводятся целые числа A и B?

Вводятся целые числа A и B.

Выведите среднее арифметическое всех неотрицательных чисел от A до B

Нужно составить программу в паскале.

Yunalichka 14 янв. 2022 г., 00:28:40 | 5 - 9 классы

Напишите программу на языке Паскаль?

Напишите программу на языке Паскаль!

На экран вводится два пятизначных числа.

Найти среднее арифметическое всех четных цифр в наименьшем числе.

DudikGO 5 янв. 2022 г., 01:28:25 | 10 - 11 классы

Дано число А>0?

Дано число А>0.

Необходимо вводить числа, пока сумма введённых чисел по модулю меньше А.

Найти среднее арифметическое введённых чисел.

Составить алгоритм (блок - схему) решения задачи.

Привести тестовый пример.

Rjkmxfr2015 6 янв. 2022 г., 19:49:32 | 5 - 9 классы

1)Вычислить и вывести на экран сумму тех целых чисел из промежутка от 1 до K, которые не делятся на 5 без остатка?

1)Вычислить и вывести на экран сумму тех целых чисел из промежутка от 1 до K, которые не делятся на 5 без остатка.

K вводится с клавиатуры.

2)С клавиатуры вводится целое положительное число.

Определить, сколько в числе цифр.

Ivanovzenit200 9 апр. 2022 г., 18:27:39 | 5 - 9 классы

Определить, является ли среднее арифметическое четных чисел из заданного одномерного массива[ - 10?

Определить, является ли среднее арифметическое четных чисел из заданного одномерного массива[ - 10.

20] числом большим 10

Составьте блок схему и программу, пожалуйста.

Vitaymba200 9 мар. 2022 г., 01:48:45 | студенческий

Написать программу, которая вводит с клавиатуры последовательность из 5 - ти вещественных чисел ипосле ввода каждого числа выводит среднее арифметическое полученной части последовательностиНа паскале ?

Написать программу, которая вводит с клавиатуры последовательность из 5 - ти вещественных чисел ипосле ввода каждого числа выводит среднее арифметическое полученной части последовательности

На паскале (через for to do).

AliceTzar33 14 мая 2022 г., 17:29:25 | 10 - 11 классы

Помогите пожалуйста) информатика PascalABC1)Составьте программу , которая выводит на экран все двухзначные числа, сумма цифр которых делится на 7?

Помогите пожалуйста) информатика PascalABC

1)Составьте программу , которая выводит на экран все двухзначные числа, сумма цифр которых делится на 7.

2)Составьте программу : с клавиатуры вводятся два натуральных числа x и y.

Вывести на экран все четные числа на отрезке [x, y] и подсчитать сумму этих чисел.

Максим146464647447 6 апр. 2022 г., 04:28:08 | 10 - 11 классы

В паскаль АВСЗаполнить массив А[1?

В паскаль АВС

Заполнить массив А[1.

8] числами, вводимыми с клавиатуры.

Найти среднее арифметическое четных элементов.

Ryagin 8 мая 2022 г., 13:35:52 | 5 - 9 классы

Помогите, пожалуйста : )1)Вывести на экран натуральные не четные числа от 50 до 40?

Помогите, пожалуйста : )

1)Вывести на экран натуральные не четные числа от 50 до 40.

2)Найти произведение последовательных натуральных чисел от 7 до 12.

На этой странице находится вопрос На экран вводится два пятизначных числа?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.