Надо решить то что на фото и то что я сейчас напишу в скобках , и это всё надо написать в языке паскаль " сумма цифр четырёхзначного числа "?

Информатика | 5 - 9 классы

Надо решить то что на фото и то что я сейчас напишу в скобках , и это всё надо написать в языке паскаль " сумма цифр четырёхзначного числа ".

Ответить на вопрос
Ответы (1)
Aishamataeva 5 янв. 2022 г., 18:48:13

Если сумма цифр это всё, то вот.

Работает не только для 4 - значных чисел.

Var a, b, sum : integer ;

begin readln(a) ; while a > 0 do begin b : = a mod 10 ; sum : = sum + b ; a : = a div 10 ; end ; writeln(sum) ;

end.

Poltoratskayan 22 янв. 2022 г., 23:28:30 | 10 - 11 классы

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4?

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4.

Паскаль.

Nikatulaidan157 22 янв. 2022 г., 21:40:54 | 5 - 9 классы

(язык паскаль)вычислите сумму чисел вводимых с клавиатуры, окончание ввода число 0?

(язык паскаль)

вычислите сумму чисел вводимых с клавиатуры, окончание ввода число 0.

Maxkorzhnev 7 янв. 2022 г., 06:32:51 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО1) с клавиатуры вводятся два целых числа А и В?

ПОМОГИТЕ СРОЧНО

1) с клавиатуры вводятся два целых числа А и В.

Написать программу, которая выводит число 1, если числа равны, и число 0 в противно случае.

2) написать программу, в которой подсчитывается сумма только положительных чисел из трёх данных.

3) определить принадлежит ли точка с координатами (x, y) первой четверти.

Всё надо в паскале написать.

Гтарист5 24 янв. 2022 г., 17:01:26 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найти минимальную цифру и приписать её в начало и в конец числа(написать программу в паскале).

Kochievaanya 27 янв. 2022 г., 05:25:20 | 1 - 4 классы

Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на языке паскаль)?

Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на языке паскаль).

Yunalichka 14 янв. 2022 г., 00:28:40 | 5 - 9 классы

Напишите программу на языке Паскаль?

Напишите программу на языке Паскаль!

На экран вводится два пятизначных числа.

Найти среднее арифметическое всех четных цифр в наименьшем числе.

Aleksandrmakaro 20 янв. 2022 г., 22:37:13 | 10 - 11 классы

Ребят, срочно нужна помощь?

Ребят, срочно нужна помощь.

Надо написать программу га языке паскаль которая

определяет одинаковые ли цифры стоят в начале и конце числа N.

KasenkovaSasha 30 янв. 2022 г., 16:19:22 | 5 - 9 классы

Составьте программу, печатающую значение TRUE, если указанное высказывание является истинным, и FALSE в противном случае : сумма двух первых цифр заданного четырехзначного числа равна сумме двух его п?

Составьте программу, печатающую значение TRUE, если указанное высказывание является истинным, и FALSE в противном случае : сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр

В паскале.

Dianamitul 15 янв. 2022 г., 01:37:01 | 5 - 9 классы

Написать программу о нахождении двухзначного числа А?

Написать программу о нахождении двухзначного числа А.

Найти сумму и произведение цифр данного числа, а также вывести новое число, в котором цифры числа А поменялись местами.

Shonokakeanfis0ce 2 февр. 2022 г., 19:16:39 | 1 - 4 классы

Язык паскаль с клав ввод 2 числа x и y не равные друг другу?

Язык паскаль с клав ввод 2 числа x и y не равные друг другу.

Меньший из этих двух числ заменить их пол суммы а большие их удвоен произвед.

На этой странице сайта размещен вопрос Надо решить то что на фото и то что я сейчас напишу в скобках , и это всё надо написать в языке паскаль " сумма цифр четырёхзначного числа "? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.