Помогите, надо записать эту задачу в с + + ?

Информатика | 10 - 11 классы

Помогите, надо записать эту задачу в с + + .

В кафе мороженое продают по три шарика и по пять шариков.

Можно ли купить ровно k шариков мороженого?

Входные данные

Вводится число k (целое, положительное)

Выходные данные

Программа должна вывести слово YES, если при таких условиях можно набрать ровно k шариков (не больше и не меньше), в противном случае - вывести NO.

Примеры

входные данные

3

выходные данные

YES

входные данные

1

выходные данные

NO.

Ответить на вопрос
Ответы (1)
Masja4 30 мар. 2022 г., 16:38:38

Program znania ;

Var

k : integer ;

begin

read(k) ;

if (k = 3) or (k = 5) or (k = 6) or (k>7) then writeln('YES') else writeln ('NO') ;

End.

Надеюсь что правильно.

Удачи!

: ) : ).

Kleo901 4 янв. 2022 г., 20:25:54 | 5 - 9 классы

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область?

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.

Входные данные

Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x - координата, затем – y - координата).

Выходные данные

Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала.

Примеры

входные данные

0.

5 0. 5

выходные данные

YES

входные данные - 0.

5 - 0.

5

выходные данные

NO.

Yolchuevanar 7 янв. 2022 г., 15:24:04 | 5 - 9 классы

Дано четыре целых числа?

Дано четыре целых числа.

Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - отрицательные

Входные данные : с клвиатуры вводится 4 целых числа

Выходные данные : необходимо вывести на экран преобразованные числа в той же последовательности

Пример входных и выходных данных

Входные данные

3 5 - 2 - 4

Выходные данные

9 25 16 256

C + +.

Аня2002Петрова 4 мар. 2022 г., 02:14:39 | 1 - 4 классы

ДЛЯ ПИТОНАДано натуральное число N?

ДЛЯ ПИТОНА

Дано натуральное число N.

Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае.

Операцией возведения в степень пользоваться нельзя!

Входные данные

Вводится натуральное число.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

3

выходные данные

NO

входные данные

8

выходные данные

YES.

Death20 2 мар. 2022 г., 05:43:09 | 5 - 9 классы

РЕБЯТ ЗАДАНИЕ НУЖНО РЕШИТЬ ЧЕРЕЗ PYTHONДаны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет (все координаты отличны от нуля)?

РЕБЯТ ЗАДАНИЕ НУЖНО РЕШИТЬ ЧЕРЕЗ PYTHON

Даны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет (все координаты отличны от нуля).

Входные данные

Вводятся 4 числа : координаты первой точки (x1, y1) и координаты второй точки (x2, y2).

Выходные данные

Программа должна вывести слово YES, если точки находятся в одной координатной четверти, в противном случае вывести слово NO.

Примеры

Входные данные

3

3

5

1

Выходные данные

YES.

Tatyanashmi 18 апр. 2022 г., 16:10:09 | 5 - 9 классы

ЭТО ЗАДАНИЕ НАДО РЕШИТЬ НА PYTHONПодсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел?

ЭТО ЗАДАНИЕ НАДО РЕШИТЬ НА PYTHON

Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел.

Входные данные

Вводится число N, а затем N чисел.

Выходные данные

Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.

Примеры

Входные данные

5

28

0

0

0

0

Выходные данные

4

1

0.

Tem04ka 12 апр. 2022 г., 15:21:31 | 5 - 9 классы

Задание решать на PYTHONВычислите сумму данных 100 натуральных чисел?

Задание решать на PYTHON

Вычислите сумму данных 100 натуральных чисел.

Входные данные

Вводятся 100 чисел, сумму которых необходимо посчитать.

Выходные данные

Программа должна вывести единственное число - полученную сумму.

GooDStaf 10 мар. 2022 г., 07:14:29 | 5 - 9 классы

Дано целое число n?

Дано целое число n.

Выведите следующее за ним четное число.

Входные данные

Вводится целое положительное число, не превышающее 1000.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

7

выходные данные

8

входные данные

8

выходные данные

10.

Margo196 15 февр. 2022 г., 10:52:22 | 5 - 9 классы

Программа на C + +Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Программа на C + +

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Входные данные

Входная строка содержит два целых числа.

Выходные данные

Программа должна вывести произведение введённых чисел.

Примеры

входные данные

6 12

выходные данные

72

входные данные - 7 15

выходные данные - 105.

Аьчндhfgkg 19 февр. 2022 г., 02:43:38 | 5 - 9 классы

Программа в C + +Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

Программа в C + +

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

Входные данные

Входная строка содержит единственное число – требуемое количество чисел N .

Выходные данные

Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами.

Примеры

входные данные

5

выходные данные

2 4 6 8 10.

Мария1155 3 февр. 2022 г., 11:18:35 | 5 - 9 классы

Напишите программу на PythonВ одной компьютерной игре игрок выставляет в линию шарики разных цветов?

Напишите программу на Python

В одной компьютерной игре игрок выставляет в линию шарики разных цветов.

Когда образуется непрерывная цепочка из трех и более шариков одного цвета, она удаляется из линии.

Все шарики при этом сдвигаются друг к другу, и ситуация может повториться.

Напишите программу, которая по данной ситуации определяет, сколько шариков будет сейчас "уничтожено".

Естественно, непрерывных цепочек из трех и более одноцветных шаров в начальный момент может быть не более одной.

Входные данные

Сначала вводится количество шариков в цепочке (не более 1000) и цвета шариков (от 0 до 9, каждому цвету соответствует свое целое число).

Выходные данные

Требуется вывести количество шариков, которое будет "уничтожено".

Примеры

входные данные

5 1 3 3 3 2

выходные данные

3

входные данные

12 1 1 2 1 2 2 2 1 1 2 2 1

выходные данные

12

Только, пожалуйста, без очень сложного решения на уровне университета!

Вы перешли к вопросу Помогите, надо записать эту задачу в с + + ?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.