СРОЧНО?

Информатика | 10 - 11 классы

СРОЧНО!

Пожалуйста, помогите решить задачу в Паскале :

Задать одномерный массив из 10 чисел, которые получены случайным образом.

Удалить из массива последний нечетный элемент, а перед 3 элементом вставить 100.

Ответить на вопрос
Ответы (1)
SvetlanaPetrova 16 дек. 2020 г., 11:10:34

Const n = 10 ;

var a : array[1.

N + 1] of integer ;

i, j, f : integer ;

begin

Randomize ;

for i : = 1 to n do begin

a[i] : = random(51) ;

write(a[i] : 4) ;

end ;

writeln ;

f : = 1 ;

j : = n ;

while (j>0)and(a[j] mod 2 = 0) do dec(j) ;

if j>0 then

begin

for i : = j to n - 1 do a[i] : = a[i + 1] ;

a[n] : = 0 ;

f : = 0 ;

end ;

for i : = n + f downto 4 do a[i] : = a[i - 1] ;

a[3] : = 100 ;

for i : = 1 to n + f do write(a[i] : 4) ;

writeln ;

end.

Пример : 40 23 16 16 29 8 2 45 8 34 40 23 100 16 16 29 8 2 8 34.

Lieraievsieiev 2 янв. 2020 г., 16:57:31 | 10 - 11 классы

Составить задачу в Паскале?

Составить задачу в Паскале.

Составьте программу вычисления суммы нечетных элементов одномерного массива А (Т).

Массив заполнить случайным образом.

Софигрэйт 26 июн. 2020 г., 05:32:27 | 5 - 9 классы

Задача?

Задача.

Подсчитать количество элементов одномерного массива, заданного генератором случайных чисел, больших среднеарифметического всех элементов массива.

Vanoli4 11 февр. 2020 г., 07:27:15 | 10 - 11 классы

Написать программу на С + + или паскаль?

Написать программу на С + + или паскаль.

Помогите пожалуйста!

В одномерном массиве, состоящем из n вещественных элементов, вычислить : - максимальный элемент массива ; - сумма элементов массива, расположенных до последнего положительного элемента .

Сжать массив, удалив из него все элементы, модуль которых находится в интервале (a.

B). Освободившийся в конце массива элементы заполнить нулями.

Kris169 13 июл. 2020 г., 16:37:52 | 10 - 11 классы

Помогите?

Помогите!

Срочно!

Составить программу.

Сформировать массив из 8 элементов, вывести количество отрицательных чисел.

Составить программу.

Создать массив из 10 элементов случайным образом, найти сумму нечетных чисел.

Писать на языке Паскаль, одномерный массив.

НастенькаПотапова 13 мар. 2020 г., 05:39:07 | 5 - 9 классы

ПОМОГИТЕ?

ПОМОГИТЕ!

Дан одномерный массив из 30 элементов массива задать случайным образом от - 30 до 30.

Посчититать количество элементов величина которых по модулю не превосходит 7.

Simonov991 13 апр. 2020 г., 08:22:36 | 10 - 11 классы

Вставить по одному элементу перед всеми элементами одномерного массива, кратными 5?

Вставить по одному элементу перед всеми элементами одномерного массива, кратными 5.

Массив сформировать через датчик случайных чисел.

Пифагор11 28 апр. 2020 г., 15:43:16 | 5 - 9 классы

ПОЖАЛУЙСТА, ПОМОГИТЕ, ПАСКАЛЬ, СРОЧНО?

ПОЖАЛУЙСТА, ПОМОГИТЕ, ПАСКАЛЬ, СРОЧНО!

1. Задать случайным образом 13 элементов числового массива – числа от 10 до 50.

Удалить из него : а) 10 - ый элемент ; б) минимальный элемент.

2. Из символьного массива, 7 элементов которого заданы с клавиатуры, удалить максимальный элемент.

Burat125 21 янв. 2020 г., 05:39:06 | 10 - 11 классы

Написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k - ый элемент массива?

Написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k - ый элемент массива.

Массив заполняется случайным образом числами от 0 до 50.

Andriymama 19 апр. 2020 г., 21:15:08 | 5 - 9 классы

Программу в паскале?

Программу в паскале.

Составить программу нахождения произведения положительных чисел одномерного массива В(10), элементы которого задаются датчиком случайных чисел.

Aishakov2000 5 мар. 2020 г., 16:27:29 | 5 - 9 классы

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент?

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент.

На этой странице находится вопрос СРОЧНО?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.