Вставить по одному элементу перед всеми элементами одномерного массива, кратными 5?

Информатика | 10 - 11 классы

Вставить по одному элементу перед всеми элементами одномерного массива, кратными 5.

Массив сформировать через датчик случайных чисел.

Ответить на вопрос
Ответы (1)
Лина1707 13 апр. 2020 г., 08:22:38

Программа вставляет перед элементом, кратным 5, элемент со значением 99 (чтобы его было видно среди прочих из диапазона [1.

50] )

const nm = 20 ;

var i, j, n, nn : integer ; a : array[1.

Nm] of integer ;

begin n : = nm div 2 ; nn : = n ; Randomize ; Writeln(' * * * Исходный массив * * * ') ; for i : = 1 to n do begin a[i] : = Random(50) + 1 ; { [1.

50] } Write(a[i] : 3) end ; for i : = n downto 1 do begin if a[i] mod 5 = 0 then begin nn : = nn + 1 ; for j : = nn downto i do a[j] : = a[j - 1] ; a[i] : = 99 end end ; Writeln(#13#10, ' * * * Массив - результат * * * ') ; for i : = 1 to nn do Write(a[i] : 3) ; Writeln

end.

* * * Исходный массив * * *

23 22 27 16 45 42 15 13 27 31 * * * Массив - результат * * *

23 22 27 16 99 45 42 99 15 13 27 31.

Katya1343 1 мая 2020 г., 10:22:52 | 10 - 11 классы

Сформировать с помощью датчика случайных чисел массива A[1?

Сформировать с помощью датчика случайных чисел массива A[1.

3, 1.

6], элементы которого находятся в промежутке от - 60 до 60.

Найти сумму элементов массива.

Вывести на экран массив в виде таблицы и сумму элементов массива.

Софигрэйт 26 июн. 2020 г., 05:32:27 | 5 - 9 классы

Задача?

Задача.

Подсчитать количество элементов одномерного массива, заданного генератором случайных чисел, больших среднеарифметического всех элементов массива.

Диана200356 19 янв. 2020 г., 19:36:48 | 5 - 9 классы

Одномерные массивы?

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов.

Найти сумму элементов массива, кратных данному числу К.

(паскаль).

Mama142356 12 мая 2020 г., 22:47:19 | 10 - 11 классы

Составить программу которая позволяет найти наименьший элемент случайно сформированного одномерного массива?

Составить программу которая позволяет найти наименьший элемент случайно сформированного одномерного массива.

Lubap1980 29 дек. 2020 г., 17:28:31 | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчика случайных чисел ?

Задайте массив из 10 элементов с помощью датчика случайных чисел .

Поменяйте знаки всем четным элементам массива на протиположные .

Выведите на экран исходный и полученный массивы.

Pinirob 14 дек. 2020 г., 08:01:44 | 10 - 11 классы

Сформировать одномерный массив из 10 целых элементов?

Сформировать одномерный массив из 10 целых элементов.

Найти сумму положительных и четных элементов массива.

VADIMIII18 28 июн. 2020 г., 17:01:30 | 10 - 11 классы

Сформировать и вывести на экран массив, элементы которого заданы датчиком случайных чисел на интервале [ - 15, 25]?

Сформировать и вывести на экран массив, элементы которого заданы датчиком случайных чисел на интервале [ - 15, 25].

SarymovaKaramelya 4 июл. 2020 г., 23:23:18 | 5 - 9 классы

Одномерные массивы?

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов.

Найти сумму элементов массива, кратных данному числу К.

Andriymama 19 апр. 2020 г., 21:15:08 | 5 - 9 классы

Программу в паскале?

Программу в паскале.

Составить программу нахождения произведения положительных чисел одномерного массива В(10), элементы которого задаются датчиком случайных чисел.

Aishakov2000 5 мар. 2020 г., 16:27:29 | 5 - 9 классы

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент?

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент.

Вы перешли к вопросу Вставить по одному элементу перед всеми элементами одномерного массива, кратными 5?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.